10 Replies Latest reply: Dec 3, 2008 3:30 PM by AJ
podsorcerer Level 1 Level 1 (5 points)
currently, in the advanced tab of my network settings, the netbios name is set to "macbook" which then appears in the finder sidebar under share. I want it to stop appearing there, so how i do i get rid of this?

Black Macbook Core2 Duo 2.4Ghz, Mac OS X (10.5.4)
  • AJ Level 5 Level 5 (7,075 points)
    NetBIOS is an MS networking thing...absent routers, domain controllers and such,
    it's how the computer identifies itself to others on the network.

    It's kind of like Apple does in the sharing control pane - the default computer share name is "<first user ID created>'s Computer"

    You can disable netBIOS over TCPIP using the Advanced... button in the active network connections control panel, TCP/IP option.
  • podsorcerer Level 1 Level 1 (5 points)
    actually, thats not where it is locate, it is located under the WINS tab, and there is nothing to delete there, just the name "macbook" greyed out, and then a message telling me that the name macbook is currently being used, so there isnt really a little box that i can check off. I was wondering if there was some other way to disable this?
  • nerowolfe Level 6 Level 6 (13,070 points)
    podsorcerer wrote:
    actually, thats not where it is locate, it is located under the WINS tab, and there is nothing to delete there, just the name "macbook" greyed out, and then a message telling me that the name macbook is currently being used, so there isnt really a little box that i can check off. I was wondering if there was some other way to disable this?


    It's not enabled, but just there should you decide to use it.
    On my computer if I click the name, even though it is grayed out, the name disappears and it looks as if I can type in something else.
    It's only the name NetBIOS would use if you connected to a PC.
    Most computers have a NetBIOS name.
  • podsorcerer Level 1 Level 1 (5 points)
    ok, so i dont really use it, but it shows up in my finder sidebar. There is a windows share that comes up that has the name macbook, so it can only be me. How do i get rid of this, i dont have any other network connections active except for airport. I also ran parallels for about a day, before getting rid of it because it never seemed to work. Some one suggested that was the problem, but i dont think so
  • nerowolfe Level 6 Level 6 (13,070 points)
    podsorcerer wrote:
    ok, so i dont really use it, but it shows up in my finder sidebar. There is a windows share that comes up that has the name macbook, so it can only be me. How do i get rid of this, i dont have any other network connections active except for airport. I also ran parallels for about a day, before getting rid of it because it never seemed to work. Some one suggested that was the problem, but i dont think so


    It is most likely from parallels which would use that NetBIOS name.
    You can simple "Poof!" the item from the Finder sidebar by dragging it onto the desktop.
    If it comes back it means that you did not remove all of parallels.
  • podsorcerer Level 1 Level 1 (5 points)
    you can't poof anything out of the shared section of the sidebar, i just tried, can't drag them any where. I've also determined that this problem is local to my computer. I did just go through all my "application support" folders in the library, because thats the only place i can think of that any remnant of parallels would be, and cleaned them out. I have found however, that on my parents iMac, all i can see in the shared section is the mac server for my computer the one that says "xxxxx's macbook" nothing that has the windows server symbol next to it and just says "macbook" what does that mean?
  • nerowolfe Level 6 Level 6 (13,070 points)
    podsorcerer wrote:
    you can't poof anything out of the shared section of the sidebar, i just tried, can't drag them any where.

    That's interesting. I thought all sidebar items were "poofable"
    You might use Finder to search for all files on your computer with that name. You have to add to the search items to include system files.
    I would start searching the files in the Preferences. It might be in a .plist.

    It may have gotten "stuck" if you removed the Windows OS before ejecting the share. Once the actual Network Link is gone, it may confuse the shares in Leopard, wherever they are hidden.
    I am sure it's in a file somewhere that simply needs to be edited. I did have this happen some time ago on a PC and had to edit a system file to remove a "retired" share that was still showing up.


    I've also determined that this problem is local to my computer. I did just go through all my "application support" folders in the library, because thats the only place i can think of that any remnant of parallels would be, and cleaned them out. I have found however, that on my parents iMac, all i can see in the shared section is the mac server for my computer the one that says "xxxxx's macbook" nothing that has the windows server symbol next to it and just says "macbook" what does that mean?

    Turn off all sharing on your computer, reboot your computer and your parents' computer and see if it still shows up on their computer.
  • AJ Level 5 Level 5 (7,075 points)
    podsorcerer wrote:
    actually, thats not where it is locate, it is located under the WINS tab, and there is nothing to delete there, just the name "macbook" greyed out, and then a message telling me that the name macbook is currently being used, so there isnt really a little box that i can check off. I was wondering if there was some other way to disable this?



    You can disable netBIOS over TCPIP using the Advanced... button in the active network connections control panel, TCP/IP option.

    Open the Active network connection, then go through as if you were going to change the IP address.
    Instead of editing the address, click advanced.
    There you should find the radio buttons and checkbox to use Netbios (or not)
  • podsorcerer Level 1 Level 1 (5 points)
    I dont see that button anywhere under leopard. Let me tell you what i am doing. i open up system prefs and click on network. there i select airport, and then go to edit the IP address by clicking the advanced button on that page. Then on the TCP/IP tab where i would normally enter the new IP address i wanted to use, you say that there is another advanced button? where exactly can i find it?
  • AJ Level 5 Level 5 (7,075 points)
    Ahhhh....thats part of the confusion

    I'm talking about the TCP/IP settings in Windows, not OS X.