8 Replies Latest reply: Feb 21, 2009 1:32 PM by chickidy
Majal_Guy Level 1 Level 1 (0 points)
This thing never happened to me before- I can't add any music to my itunes library.
I drag the files but just nothing happens. even an error doesn't appear.
Help?
  • varjak paw Level 10 Level 10 (169,830 points)
    What format are the tracks you're trying to add?
  • the_editor Level 1 Level 1 (0 points)
    I have this same problem. I am running XP, and I cannot import music into my iTunes library anymore. I was able to just a few weeks ago, and now I cannot. I am unable to drag files/folders into the library, I am unable to add them via the file menu, and I cannot double click on files to play them anymore. It is as if iTunes has permissions errors or something.

    I did notice that all of my folders are marked as read-only. I don't know if this is the problem. I cannot change that, however. I have admin rights, but when I click on the folder properties menu and uncheck the read-only attribute, it comes right back when I open the properties menu again. Effectively, I cannot change this. I don't know if this is the problem but it seems likely.
  • natster988 Level 1 Level 1 (0 points)
    i also have the same problem. I just got an iTouch on my birthday (Dec 1st) and henceforth got itunes so i could sync stuff. It's been working fine up til about an hour ago - where i can't add new songs (which are unprotected in mp3 format) to the library. The library doesn't even look like it's processing anything when I drag and drop the song onto the program or try it via the menu File > Add File to Library.

    In accordance to what the_editor suggested, I tried turning Read-Only off for all the files within the folder and the folder itself, but this had no effect on the way in which itunes was acting. I have also tried uninstalling and reinstalling the program - however this hasn't worked at all.

    So in other words...i'm also stuffed.
  • applcor54 Level 1 Level 1 (0 points)
    I've had this problem too, for quite a while actually. Even when I double click on the music file, it opens iTunes as if it were going to play it and add it to the library, but nothing happens. It's quite aggrivating. The only way I've found around it is to burn the songs that won't add to a disc using another program (i.e. Windows Media Player) then burn that CD to iTunes. A hassel but it works. I'd love to figure out an eaiser way though.
  • Mama Luigi Level 1 Level 1 (0 points)
    Sometiems this happens to me but usually not for long because when I put the songs on a second time it works.
  • Rasbanton Level 1 Level 1 (0 points)
    I had the same problem. It seems that a few of my mp3's had bad header tags or smth. Basically...when you drag the file into Itunes...Itunes cannot read the mp3. So what I did to resolve this was reconvert the bad mp3s using Adobe Audition. This worked for me.
  • foronepostonly Level 1 Level 1 (0 points)
    MP3 files may be corrupted, iTunes won't add/play corrupted files so you must repair them.

    Follow this tutorial to fix your files: http://trevinchow.com/blog/2008/09/17/fix-for-mp3-songs-not-playing-in-itunes/

    Experienced users just download "MP3 Validator" (MPIIIVal) at http://www.gromkov.com/faq/repair/mp3_validator.html and follow your instincts to fix your files.

    If by the time you try links are broken, I read another solution is to burn your files and rip them again, sounds logic since they will be recreated, but that's the long way.

    Initially I thought it was due to some license issue, maybe my files were protected, I was able to play them in other players (Windows media, winamp, etc.) but finally was able to add my Soulfly songs.

    APPLE.COM WEBMASTER: the process to create a user in this forum is tedious and not user friendly, I had a really bad experience trying to post this answers but I wanted to share this working fix, that's why you can find this.
  • chickidy Level 1 Level 1 (0 points)
    I had the same issue, it just started happening a week ago.
    its wierd, cause it had never happened before, i tried converting it again, even tho the format was already .mp3, i went on media-convert.com and converted it to the exact same thing actually, and it worked