6 Replies Latest reply: Aug 4, 2010 12:14 PM by rpduval
rpduval Level 1 Level 1 (50 points)
So all of a sudden my iMac refuses to recognize my external 500G USB Maxtor drive. This is the same drive I have been using for a year as my TM drive. I have tried the following:

Restart
Zap the PRAM
Repair permissions
Power management reset (unplug everything for 30sec - it was unplugged for like 30min)
Change USB ports (mouse and keyboard work in all ports, drive in none)
Change USB cables
Mount different USB drive (no joy - it will not mount any USB drive)

The USB drives that I tested all work and mount fine on my wife's iBook running 10.4 so I know it's the iMac with the issue.

Any thoughts?

24" 2.4GHz alumiMac 3/320, Mac OS X (10.5.5), WD 1TB FW800, Maxtor 250GB USB2, 20" Cinema display
  • Carolyn Samit Level 10 Level 10 (95,975 points)
    Disconnect the Maxtor drive. Go to Finder/Preferences and make sure all 4 buttons are checked where it says; Show These Items on the Desktop Reconnect the external drive and see if it mounts on the Desktop.

    If that doesn't work, delete these files; com.apple.finder.plist and com.apple.desktop.plist
    /Users/YourName/Library/Preferences. Drag those files from the Preferences folder to the Trash, empty the Trash and reboot. Connect the drive.. see if that worked.

    Also, run Disk Utility and Repair Disk Permissions. (Applications/Utilities). Launch DU, select MacintoshHD 10.x.x in the panel on the left, select FirstAid, then click Repair Permissions. Quit DU when it's finished and reboot.


    Carolyn
  • rpduval Level 1 Level 1 (50 points)
    Still no joy - thanks for the ideas though. I really have no clue why this would stop working all of a sudden with no changes in my computer. The only update I have run recently was for Safari.
  • Carolyn Samit Level 10 Level 10 (95,975 points)
    Have you tried booting from your restore disk and checking the internal drive for errors? If not... try that.

    And...
    Mac Help Index

    My USB device isn't working
    If a USB device isn't working, there are several things you can try:

    Make sure the device's cables are properly connected.
    Make sure you have installed the latest software for your device. Visit the manufacturer's website for any updates.
    If the device doesn't have a power cord and is plugged into another USB device that doesn't have a power cord, try plugging the device directly into your computer or to a USB device that does have a power cord. You might need to disconnect and reconnect the other device as well, if it has stopped responding.
    If the device is connected to a USB hub, make sure the device and the hub are the same speed. Connect USB 2.0 Hi-Speed devices to a USB 2.0 Hi-Speed hub, and connect USB 1.1 full-speed or low-speed devices to a USB 1.1 full-speed or low-speed hub.
    Disconnect all USB devices except the device you're testing, an Apple keyboard, and an Apple mouse. Make sure the device is connected directly to the computer, and that any hubs or extension cables are disconnected. If you can use the device now, the problem may be with one of the other USB devices or hubs you had connected to your computer. Try reconnecting them, one by one, to your computer. When you find the device that causes the problem, review that device's documentation for further troubleshooting steps.
    Open Apple System Profiler and click USB. If the device appears but does not work, the problem might be with the device. Review that device's documentation for further troubleshooting steps
    Switch the USB cable from the current USB port to another USB port. If you can use the device now, your computer might need to be repaired


    Carolyn

    Message was edited by: Carolyn Samit
  • rpduval Level 1 Level 1 (50 points)
    Can't imagine the internal drive has a problem, it works fine. My FW800 drive works fine. I can plug my mouse into any USB port and it works fine. The items I have plugged in to the USB ports on my 2nd display work fine (but the drive doesn't show up when plugged in there either) and the display works fine.

    Plus, this drive was working fine until a few days ago and still works fine plugged into a different computer.

    I was hoping for a miracle fix but I guess I'm off to the Genius bar. Glad I purchased the 3 year AC extension!

    Thanks for your help.
  • rpduval Level 1 Level 1 (50 points)
    To add another chapter: if I plug my camera in via the USB on my cinema display it works fine, iPhoto pops up and I can import my pics no prob. The hard drives still don't show up though. How odd is that?
  • rpduval Level 1 Level 1 (50 points)
    It was having the cinema display USB and FW connections plugged in. As soon as I unplugged them the puter worked mostly normal again.