Previous 1 2 Next 19 Replies Latest reply: Oct 10, 2009 12:01 PM by jmsuijkerbuijk
jmsuijkerbuijk Level 2 (160 points)
My 15" aluminium powerbook (1.67 GHz) has a serious power issue. Every unpredictable now and then, but at least once a day, the power drops, screen turns black and the machine is entirely unresponsive. At that time a light in the display release button starts to pulsate. The only way to get out of this situation is to remove the adapter and the battery and press the power button for five seconds. After that, the machine will boot again and behave for some time.
Does anyone have a similar experience? Better yet, does anyone know how to solve this? Thanks in advance!

Powerbook 15" 1.67 GHz (aluminium), Mac OS X (10.5.5), 2 GB RAM installed, 1 GB RAM recognized.
  • scottls22 Level 1 (0 points)
    Other than resetting the PMU I don't have any answers. Have you found out anything new about this.

    I am having a similar issue but not quite the same. Every time I attempt to put my ALPB to sleep it does shut off the screen and seem to go into sleep mode, but my latch button will NOT pulsate. (which only means it is successfully went into sleep mode) Then, when I try to wake it back up, it is totally unresponsive. I noticed when I press the shift lock button the LED indicator will come on, letting me know it is not actually asleep. So when I press the power button for 10 seconds and force it to shut off, I can then press it again and it will boot up but forgetting all unsaved work, which was why I was only putting it to sleep in the first place.

    That in itself was bad enough, but now it is even worse. Now whenever I try to turn it on from a cold stand-point, (like for the first time in the day, or after taking it out of my backpack and it had a chance to get cold) it now will not power up without cycling back and forth from forcing it to shut off and pressing the power button with only the shift lock indicator or the Number lock indicator coming on.

    I tried resetting my PMU but to no avail. Anyone have any suggestions?
  • Carissa Katz Level 1 (5 points)
    I am having almost the same issue. For a while my computer had been shutting down randomly when unplugged, even when the battery charge indicator said I had almost a full charge. At first, I could press the power key and restart it and it would run plugged in. Later, it would wait until the battery was completely charged up before it would restart, even when plugged in. Often when it came back on, I would get a message saying that my date and time were set to a date before 2001, etc., etc. When I go to system preferences to check and change the date, the date appears to be set correctly. Finally, it shut down while I was working on it and could not be restarted at all. The little light on the front at the monitor release was pulsating as if it was in sleep mode, but I could get it to turn off or on. I tried taking the battery out, pressing power for five seconds and restarting without the battery while plugged in. That worked, but with the battery in or with it out when the computer went to sleep, I could not restart it. I borrowed a friend's battery and the computer started up no problem, so I assume it is a dead battery, but I am wondering two things: is my pram battery(?) also dead? And could the problem have been caused by a faulty ac adapter delivering an irregular power supply to the battery. In other words, if I get a new battery and a new pram battery will this problem resurface because of a bad ac adapter? Is that possible?
  • jmsuijkerbuijk Level 2 (160 points)
    I have bought a new adapter only two weeks ago, but that didn't solve anything. The problem occurs when on operating on battery power as well as on net power, with or without battery installed.
    Could the problem be related to the video card? I'm not sure if it was always the case, but lately the problem arises shortly after the fans start working and in my set up the fans only start with intensive video use. Mind you, the problem is not reproducable.
    Resetting the PMU is, in my case, the only solution, which means that all unsaved work is lost. I have all applications automatically save and backup open documents every two minutes in order have minimal loss when the computer again goes dead on me. So much for extra memory and CPU speed.

    I know that power management has been a problem since this model was introduced and I know it has been discussed here several times since, but didn't anyone find a solution or at least a workaround? Did actually every owner of this model accept the problem as a given and move on? Or did they all sell their Powerbook and buy a Macbook instead? That might explain the problems I'm having with one I bought.
  • scottls22 Level 1 (0 points)
    Ok, Just a couple of obvious questions... First, is everybody that is having this problem making sure your settings in 'Energy Saver' is NOT the culprit of making your PB go into sleep mode? Check by going to system Preferences, then click on 'Energy Saver'. (the light bulb in the second row) Then with the sleep button selected, check the settings for both the power adapter and for the battery to make sure you know when your machine is set to put itself into sleep mode for inactivity. ('sleep' mode is when everything is off except the LED in the screen latch button is pulsating to let you know it is effectively in 'sleep' mode)

    Second, for those that can not 'wake up' their PB by pressing the power button, do you notice if the 'caps lock' and the 'num lock' (numbers lock button which is also the F6 button) will light up when activated? In other words, when your PB is stuck in the sleep mode, and you press the 'caps lock' or 'fn'+'num lock' does the light indicators come on?

    Third, does your PB cool down when it is in this 'unresponsive sleep' mode, or does it still feel warm on the bottom like it is still on? Give it a few minutes and then check it.

    And finally, does pressing the power button for *10 full seconds* NOT completely shut down your PB? I ask because this is suppose to be a fail-safe built into the firmware of the system and not in the OS software.
  • jmsuijkerbuijk Level 2 (160 points)
    I have tried just about every setting in the Energy preference pane, as I read somewhere that it should be anything but 'custom' to avoid the 'sleep' problem. Sadly, no setting was problem-free. Lately my setting for both power adapter and battery reads 'never sleep' for computer and 'sleep after 3 hours' for monitor. Additionally, there is no hot corner or hot key assigned to put the computer to sleep.

    Next time the computer goes into this coma, I will check whether the num lock and caps lock keys are responsive or not and whether the machine will cool down. Though it never really runs all that 'hot' in the first place.

    I had this problem again this morning and tried to shut down the machine by holding the power button down for at least ten seconds, but the computer didn't respond to anything whatsoever. I had to unplug the power adapter, remove the battery and wait until the pulsating LED died down. After that I could reinstall the battery, plug the power adapter back in and boot.
  • scottls22 Level 1 (0 points)
    The only reason I can imagine the PB would not force itself shut off after holding the power button for 10 seconds is 1) Corrupt firmware and I am not sure how to fix this, OR 2) the PB will NOT wake up if it forced itself to sleep because it is reading the battery as falling under a certain voltage.(*whether or not* that is a correct reading) Why it would malfunction like this while plugged in I have no idea.

    To further the bad news is that it is most likely a hardware failure of either the PMU, the battery, or maybe the 'DC/Sound card' (a small board inside the machine on the left side where you plug in the AC adapter, separate from the logicboard.) I am not sure if that or the PMU on the logicboard is what actually reads the state of the battery and tells the machine when the battery is about to die, thus forcing it into the unresponsive sleep mode. It is unresponsive because the machine 'thinks' the battery doesn't have enough juice to preform anymore functions other than to stay asleep and await charging.

    The problem I have is different which is why I was asking the questions I did. I am looking to see if someone has experienced the same problem I am having.(not to under-mind your problems)
  • jmsuijkerbuijk Level 2 (160 points)
    Thanks for your contribution. Hope you will find an answer to your problem.
    I doubt that the problem is related to the battery, because it occurs when the battery isn't even present. We'll search further and hope to pinpoint the culprit someday.
  • jmsuijkerbuijk Level 2 (160 points)
    Just now the computer went to sleep again. Caps lock and num lock keys are unresponsive. The machine at that time was hardly warm at all, but what little 'heat' there seemed to cool down when the machine was asleep.
    Again, the computer didn't respond to anything at all and unplugging everything, removing the battery and pushing the power button was the only remedy to finally extinguish the pulsating 'sleep' LED and have the computer able to reboot afterwards.

    Of course, the computer will say that the date has been set back to somewhere in 2001, but it doesn't. It actually sets the date back to January 1st, 1970!
  • scottls22 Level 1 (0 points)
    My suggestion would be to replace the PRAM battery. A very important step that is often overlooked when installing a PRAM battery is that once you install it and put it back together, you must reset the PRAM to make sure you don't have a run-away drain on the new battery which can drain and kill it within a day to a few days!

    You can go to: Battery/64/5/Page-1
    for instructions on how to replace that battery.(hint, the battery has a small board soldered to it but the entire apparatus is rapped in a yellow film like in the pictures displayed in the web-pages above. Also when pulling the plug off the logicboard, be very careful, I have broken this plug before. It is a little delicate.

    I am not affiliated with but they do sell batteries that are a little pricey. You can take a chance and find it cheaper on ebay but make sure you get one that was pulled from the exact same model PB. Same CPU speed, same screen size, ect. Otherwise the plug may differ a little which wont help you.
  • scottls22 Level 1 (0 points)
    Two more things I want to add. I read a while back that using an adapter that didn't come with the PB but was meant for the iBook or macBook series laptops is a big no no.

    They only provide 45 watts of power instead of the minimum required 65 watts, and will NOT charge the battery properly, resulting in a seriously shortened battery life. It further said that it starves a 15" PB for power even when the battery is taken out so when the processor or graphics card requires more power to keep everything running to full specs, the PMU reads a voltage drop and may sometimes force it to shut down, just as it would do if the battery were to suddenly die. If you have an aftermarket power adapter and you're not sure if it is the correct one, then look at the label on the brick itself and find out how many AMPs the output is. Times that by the output voltage, which should be around 24.5 volts and that should be at least 65 watts.

    The second thing is not that important but it is just a small observation I have made. When you take out the battery and unplug the adapter, the only thing keeping things like the time, date or unsaved work from being forgotten is the PRAM battery, which is why I advised to change it and see if this helps with any part of your problem, but as supermama10 pointed out, her PB seemed to retain it's memory, because even though the error message said the time and date was set to a time before 2001 it was actually correct when she went to update it. My guess is that the machine DID forget the time but she probably had the box checked for the machine to sync the time automatically over the internet, which it did once it booted back up and the wireless card was again active, thus making it seem like this time was correct all along.
  • Redbuilder35 Level 1 (0 points)
    I'm having the same problem as supermama10. Powerbook shuts down automatically when the power cord is unplugged. It is as if it PMU won't switch over to the battery. This all seemed to have started yesterday after I did the latest software update from Apple. I've tried starting up from just the battery and I can hear something happen but it won't start up. I've tried resetting the PMU from directions listed in the support area but it has had no effect on my problem.
  • scottls22 Level 1 (0 points)
    I realize Apple has had a good portion of us PowerBook owners do a firmware update on the batteries. I wonder if this has anything to do with it all.

    Message was edited by: Scottls
  • scottls22 Level 1 (0 points)
    Redbuilder35, when you have your PB plugged in and turned on, how much of a charge does the battery say it has?

    When you unplug the PB how many LEDs light up when you press the button on the battery?

    And finally, after you've pressed the power button to turn it on while it is unplugged and only running on battery power, can you press the 'caps lock' and 'fn'+'num lock' to see if the LED indicator lights come on?

    Let us know. Thanks Scott
  • jmsuijkerbuijk Level 2 (160 points)
    I did separately buy a power adapter from the Apple store, but made sure it was the appropriate one for my Powerbook model.
    Changing the PRAM battery seems quite tricky to me (I'm not all that skillful), but I may give it a shot. The batteries on iFixit are actually substantially cheaper than the ones offered on eBay, albeit out of stock at the time.

    I am now testing if a little, free piece of software, Caffeine (, can prevent the unwanted sleep. I'll report back on that.
Previous 1 2 Next