1 2 Previous Next 15 Replies Latest reply: May 21, 2009 10:04 PM by seewig
RonL Level 1 Level 1 (45 points)
iTunes 8.0.2 and OSX 10.5.5 on a G5 tower (2GB RAM)

For several versions of iTunes now I've been having problems that have finally gotten to the point that I can not create playable CDs.

Yet using Toast 6 Titanium with NON iTunes tracks (i.e. from CDs I have purchased and saved to my hard drive) I have no problems burning audio tracks to CDs and having them play.

I have of course trashed the iTunes preference file (several times) and Repaired Permissions, etc. (i.e. ran Disk Utility and DiskWarrior)

Some times iTunes fails in the 'initializing' CD phase and at other times at various other steps. It even sometimes 'successfully' burns a CD and may play one track and then freeze iTunes on the others and then when the same CD is reinserted after having had to force quit iTunes... the same CD gets an error that "You inserted a blank CD."

If Toast didn't burn CDs very quickly and without problems I'd think it was the CD burner, but since it does I would think that can be ruled out.

Any ideas?

Thanks!

G5 Tower, Mac OS X (10.5.5), 2 GB RAM
  • 1. Re: iTunes won't burn CDs
    cypherism Level 1 Level 1 (80 points)
    If the burn speed is set to "Best" try x8
    Best is always too fast

    Just keep using Toast, it blows itunes out of the water anyway !
  • 2. Re: iTunes won't burn CDs
    RonL Level 1 Level 1 (45 points)
    {quote}> Just keep using Toast, it blows itunes out of the water anyway !{quote}


    Cypherism,

    Only problem is that Toast won't burn iTunes tracks that I have downloaded (DRM?).

    I agree... Toast is many times faster than iTunes in burning CDs... (that is... when iTunes was working in the past).

    Any ideas as to how to get Toast to burn downloaded iTunes tracks?
  • 3. Re: iTunes won't burn CDs
    RonL Level 1 Level 1 (45 points)
    Thank God for the Brits!

    Thanks cypherism... by changing the burn rate to 8 instead of default 'maximum' it now burns CDs correctly!
  • 4. Re: iTunes won't burn CDs
    cypherism Level 1 Level 1 (80 points)
    I keep tellin' people but they don't listen !
    I can burn at x52 but I would rather be safe than sorry
    Old versions of Toast would show how fast your computer would throw the information at the CD Burner........ and guess what, x8 was the one on my old "Spec'd to the limit iMac"
    Sad fact is most computers are not as fast as the blank CDRs or the Disc drive

    Glad its sorted
  • 5. Re: iTunes won't burn CDs
    nopoet28 Level 1 Level 1 (5 points)
    Okay, I need help. Throughout this forum I have found that burning at 8x or slower will help this issue. I was able to burn 2 music discs using this method. Now, it won't burn a music disc again! I have even tried at 6x....getting frustrated.

    Situation is: says it is 'writing xxx' (first track), but it never really starts. So I try and cancel it and it never spits out the disc until I restart the computer. Any ideas? Thank you!
  • 6. Re: iTunes won't burn CDs
    AKAML Level 1 Level 1 (0 points)
    You just described my problem exactly -- it says it's writing, never goes anywhere, and freezes up and have to restart to get the disc out -- I just ran into this yesterday. I'm guessing it's a problem with Itunes 8.0.2 because I never had any problems burning discs with older versions (but it's been so long since I've burned discs that I don't know what version I was using). I know it's not my cd burner because it works for data or even for mp3's if I just drag & drop thru Finder. I've been reading a bunch of discussion about this on Apple's website, a few variations on the theme of "can't burn discs w/iTunes" but NO SOLUTIONS IN SIGHT. Eeek, very discouraging.
  • 7. Re: iTunes won't burn CDs
    woohoolaur Level 1 Level 1 (0 points)
    Having the same problem ... But I'm still using iTunes 7. Guess I'll try to updated now. Has anyone found an answer to this problem? Very frustrating!!
  • 8. Re: iTunes won't burn CDs
    Sunny123 Level 1 Level 1 (0 points)
    Same problem here. Wasted 2 discs because of this already. Anyone know of any workarounds? Is it only on an PPC Mac?
  • 9. Re: iTunes won't burn CDs
    heartfuldodgers Level 1 Level 1 (0 points)
    I'm running the updated itunes and I had the problem for the first time tonight. The playlist I am trying to burn is from an actual audio cd, not purchased from itunes and I haven't burned anywhere near 7 times, so i can't figure it out. It will split it into, get this, one track per cd. What I finally did is drag the files out of the itunes folder, bypassing itunes library altogether, and put it in the burn folder. Or you could just create a folder, drag mp3's to it and burn it as a data disc with mp3's on it. But how to make audio discs with this problem remains a mystery to me.

    Also, I don't get the message that I have burned too many times. Itunes just says that not all songs with fit on the disc, but when I delete enough songs, it will only burn one. I'm getting very ticked.

    I'm wondering if maybe some discs come with some kind of block on burning from itunes.

    Anyway, good luck.
  • 10. Re: iTunes won't burn CDs
    willisthek Level 1 Level 1 (0 points)
    If anyone's still having this problem - of the CD just never actually burning - even though it says initializing, etc. - I found a recommendation to:

    shut down

    restart with your CONTROL, OPTION and P, R keys held down to reset the PRAM and it worked just fine... they said you might have to reset your clock, but i did not.

    good luck!
  • 11. Re: iTunes won't burn CDs
    Pemsong Level 1 Level 1 (0 points)
    My iTunes is updated and for some reason, it is not finishing the CD's. It will initialize, write the songs, and then it hangs on the "finishing" process -- but never finishes. It will stay on "finishing" for hours if I leave it. I have to Force Quit iTunes and then I can restart iTunes and eject the CD.

    After that, the CD usually does not work, though sometimes it does. It worked before, I'm not sure what the deal is here.
  • 12. Re: iTunes won't burn CDs
    mcfart Level 1 Level 1 (0 points)
    Having the same problem. It seems to create a CD-R of MP3's (no DRM issues); makes a sound as it finishes, the disk in Finder has the name of my playlist, and while it will play when I load the CD back into the computer, it won't play in my car audio. I have occasionally had issues before that were resolved with different brands of CD-R, but I've tried 3 different brands (TDK, Maxell, Memorex) and none of them work. iTunes won't get around to ejecting the CD (but iMovie will eject a DVD, so I don't think it's the drive). I've had these problems since upgrading to the latest version of iTunes.
  • 13. Re: iTunes won't burn CDs
    Sunny123 Level 1 Level 1 (0 points)
    Anyone still having issues burning discs after 8.1.1.? My discs get stuck with "Writing Song <the first one in the playlist>"

    I can burn mp3 cds.

    Any ideas?
  • 14. Re: iTunes won't burn CDs
    itunes not burning cd's Level 1 Level 1 (0 points)
    Im having a complete crisis!!!

    when i try to burn a playlist onto a disc it initializes then stop, pops the cd back out and says 'unknown error occured, 2131) ive tried every thing you have all suggested and i get the same message.

    does anyone know what error 2131 is???

    or have any tips on how i can overcome this problem?
1 2 Previous Next