7 Replies Latest reply: Jan 7, 2009 6:05 PM by bz-21
JD in SoCal Level 1 Level 1 (0 points)
I added a WD My Book 1 Tb external drive to my iMac, and I'm trying to format the drive to the Mac OS Extended (Journaled) format using the Disk Utilities/Erase utility. When I start the Erase operation, it runs for 3-4 seconds and then gives me a "Disk Erased failed" message, saying "Disk Erase failed with the error: File system formatter failed."

This is the second drive I have tried this with. After experiencing this the first time, I visited a local Genius Bar and described the problem, and they said it sounded like the drive was bad. I exchanged the drive for a new one, but same problem.

Is there a known compatibility issue between the My Book 1 TB drives and the iMac, or is the problem with my machine?

iMac7, Mac OS X (10.5.5), Intel Core 2 2GHz
  • Kenichi Watanabe Level 7 Level 7 (30,460 points)
    I have read quite a few posts here about issues related to Western Digital external drives. I can't tell how extensive (as a percentage of all users) it is, since people without issues will not post, but if you personally tried two and had the same problem, I would get a refund. Get a different brand. Western Digital makes excellent hard drive mechanisms (I use quite a few), but I'm not so sure about their enclosures.

    One suggestion is to go with a company that caters to Mac users. For example, OWC.

    http://eshop.macsales.com/shop/firewire/

    You should also get a drive with both FireWire and USB connections for maximum flexibility down the road.
  • burkely Level 1 Level 1 (10 points)
    I copied this from the discussions a while back.

    Hard disk drives used in Windows XP or Vista are partitioned using a Master Boot Record scheme and formatted in NTFS format by default. MacOS X can read these drives but cannot write to them without extra third-party software. Needless to say, you cannot install MacOS X nor can you boot from these drives.

    What happens if you want to reuse such a drive, or if you purchase an external drive which comes preformatted for these systems? You need to change the partitioning scheme from MBR to GUID and the format from NTFS to MacOS Extended (Journaled) if you want MacOS X to boot from that drive, but there's a bug in Leopard's Disk Utility that impedes erasing an NTFS HD directly, so you have to use the following workaround:
    Make the drive available to the MacOS system (plug it in, power it up, etc. Firewire and USB drives are plug and play, SATA, e-SATA or PATA drives are not and need to be connected with the system powered down).
    The NTFS volume should appear on the Mac desktop, unless password-protected. Remember that all data in the volume is going to be lost with this procedure.
    Open Disk Utility and select the device containing the NTFS volume. The Partition tab should appear, in between Erase and RAID. Click on Partition.
    The Volume Scheme and Information will be displayed, but DU will say that "The NTFS volume will not be erased" and all buttons will be grayed out. This is the bug and here comes the workaround.
    Click on the "Current" drop down menu and select "2 partitions" or more. The Options button will activate.
    Click on the Options button. Select GUID Partition Table if you are using an Intel Mac, select Apple Partition Map if you are using a PPC Mac. Click OK.
    You can now go back to "1 Partition" or as many as you want for the drive. Click Apply and let DU create and format the partition(s). Time Machine may pop up a window asking to use the volume(s) for backups; click Cancel.
    Select the new volume(s) on the left column and verify that the format is Mac Os Extended (Journaled). If not, click on the Erase tab and correct.
    You have successfuly eliminated the NTFS formatting from the HD and it can now be used to install or clone a bootable MacOS X 10.5 startup volume. Quit Disk Utility.
  • Neoblackout Level 2 Level 2 (325 points)
    I had the same problem, but i just fully erased the drive on my pc and left it as "free space" and just formatted it on the mac from there.
  • cityofsatellites Level 1 Level 1 (0 points)
    Thanks Burkely...
    Took this approach with a Windows formatted Seagate Freeagent Desk hard drive after getting the same error messages trying to do a regular format. This technique worked a treat!
  • jp4678 Level 1 Level 1 (0 points)
    This worked perfectly for a WD My Book 1TB drive. Thanks for the excellent write up.
  • MsPilates Level 1 Level 1 (0 points)
    I created an account with Apple just so I could say THANK YOU to a few people:

    *THANK YOU* to JD in SoCal for posing this question.
    *THANK YOU* to Burkely for having realized the valuable information that Courcoul had offered regarding reformatting Windows drives. Thanks Burkely for having copied, saved, and posted this information, and
    *THANK YOU* Google for your search engine.

    I got a GREAT Black Friday deal on a Western Digital 750GB external hard drive. I thought I was going to have to take it back. Thanks to those above, I was able to follow the directions, and it works. I did it! I'm not the most computer savvy, but thanks to these Apple discussion boards, I've been able to solve many problems along the way.
  • bz-21 Level 1 Level 1 (0 points)
    Thank you. Excellent. Worked perfectly.