Previous 1 2 Next 29 Replies Latest reply: Apr 19, 2009 9:53 PM by Robert Nicholson1 Go to original post
  • fuugus Level 1 Level 1 (0 points)
    same problem/config here with vista (sp1, 32bit & 64bit) as well. i was heading for efi as well after all the stuff i tried, but what i cant understand is that osx sees the disk, but vista does not.

    on the other hand: there is an /efi folder on the vista install dvd... could it be that part of efi is loaded and replaced live from the dvd during install???

    - efi update 1.6 installed
    - macbook: osx install works on hdd/ssd
    - pc: vista install works on hdd/ssd
    - macbook: vista install works on hdd but not on the ssd
    - preformatted ssd with master boot record doesnt work
    - bootcamp doesnt work
    - acronis cant clone the hdd to ssd, not even if attached to a pc

    ill try ubuntu next and let you know, but i dont think with that we have much more clues to go.
  • Kiety Level 1 Level 1 (0 points)
    OS X 10.5.6 out, but I don't see any mention of any fixes with intel SSD + boot camp
  • YusifSaladin Level 1 Level 1 (0 points)
    fuugus wrote:
    but what i cant understand is that osx sees the disk, but vista does not.

    You're right, it is weird, and it's a certainly different, but not unexpected. It's down to how EFI is actually different from BIOS, and it's interaction with hardware.

    When the computer (intel mac, that is) intially loads (so we're independent of OS at this stage), we're booting into an EFI environment. The devices are detected/accessed using their respective EFI drivers (yep, EFI has drivers) and we get access to them to use at this point.

    EFI also supports a higher framework, which is where all the cool stuff starts happening. On our Intel macs, one of the components that is loaded by this framework is the "BIOS compatibility module". (BCM)

    At this point onwards, if an operating system wants to address hardware via a BIOS call, it does so via the BCM. For the most part till now, everything has worked fine, and XP/Vista (and linux in compatibility boot mode) has access to hardware (such as hard drives) and we're all happy campers installing away. (then you need drivers to run this hardware correctly with the OS, but that's a seperate problem, and has been addressed by the drivers provided by Apple on the installation media (and subsequently in the 2.1 update, or the 2.1.1 drivers supplied with the new macbook pro installation dvd)

    Now: What we're experiencing here is down to the device not being compatible with the settings/information/etc assigned to it via the BCM. Once this occurs, you end up with the situation we have here. (ie, a hard drive that is as accessible as a piece of cheese installed into a computer)

    It (the Intel SSD) works with OSX, and Linux installations (not running compatibility mode boot mode). That makes sense, as these operating systems are completely EFI compatible/native, and they don't utilise anything to do with BIOS to interface with hardware. Their calls go via EFI, and everything works because the device is compatible with the EFI drivers for the SATA class of devices...

    You occasionally see this behaviour in a standard BIOS PC, and to fix it you'd change the settings in BIOS for the sata controller (ie, to SATA native, or RAID, or AHCI...that type of thing)

    Whew....that's a rushed summary (and people are welcome to correct anything I've over-summarised. It's not meant to be a 100% 'pass an exam' explanation, but it's pretty close.)

    For more information on the EFI environment, wikipedia is a very good source for this. It explains this much more coherently...<grin>
  • The hatter Level 9 Level 9 (60,915 points)
    Vista 64-bit SP1 has support for EFI, though, right? UEFI (Unified EFI 2.x).

    Some Macs you would think support (officially) Vista 64-bit, though, are not listed by Apple (Mac Pro pre-2008) only because it uses older EFI 1.x and EFI32 instead of EFI64.

    And yet, 2008 MacBook and MacBook Pros do get official Vista 64-bit support or "nod" from Apple. And the Penyrn iMac from mid-2008? Not a bit.

    I have older Vista 64-bit media, and it has worked fine, though sometimes but not always I have had to remove hardware (PCI Express cards). Vista installs but after the first big update, BSOD hardware crash (white text on blue).

    Bought Vista 64-bit SP1. This DVD gives me some kind of boot menu with "Choose Option 1 or 2" screen but sits frozen and won't respond. In that case, I can install a 2nd version of Vista while in my first original OS (I have 2 copies of Vista installed on their own hard drives.

    So that EFI-X would allow the Mac user to access the settings, and maybe tweak "BIOS compatibility module." Something I was unaware of before. Add support for Intel X225-M SSD even.

    Could EFI-X actually help a stock standard Mac Pro etc. run Windows (not the other way around which seemed to be the intent, to run OS X on non-standard PC hardware)? benefit from being able to finally use stock PC hardware like Nvidia 9800GTX or GTX 260. Cards that for now lack EFI ROM and only work in Windows.

    Okay, list of Macs with official Vista 64-bit support (does not differentiate between SP1 or not).

    Microsoft (and Intel) had said that support for EFI would only be in SP1 64-bit UEFI2.x. And seems to coincide with Apple's 2008 Macs.,2542,t=EFI&i=58377,00.asp
  • GavMackem Level 1 Level 1 (15 points)
    I'm a relative Mac novice but certainly not on PC boxes so here's my two penneth worth. There are similar issues installing a vanilla XP SP2 disc on SATA devices which use the AHCI format instead of compatibility mode which XP setup can detect.

    In XP's case you could try and see if the Mac supports detecting a USB floppy drive on boot and try loading the driver via F6 when windows setup first starts. Else the only other option is to unpack the original XP disc and slipstream the files recreating the image with a later hacked XP AHCI SATA driver from Intel's website with the 'inf' file modified adding the extra strings present in Apple's boot camp SATA driver's inf file.

    In Vista's case it supports USB drives on setup at boot which putting the drivers on a USB stick for Vista to detect.

    Spelling is not my forte..
  • Maven1975 Level 1 Level 1 (0 points)
    Well.... I would gladly donate to someone that can find a solution.

    God Speed!
  • firatlogin Level 1 Level 1 (0 points)
    I tried to install vista on another machine, failed.
    I tried grub, failed.
    I tried rEfit with bootable cd, boot from refit and than selected windows partition to continue, failed.
    I tried windows 7 (azure) x64 build 6936, tried to setup, failed.

    only hope seems to boot all the os from the cd. which is not good at all.

    so in short, to boot from x25 to a windows os seems to impossible now.
    intel x25-m unable to boot in bios mode on a macbook pro.

    we will need a firmware update for macbook pro.
    I do not think there will be any update soon.
  • Maven1975 Level 1 Level 1 (0 points)
    I got it to t work!

    I used my iMac 3.06 and ran bootcamp assistant. It installed XP SP2 without a hitch. I made a 5GB partition and will use Mac Drive 7 to get access to the open space on the OSX partition.

    Thanks goodness!
  • Maven1975 Level 1 Level 1 (0 points)
    I spoke too soon. I have XP installed on the HD, but I can not boot natively into XP via bootcamp. I just hangs when trying to boot. I was able to use the partition with VMware, but that was not what I was shooting for.
  • Kiety Level 1 Level 1 (0 points)
    has anyone found any solutions to this problem?
  • ray mazeika Level 2 Level 2 (415 points)
    Has anyone installed OSX and XP on a regular HD then used SuperDuper and back it up to the X25M and tried to boot XP? I don't have a spare drive to to this with yet. For now I'm using parallels 4.0. Seems to work fine.

  • ddrcoder Level 1 Level 1 (0 points)
    I'm in the same boat here, though I've tried various editions of Windows with various configurations.

    Notably, I've tried installing Windows 7 onto the SSD via a desktop computer with no luck (though I did /not/ repartition the drive, I used the OSX-created existing bootcamp partition).
  • rebotfc Level 1 Level 1 (5 points)
    Anyone have any progress with this problem, not being able to use bootcamp with this drive is ridiculous.
  • tkom1970 Level 1 Level 1 (0 points)
    The new firmware fixed my issue.
    You should contact Intel support for a fix.

    However, it may not solve.
  • Robert Nicholson1 Level 2 Level 2 (265 points)
    Related to this does anybody know why my X-25M is in a ATA-5 frozen state for ATA Security upon boot? What is it about the boot process that leaves the drive in this frozen (ie. cannot security erase) state?
Previous 1 2 Next