Previous 1 2 Next 16 Replies Latest reply: Sep 27, 2009 5:34 AM by bonecarpenter
badtz Level 2 (250 points)
When I reply to an email on the iPhone, it doesn't show the "reply" flag inside of Mail.app on the Mac.

Obviously this is annoying since sometimes I forget if I replied to an email or not.

Is there any way to fix this behavior?

G5 + MBP, Mac OS X (10.5.1)
  • Kevin Liu Level 1 (100 points)
    Is your account IMAP or POP?? Synchronizing these details will only occur with IMAP accounts.

    I'm not an expert on these topics but I think both the iPhone and your computer need to have IMAP accounts.
  • Allan Sampson Level 10 (123,405 points)
    As Kevin provided, this is only possible with an IMAP or Exchange account.

    All server stored mailboxes with an IMAP or Exchange account are kept synchronized with the server automatically with each email client used to access the account.

    Although it is possible to access a POP account with more than one email client, a POP account is designed to be accessed with a single email client only. The only mailbox available with a POP account when accessing the account with more than one email client is the account's Inbox mailbox with new messages received at the incoming mail server for the account downloaded by each email client used to access the account. The account's Inbox mailbox is not kept synchronized with the server as is available for all server stored mailboxes with an IMAP or Exchange account.
  • badtz Level 2 (250 points)
    all accounts are IMAP.

    Emails are sending out okay on both ends. It's just the little arrow reply flag inside of mail.app doesn't show when the replied email was sent from the iPhone.
  • Mandel23 Level 1 (0 points)
    This is actually a known issue with the iPhone, as it doesn't work with Exchange either. If I forward or reply to a message on the iPhone it won't show up as replied to or forwarded in the Exchange mailbox. There have been some other threads here about this, but so far it hasn't been fixed, and as is traditional, there's no word on whether it will be fixed or not in the future. It is a real problem though, as when you're checking your mail in Entourage or Outlook after being out and using your iPhone, you can't easily tell what was just read and what was replied to.
  • Allan Sampson Level 10 (123,405 points)
    I don't have an Exchange account, but this works as designed and intended with my IMAP account.
  • acursio Level 1 (0 points)
    I have this issue as well when using my PC (Outlook 2007) through our Exchange Server. Agree it's annoying! Is there any further news on this one? Cheers
  • dlong500 Level 1 (0 points)
    Mandel23 is correct, this is a known issue. It is beyond me why Apple wouldn't fix something like this right away, as it can't be but a few lines of code involved.

    Allan, I'm not sure you are grasping the issue at hand. First you seem to think it has something to do with POP access (when no one is talking about POP), and then you state that it is "working as designed and intended" for you. If it is working for you then you must have a "special" build of the firmware.

    As the original poster stated, this is extremely annoying as you can't tell if you replied to an email or not when you are viewing your email in Outlook, Entourage, Mail.app, or any other mail client.
  • zoo1023 Level 1 (5 points)
    Just adding an "us, too" to this thread, the messages aren't being flagged with replies in Microsoft Entourage (I thought that would help anyone else searching). We use IMAP on our computers and on our iPhones.
  • mcuzo Level 1 (0 points)
    I know I am jumping an old post but this is still an issue with me and my clients! I am a computer consultant that works with Exchange extensively and this to me is a real outrage. All my clients ran out and bought an iphone because Apple trumpeted how they leased ActiveSync from MS and will support corporate email. Well, they should learn how to implement it! I have an iphone too and this is a real bummer! Wonder if 3.0 software will cure this??? PROBABLY NOT!
  • Mandel23 Level 1 (0 points)
    Now that the beta version of 3.0 is out to developers, I'm wondering if anyone has had a chance to check this out? This feature is a dealbreaker for me - I'm deciding between a Blackberry, the Pre and the next iPhone this summer, and the iPhone will lose if this isn't fixed.
  • Mandel23 Level 1 (0 points)
    I'm going to answer my own post here. I got my company to pony up for the developer fee and downloaded OS 3.0 Beta 3. No change to this issue - replying or forwarding is still broken. At least I can submit a bug report / feature request as a developer now. But if this isn't fixed by the final release...
  • Looter Level 1 (55 points)
    Bummer, this drives me crazy as well. IMAP accounts, replying to email via iPhone is not flagged on the IMAP server as replied to.

    Message was edited by: Looter
  • andrew.in.Boston Level 1 (0 points)
    I'd also like to chime in and wish (again) that there was proper flag synchronization in Exchange!
  • GearJabber Level 1 (0 points)
    Add me to the "wished this worked list". I too have 3.0 which did not fix this issue.

    Dear Apple,

    If you wish to compete with the other "enterprise" level smartphones of the world, you really need to get the basics like message flagging working. Notes and tasks syncing couldn't hurt either.

    Regards,
    BlackBerry
Previous 1 2 Next