5 Replies Latest reply: Dec 30, 2008 9:14 AM by st3v1e
ham02tech Level 1 Level 1 (0 points)
My iPhone wont connect to my wireless network. It recognizes the network in the general settings but just wont connect and the network is not locked. My wife's phone connects to it right away. Not sure how to fix it...

Mac OS X (10.5.4)
  • gmoney1227 Level 1 Level 1 (0 points)
    I'm pretty new to my iPhone, so I'm not quite sure if this will help. But have you tried resetting your phone? If that doesn't work, maybe a visit to the Genius Bar is in order specially since you can rule out the wi fi connection since your wife's phone can connect just fine.
  • biggig Level 1 Level 1 (0 points)
    I had a problem connecting to my home wifi network, I just purchased a new iphone dec 27,2008 and no matter what I tried I could not connect to my home wifi, it would not even show any networks, what really threw me is I could connect easily with my ipod touch without connecting to safari first. Then I read somewhere that safari must be connected first, so I connected to safari and turned on wifi and it found my network and connected right away.
    You would think Apple would tell you about quirks like this but they are very poor in that area and their user guides are not really very helpful like most comp companies they assume customers know way more than they do.
  • st3v1e Level 1 Level 1 (65 points)
    How about this for a strange problem:

    I took my nice new iPhone to work yesterday, and it found the wireless network straight away. I played with it and surfed the internet during breaks and had a great time finding my way around. Bought it home with me, and despite it finding my home network, and having me assign the WEP security and relevant password, no matter what i try, I can't connect via my home network to the internet.

    Took it back to work this morning, and once again, straight on the network and internet. Back home tonight . . . . . no connection.

    Any idea's would be greatly appreciated.
  • dherron Level 1 Level 1 (95 points)
    My 1st Gen iPhone has strange notions of disconnecting from my home Wi-Fi connection. I can connect by entering the WEP password, but within 10 seconds it will prompt me for the password again and again.

    Works at friends homes first time, but not at mine!

    Is this a fault? or is there just a setting that needs changed somewhere? I may have 1 week warrenty remaining because I got my iPhone replaced in October 08 with a 90 day warranty on it. I had the same problem with my 1st iPhone.
  • st3v1e Level 1 Level 1 (65 points)
    Hmmm it sure is strange . . . . I keep getting the following message at home only:

    "Could not activate cellular data network: PDP Authentication failure"

    None of this at work though, we do use a different ISP at work too!
    Must be a setting in the phone.
    It's only a week old, so I'm still finding my way around. Anyone?


    Cheers,

    Happy New Year to all!