11 Replies Latest reply: Jul 17, 2009 5:53 PM by S Strider
rkm28 Level 1 Level 1 (0 points)
Mail.app seems to be stripping or otherwise not showing Omniture SiteCatalyst reports sent as attachments to my Gmail account.

* If I login to Gmail in a browser, I can see the PDF report.
* If I download messages to Mozilla Thunderbird via POP3, I can see the PDF report.
* If I download messages to Mail.app via POP3, I can't see the PDF report.

I've tried this on a brand new Mac OS X account and a brand new Mail.app account. Interestingly, Mail.app does not strip all attachment because the Omniture logo GIF is still present in the message.

Any ideas?

Macbook (black), Mac OS X (10.5.5)
  • Camelot Level 8 Level 8 (46,190 points)
    It's certainly not a normal thing for Mail.app to do, therefore there must be something specific about the message that's causing this - is it possible the attachment is getting stripped through some kind of virus/spam check? either at your ISP or your mail client?

    Also check the account settings - there's an option to skip messages over a certain size - is it possible the message (or the attachment) is too large?
  • rkm28 Level 1 Level 1 (0 points)
    This is definitely odd. I don't think it's my ISP because Thunderbird on the same computer with the same connection works fine. (I wonder if the ISP even could strip attachments since the Gmail POP connection is over SSL.)
  • danno56 Level 1 Level 1 (0 points)
    I have a similar thing happening. I use Mac Mail and when one particular person sends me email and that email includes an attachment, Mac Mail seems to strip away the attachment. I still get the email but no attachment. If I go out to the mail server via the web, the email is there and so too is the attachment. This only happens with one person. I receive other email with attachments from other people all the time. Does any one have any suggestions on where to look?
  • Levine Level 1 Level 1 (0 points)
    I actually arrived on this page after Googling because I, too, am using Omniture Site Catalyst and having my report attachments stripped! It doesn't matter which format I send the report in (PDF, XLS, CSV, etc), the report is not a part of the email when viewed in Apple Mail.

    Even stranger, other members on my distribution list, who are in my office, get the reports attached just fine. The only difference between them and me? They're all on PC's running Outlook.

    I receive attachments all the time and this is the only scenario in which it doesn't work. I wonder if it's an encoding problem coming from Omniture.
  • Bruce Sanderson Level 1 Level 1 (70 points)
    I have this problem also except that its a different sender. If I look at the message through my ISP web mail service via the internet the message and attachment shows up as intended. Also I notice that if the Raw Source is examined in Mail through the Mail>View>Message>Raw Source command the material is all there albeit with much other gobbldy gook.

    I can get the full message using Thunderbird (which I do not want to use because Mail is otherwise satisfactory). The issue must be something to do with Apple Mail.
  • marklinw Level 1 Level 1 (0 points)
    I also am having this problem with reports from Omniture SiteCatalyst. I've noticed the Mail.app says the attachment is there in the list of messages, but when you open the message (or view it within the preview pane) it says it's not there.

    For example, the message from Omniture SiteCatalyst typically comes in with 5 attachments (images plus the actual report file). However, when you open the message you only see 4 attachments. Makes me think the file I actually want is oh so close!

    Any info would be appreciated.

    M
  • TONYTECH Level 1 Level 1 (0 points)
    Has anyone come up with a solution for this? I've checked with Omniture and they claim that it's not an issue on their end, perhaps something in Mail.app. Just to review, attachments are getting stripped in Mail from Omniture SiteCatalyst, though you can view them fine via webmail or if you're on a pc or any other email program on a mac.
  • IGolubovic Level 1 Level 1 (0 points)
    Hi,
    I have a similar problem, message I'm receiving have two attachments and in inbox list I see under attachment column 2 items, but in message view I only see one (png image), and have option to save it.

    Only way to get second attachment (that I'm actually interested in) is to use menu File/Save Attachments...

    Maybe you have the same problem and I hope this helps.
  • TONYTECH Level 1 Level 1 (0 points)
    Yes, that does seem to work. Good workaround! Incidently, it only seems to affect Leopard (10.5) users and not Tiger (10.4) users on Apple Mail. Must be something written in the code, because i've two identical machines but one is running Tiger and the other Leopard.

    Thanks!
  • S Strider Level 1 Level 1 (0 points)
    Here's another person with the same problem . . . but we're also developing web apps and MacMail on 10.5 is the ONLY place we're finding this problem with PDFs we're attaching. Strange.

    The "Save Attachments" feature works. . . but it's not obvious to the layman who is used to seeing the paperclip icon with a list of attachments.

    Gmail, Outlook, PalmOS, Thunderbird and Roundcube all have no problems, but MacMail gets the lemon award of the day for this quirky bug.
  • S Strider Level 1 Level 1 (0 points)
    Just one more thing to add, I can confirm that this problem seems to be persistent in all our 10.5 computers but none of our 10.4 systems.