8 Replies Latest reply: Jan 30, 2009 5:41 PM by Pioden
HChavarria Level 1 Level 1 (25 points)
I just bought an 8 gb ipod touch 2nd gen and a voice recorder app from the app store to record my meetings. I tried the app and it installs and runs fine but when I try to record it doesn't. Does the iPod touch have a mic to record?

Windows XP Pro
  • Graham K. Rogers Level 5 Level 5 (5,430 points)
    No, unlike the 3G iPhone the G2 touch does not have this. You will have to use an external microphone like those on the new Apple ear buds (which are at least ready for order on the Store web pages).
  • Yana Level 1 Level 1 (25 points)
    Do the earbuds that come with the 2g work for recording? What app should I download?
  • Rudegar Level 7 Level 7 (23,630 points)
  • Pioden Level 1 Level 1 (0 points)
    Are these (apple earbuds) the only headphone/microphone that work to input sounds into the touch?

    I purchased a "monster mobile" microphone that plugs into the touch, and has a spot on its plug to allow the plug in of any other headphone or speaker set that's size compatible.

    It kind of works, but seems to be VERY buggy when I try to use it with a recording app - it triggers my music player, and sends it into spasms of playing. Pausing doesn't always work, it'll start up on its own again sometimes. I got the microphone to use with the iprorecording app, and am currently fighting the urge to throw a very expensive piece of technology across the room }:~/

    Any suggestions, help, commiseration, similar stories, etc. would be very much appreciated.

    thanks,
    Pioden
  • BobHarris Level 6 Level 6 (15,965 points)
    I have a pair of $20 GE earbuds w/microphone that works fine with my iPod Touch 2G. There was another thread in this forum that was listing different earbud/microphone models that worked as well. Try searching for that thread.
  • Magenta Orchid Level 1 Level 1 (0 points)
    I'll commiserate. :/

    My experience is here: http://discussions.apple.com/thread.jspa?threadID=1886419&tstart=50

    I think we are looking for the same solution here, I hope someone can help us.

    For me the problem is primarily with the play button on the headphone wire, which is on the mic even though I am not using headphones.
  • Pioden Level 1 Level 1 (0 points)
    Thank you for this post, it gave me a new direction to go in, and now it works about 40-50% of the time, an improvement {:~0 It seems to be getting better, as I learn its quirks, though I still think it is buggy, it has shut down on me a few times, and seems to change the rules on me... It doesn't want to record new memos lots of times, and then it will, and then it won't... I wonder if it behaves better on an iphone?
    I'm going to try downloading the italk program, and see if that works any better. I was looking for something that recorded with a decent quality, and could be uploaded to my computer easily, so I could record story and song ideas. Sorry about you're class, I know that's very frustrating, esp if you were counting on the recording to flesh out your notes!
    Keep me updated, please, and if I find a solution, I'll let you know!
    Pioden
  • Pioden Level 1 Level 1 (0 points)
    Thanks for the confirmation that others work, and the suggestion - I'll look for that thread.
    Pioden