10 Replies Latest reply: Dec 30, 2008 6:05 PM by jfjunior
jfjunior Level 1 (0 points)
I was getting the following error message when attempting to install iTunes:

*iTunes Installer Completed*

*The installer encountered errors before iTunes could be configured.*
*Your system ha snot been modified. To retry these operations at a later time, please run the installer again.*

*Click Finish to exit the installer.*

The Solution which worked for myself.

I checked my c:\temp folder - your temp folder could be different - and located the "iTunesSetupD04.log" file. Please note that your log file name could also be different, so check all the log files related to iTunes inside the temp folder, just in case.

Inside the log file I located the following line:

Executing: "C:\WINXP\system32\msiexec.exe" /i "c:\Temp\ixp433.tmp\iTunes.msi"

I then copied all the *.msi files from inside the c:\temp\ixp4433.tmp folder to another folder in my desktop. There were 6 .msi files in the ixp4433.tmp folders as follows:

1 - AppleMobileDeviceSupport.msi
2 - AppleSoftwareUpdate.msi
3 - Bonjour.msi
4 - Itunes.msi
5 - MobileMe.Msi
6 - QuickTime.msi

Once I had all these files copied to a folder on my desktop I just ran the "itunes.msi" and voila, it worked just fine.

Good luck.


Too many to list! :), Windows XP Pro
  • Ozzkuu Level 1 (0 points)
    I have the same problem. That your solution doesnt work for me because there were nothing related to iTunes in my temp folder. Problems started when I installed other CD/DVD burning software. iTunes started to say on every startup that regisrty marks(or something like that) that are used for burning CD's and DVD's are missing. To solve this program install iTunes again. Well tried trough automatic update to iTunes 8.0.2 but encountered that problem. After that downloaded it and tried to install it manually but same problem. Today I finally deleted the iTunes and then tried to install it again. Same problem again. Anyone can help?
  • jfjunior Level 1 (0 points)
    I think I know why you cannot see the iTunes temp folder. It happens that after you finalize the iTunes installation the temp iTunes folder is removed.

    Try this and let us know how it goes:

    Start the iTunes installation, go all the way just before you get the error message and stop. At this point check for the iTunesSetupD04.log. Please note that the log may have a different file name, so you better off to do a search for itunes*.log instead. Once you locate the log open it and look for the executing line such as this one:

    *Executing: "C:\WINXP\system32\msiexec.exe" /i "c:\Temp\ixp433.tmp\iTunes.msi"*

    Again the executing line on your log may show a different path than the one I have above. Once you know the path, - in my case above it was c:tempixp433.tmp - just copy all the *.msi files from inside the ixp433.tmp to a new folder in the desktop or any location of your choice, except the temp folder itself. Then just go ahead and run the iTunes.msi and it should work for you.

    Note: Its important to copy all the *.msi files to the new folder. Also pleaase remember that until you copy the *.msi files you should not finalize the iTunes installation you had started.

    Please post back the results for the benefit of the community.

    Thank you.
  • Ozzkuu Level 1 (0 points)
    Did exactly as u advised. Found the log file and those .msi files, copied them to desktop and finished that install. Then opened iTunes64.msi that I copied, but same problem. It gets to "Copying new files" and almost to end ad then it starts to cancel it.
  • jfjunior Level 1 (0 points)
    Sorry to hear that Ozzkuu.

    It looks like your problem is a little different that the one I had. Besides you are using Windows Vista 64 - just noticed that now. I won't touch Windows Vista with a 100 metres long pole.

    That last two things I could suggest:

    1 - Uninstall iTunes and all related software, such as QuickTime, etc. Then use Ccleaner - http://www.ccleaner.com/ - to clean up your registry - make sure to use Ccleaner to backup the registry changes just in case and then attempt the install the way I mentioned again. Also make sure Ccleaner is compatible with Windows Vista.

    2 - Create a new user profile and see if you are able to install as a different user after rebooting your machine and perhaps using both of these suggestions at the same time.

    Other than that I'm not sure what else to recommend.

  • Ozzkuu Level 1 (0 points)
    Now got it installed. First tried to uninstall the software that caused the DVD/CD burning thing and used CCleaner to repair registry and clean temporary files etc. Then tried to install.. Sme problem. Then tried to uninstall QuickTime and again run CCleaner, then installed and got it. Thanks for your help! Now I have to restore my playlists and other stuff, but I can find help to that from these forums
  • jfjunior Level 1 (0 points)
    Glad to know it worked out!!! You're quite welcome!

    The playlists restore should not be difficult at all, however I cannot offer much help about it as I don't use iTunes to sync my files or play music in my computer.

    I use MediaMonkey - http://www.mediamonkey.com/ - which I find a better media player, more customizable and lighter. The only reason I installed iTunes was to perform software update and because MediaMonkey needs it installed before it can sync files to the iPod Touch.

  • coldkid Level 1 (0 points)
    Hey, I got this problem too but I can't seem to find the IXPsomething.tmp that you mentioned anywhere in the temp folder. Running Ccleaner didn't help. Got any ideas? I've got a brand new iPod classic and if I can't install iTunes 8 then how can I load things up? Thanks for your help.
  • togap43 Level 1 (0 points)

    I just got a new ipod nano, 3rd generation and I'm encountering the same error as well. I can't find the temp folder to attempt the methods listed. Is there anything else I can do?

  • jfjunior Level 1 (0 points)
    As I mentioned before you need to start the iTunes installation, then do NOT allow it to complete. In other words go all the way to the point that the installer extract the installation files, then STOP right there.

    Now look for the temp folder and the files I mentioned in my initial posting. If you don't find the temp folder it may be because you have "Do not show hidden files and folder" selected under "View Tab" in the "Folder Options". You may need to unselec it. If you don't know about hidden files and folders in Windows XP take a look here: http://txpress.blogspot.com/2007/05/show-hidden-filesfolders-in-windows.html

    Another possibility is that you may have a different path for your temp folders. To find out where you temp folders are located please do the following:

    - Right click on "my computer"
    - Select the "Advanced" tab
    - Click on "Environment Variables"

    Then look for the path for both variables "TEMP" and "TMP" take note of the path and check them out.

    Or you may just go to a DOS Prompt and type the following commands:

    1 - %temp% and hit enter
    2 - %tmp% and hit enter

    to both of these commands you will get a reply such as:

    'c:\temp' is not recognized as an internal or external command, operable program or bath files.

    So by looking at the reply you can see that my temp folder is c:\temp

    The above is the temp folder on my machine which I've customized to my own use. Your machine may be different.

    I suggest you check for the iTunes temp folder inside both your temp folders locations "TEMP" and "TMP" as they may be in different locations.

    IMPORTANT NOTE: If you allow the iTunes installation to complete you will NOT SEE the iTunes temp folder and files because it will be deleted as soon as iTunes processes the installation.

    Hope it helps.