1 2 Previous Next 21 Replies Latest reply: Dec 29, 2008 8:03 PM by Mac User Totally frustrated
Picchu Level 1 Level 1 (0 points)
I just installed 10.5.6 on the first generation macbook pro and now it does not wannt to go beyond the apple logo and load screen...its been looping for about 15 minutes...any thoughts? or is this happening to anyone?

MacBook Pro, Mac OS X (10.5.6)
  • 1. Re: 10.5.6 and startup loop
    a brody Level 9 Level 9 (63,280 points)
    This can happen with any version of 10.5 and installation. This article discusses the most common causes:

    http://support.apple.com/kb/TS1541

    Hopefully you have backed up your data. These tips apply before installing anything:

    http://discussions.apple.com/thread.jspa?threadID=1826767&tstart=0
  • 2. Re: 10.5.6 and startup loop
    Picchu Level 1 Level 1 (0 points)
    i have no issue with the OS disk. My mac cant pass the apple logo loading screen
  • 3. Re: 10.5.6 and startup loop
    a brody Level 9 Level 9 (63,280 points)
    According to this, you've only reached the kernel:

    http://support.apple.com/kb/HT2674

    Which says anything beyond that is either corrupted or unreachable.
  • 4. Re: 10.5.6 and startup loop
    Zan B Level 1 Level 1 (0 points)
    - Quick diagnosis -
    You need to re-install your operating system.

    - Quick fix -
    Boot up to your Mac OS X installation disk, select the device you want to install OS X on, and click options. To preserve your data you will want to choose "Archive & Install". Once OS X has finished installing, run the update again.

    Message was edited by: maczan
  • 5. Re: 10.5.6 and startup loop
    a brody Level 9 Level 9 (63,280 points)
    An archive and install may end up in a worse scenario than one started. This is especially true if you have an older system than you started with when you do the archive and install, or if there is data corruption outside of the system and user preferences.

    If they aren't getting much beyond the kernel, that kind of corruption is not easy to eliminate as a possibility.
  • 6. Re: 10.5.6 and startup loop
    Zan B Level 1 Level 1 (0 points)
    I don't think you have ever worked in an Apple Authorized service center. Archiving & installing the OS, then doing the combo updater will most likely solve the problem. This can be looked at differently:

    Perhaps the RAM is corrupt and won't allow certain data to be stored;

    The hard drive could have bad blocks, therefor corrupting the data of the Boot.efi.

    The most likely solution to this problem is to Archive & Install.
  • 7. Re: 10.5.6 and startup loop
    Jim Needham Level 1 Level 1 (25 points)
    That's no quick solution but in a worst case scenario it is a proper procedure.

    FYI I back up my primary terra byte drive everyday and have both internal and external alternatives to boot from. Everyone benefits from having a second boot choice when something like this happens. And how the **** can one use Time Machine to fix this (not that I will be trying!)

    Opps just got a successful install message from the stand alone... time to reboot.
  • 8. Re: 10.5.6 and startup loop
    Zan B Level 1 Level 1 (0 points)
    Archive & Installing the OS is much quicker than swapping RAM and doing a full disk scan/repair in Disk Warrior
  • 9. Re: 10.5.6 and startup loop
    Jim Needham Level 1 Level 1 (25 points)
    Hopefully no-one is suddenly pulling all their RAM out. (I have 8GB plus per) but nothing solves so many different problems like a clean install without carrying across your user data.

    I think I am starting clean with a new 8-core later this month since I have been moving baggage through several machines this year. Your advice is well thought out and reasonable for a newbie or anyone who wants to reduce the potential of wasting more time by diagnosing the actual problem than by doing the reinstall.
  • 10. Re: 10.5.6 and startup loop
    a brody Level 9 Level 9 (63,280 points)
    Maybe not, but when you can't rely on anything beyond the kernel being solid, the first step IMHO should be to restore your data back to what it was using known working data. I'm not saying hardware would be the next most obvious choice to look at or pulling RAM. Far from it. My procedure is to:

    1-1. Ensure the data is safe. If it is a full clone backup prior to the installation, restore that, or a restorable Time Machine backup. Otherwise proceed to step 2. By safe, I mean you need two copies off system of the software, ready for restoration at another time. Additionally, check if the third party applications and drivers have been tested with the operating system update in question.

    1-2. If it isn't safe and isn't accessible, recover it via Target Disk Mode if possible, and if not, with a data recovery tool. By safe, I mean you need two copies off system of the software, ready for restoration at another time.

    2. Make sure the directory is fine.

    3-1. If the directory is fine, and the system has not been compromised by third party "maintenance" applications or drivers or plugins, then try zapping the PRAM with the caveat of not doing so if the clock battery is 4 or more years old. proceed to step 3-2.

    3-2 if 3-1 does not work, then try archive and installing and applying the combo update. Proceed to 4.

    3-3. If the directory is fine, and it has been compromised by those, try the archive and install and reapplication of the previous combo update and see if those work. If they don't a rebuild of the operating system from scratch may be necessary, and reinstallation of the third party software from scratch may be necessary, while recovering the user created data immediately after the installation of the software.

    3-4 If the directory is not good, attempt repairing it, and see if the system will boot.

    4. Backup the data once you have a working system.
  • 11. Re: 10.5.6 and startup loop
    a brody Level 9 Level 9 (63,280 points)
    Mac OS X doesn't have a clean install option by the way:

    http://discussions.apple.com/thread.jspa?messageID=607614
  • 12. Re: 10.5.6 and startup loop
    a brody Level 9 Level 9 (63,280 points)
    Quicker iff the non-System level kernel files are not compromised. I've seen situations where they are.
  • 13. Re: 10.5.6 and startup loop
    Zan B Level 1 Level 1 (0 points)
    Jim,

    You're missing the point. After running a new OS update and the computer doesn't want to boot up; the most likely problem is that the update didn't take, and the OS needs to be re-installed. If you want to find out which file was corrupted during the upgrade, you can waste as many hours as you want.

    Let's say an air sensor went bad on my car. I'd know just to replace the part, rather than completely dismantle the engine to find out why the part went bad. Think logically and practically.
  • 14. Re: 10.5.6 and startup loop
    Picchu Level 1 Level 1 (0 points)
    so i ran a verify disk and it tells me a file structure corruption. and of course my back up is not working...is there anyway i can recover things off my mac such as a program or is there a program that can fix the corruption.
1 2 Previous Next