5 Replies Latest reply: Jan 23, 2009 7:47 AM by turingtest2
Karajabola Level 1 Level 1 (0 points)
Hey folks,

I have been struggling with this for a long while, I cannot seem to figure out why it works only sometimes. It has to do with compilation albums. In many cases in my collection I have a mix album mixed by a popular DJ. I would like to designate this album as a compilation, but also have the DJ show up in the artist list. For example. Paul Oakenfold's 'Live By Stadium DJ'. I want to designate that as compilation, but still have this album listed when I filter for Paul Oakenfold in the library browser. You would think that setting "Album Artist" to "Paul Oakenfold" is all I need to do. I have successfully done this on some albums, but absolutely can not get it to work for all albums and I am at my wits end trying to figure out what the criteria is. Its a computer, so I got to think this is not an intermittent problem but something I am doing wrong. I have compared numerous examples of albums sorting correctly and incorrectly and cannot identify any difference in the way the ID tag is set in iTunes. Has anyone experienced this before, and if so, what's the trick? Thanks!

17" mbp, 2.6ghz penryn, 2gb, hi-res matte, Mac OS X (10.5.5)
  • Jason Woerner Level 1 Level 1 (15 points)
    I've just started to research similar issues. What I've found so far (in my case with the Back to Mine series of DJ mixes) you need to set the Compilation option to No. This will cause the album to be sorted under the Album Artist field (the DJ in our case) as well as placing it under the same artist in the Browser view.

    You mention your desire to designate the album as a compilation. I initially did, too. But perhaps Apple is considering examples like these not to be compilations. Either an album is identified under a specific artist, or it is a compilation of artists, and therefore can not be sorted perfectly under one artist. Make sense?
  • turingtest2 Level 9 Level 9 (58,195 points)
    Setting the album artist should work fine in iTunes but unless you set the compilation flag when you put the album onto the iPod it will be listed a number of times, once for each individial artist as the iPod takes no account of the Album Artist field. See my recent post on Grouping Tracks Into Albums for details. There is also a particular problem with albums that have the same title such as the Back To Mine series (see topic One album, too many tracks). My approach is to add in the Album Artist so I have albums such as "Back To Mine - Everthing But The Girl" & "Back To Mine - Morcheeba".

    tt2
  • Jason Woerner Level 1 Level 1 (15 points)
    Thanks for the input. I have yet to get to the iPod portion of my testing. (You'd think after amassing 46000 tracks I'd have this stuff down.) Right now, I'm overjoyed to have iTunes showing albums / artists and compilations exactly as I want it to, and in a way that makes logical sense as it relates to the metadata fields within MP3s. I consider it a fault of iPods and iPhones (I have two) that they do not behave exactly as iTunes does. And don't get me started on the Remote application for the iPhone not even understanding what a Compilation is!
  • stevebrancale Level 1 Level 1 (0 points)
    Hey, do you have to actually go through each song and unclick the compilation box? When I try to do it as a whole album I don't see any compilation box to click. Let me know, thanks!
  • turingtest2 Level 9 Level 9 (58,195 points)
    stevebrancale wrote:
    Hey, do you have to actually go through each song and unclick the compilation box? When I try to do it as a whole album I don't see any compilation box to click. Let me know, thanks!

    It's on the Options tab...

    tt2