Skip navigation
This discussion is archived

10.5.6 breaks Dvorak keyboard shortcuts in Eclipse

19570 Views 72 Replies Latest reply: May 16, 2009 6:55 PM by OldGuyinCalifornia RSS
  • kzettel Calculating status...
    Currently Being Moderated
    Dec 22, 2008 2:29 PM (in response to johncarync)
    That seems to affect all applications, including the ones that work correctly. Is there a way to just change Eclipse to us Dvorak - Qwerty?
    MacBook Pro, Mac OS X (10.5.6)
  • Grey Drane Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2008 2:37 PM (in response to kzettel)
    You can set it so that Cmd-space ("Select previous input source") toggles between the two keyboards. So when you're in an app that doesn't work, you use Dvorak-Qwerty, and when you're in well-behaved apps, you switch back. (And you can see in the menu bar which keyboard is currently active if you "show input menu in menu bar".)

    It's a bit of a hassle to remember to switch back and forth, but it's hopefully just a very short-term workaround.

    HTH

    ~G
    Intel iMac 20" (the white ones), Mac OS X (10.5.6)
  • igcdivine Calculating status...
    I'm having this problem also, I contacted MS about it, and the support person said she could not reproduce it. I updated Office 2008, then updated my Mac Pro to 10.5.6 and saw the problem. I cloned my MacBook Pro, via Time Machine, and see the problem on the one with 10.5.6 but not on 10.5.5. Is this a universal problem, or does it have to do with a specific file or extension, as MS reported that they could not reproduce it? Interestingly, when I try to customize the key commands in Word 2008 back to what I can type under "tools, customize keyboard," I get the qwerty keys in the "new keyboard shortcut" window whether the key combination works as expected or not. For example, print works with command-r (p in DV), but in the window, command-r gives command-r, command-l (DV; p, qwerty) gives command-p.
    MacBook Pro, Mac Pro, Mac OS X (10.5.6)
  • OldGuyinCalifornia Calculating status...
    This is a pain. Had not noticed it because the only thing I had used since the upgrade was TextEdit and mail. But in Word 2004 it is really messed up. Instead of Bold, I get a New document, Command W (the <, key), gives the preferences pane instead of closing the window. What's even odder Command W (the W key) also gives the preferences pane.

    How do I downgrade? Or has someone found another cure?
    MacBook, early 2008, Mac OS X (10.5.6), Have other Macs in house as well
  • Necromancer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2008 5:33 PM (in response to masto)
    Same problem here.

    Random switcharoos of command-key shortcuts in Office 2004 and other apps (Carbon-related perhaps?). Sometimes, BOTH are active at the same time! Command-w and Command-comma both bring up Preferences.

    What's going on here, Apple?!?
    McBook, Mac OS X (10.5.6)
  • Necromancer Level 1 Level 1 (0 points)
    If you have an ADC account, please log a bug with Apple.
    https://bugreport.apple.com
    LemonBook, Mac OS X (10.5.6)
  • igcdivine Level 1 Level 1 (0 points)
    MS suggested removing MS preferences all com.microsoft.x and the microsoft folder in the current user preferences folder. Apple suggested trying creating a new user. Apple's did not help. MS's helps me a lot, most of my command-key combinations now work as expected; however, some are duplicated (maybe they are if not otherwise assigned), i.e., command-f and -u (DV; -y and -f qwerty, respectively) both give "find."
    MacBook Pro, Mac Pro, Mac OS X (10.5.6)
  • Guido Kollerie Calculating status...
    Currently Being Moderated
    Dec 26, 2008 11:50 AM (in response to masto)
    I tried to come up with a workaround by generating a new Dvorak keyboard mapping. Unfortunately that didn't work:

    http://kollerie.wordpress.com/2008/12/26/continued-os-x-1056-update-broke-eclips e-shortcuts/
    iMac G5, Mac OS X (10.5.6)
  • Elise Springer Calculating status...
    Currently Being Moderated
    Dec 26, 2008 4:20 PM (in response to masto)
    Crazy-making problem, in my case for Microsoft Word,... Spent hours troubleshooting Word-related stuff (removed ALL prefs, both user and general, with no luck) BEFORE it occurred to me that the culprit could be the 10.5.6 update. THANKS to google "10.5.6 dvorak" for finding this thread, and to all of you for confirming the cause. Will stay tuned!
    iMac intel 20", Mac OS X (10.5.6)
  • Grey Drane Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2008 11:22 AM (in response to igcdivine)
    igcdivine wrote:
    MS suggested removing MS preferences all com.microsoft.x and the microsoft folder in the current user preferences folder.


    I'm afraid this didn't seem to change anything for me in terms of the keyboard shortcuts.

    Maybe we'll have to wait for Snow Leopard? Q1 2009? Maybe one of the company's last Macworld announcements?

    ~G
    Intel iMac 20" (the white ones), Mac OS X (10.5.6)
  • eayars Calculating status...
    10.5.6 also breaks Dvorak keyboard shortcuts in Excel X (Yes, I was still using it). The behavior is the same as reported above in this thread: the keyboard revert to QWERTY whenever the command key is held, but doesn't seem to do so consistently. Command-S (Dvorak) works as it should, but Command-T (Dvorak) opens the "insert hyperlink" window.

    I can confirm that this problem is directly related to the 10.5.6 update, as I was using Excel immediately before the update without a problem, and it was broken after the update.

    Word X is also broken in the same way: Command-B (Dvorak) now gives me a new window, as one would expect Command-N (QWERTY) to do. Command-Q (Dvorak) quits Word, though, so at least the most useful Word command still works.

    Very annoying. I don't use Word any more, but Excel is the one worthwhile program to come out of Redmond in the last decade and Numbers doesn't match its functionality yet. And no, I am unwilling to move to the Dvorak-Command-QWERTY layout since that screws up all my non-microsoft programs.
    MacBook Pro, Mac OS X (10.5.6), Showing its age...
  • Elise Springer Level 1 Level 1 (5 points)
    I'm another person NOT satisfied with the hybrid Dvorak-with-Qwerty-command keyboard "solution". It's predictable, yes. (And, in theory, it's possible to get input-menu assignments not to be global, but rather to remain specific to a window (or is it an app?).

    But in my case, I'm doing word-processing in Word and I keystroke all sorts of things like bold, italics, and copy-paste *on the fly* while typing. These command-gestures are so habitually "in" my fingers that I cannot use Word now without getting bounced to a New document window every time I mean to apply Bold, a preferences dialogue when I try to close that new document; italic text every time I mean to copy text, and that darned unhepful "help" window (that cannot be dismissed without reaching for the mouse, grrr) when I automatically attempt to UNDO any such mischief...

    I'm temporarily using Pages for my documents, though Pages doesn't have all the features that I need as an academic, so I'm looking forward to whatever fix Apple might be able to offer us.

    Does anyone know, by the way, of a list of Carbon-based vs. Cocoa-based apps, so that I can browse for Cocoa word-processor solutions that might tide me over better? And, for what it's worth, it might be good to verify with a few more tests that the bug comes out exactly when Carbon coding is at work...

    (By the way, for anecdotal purposes, I can say that Word has occasionally surprised me with this inconsistent Qwerty-command behavior in the past. But a relaunch of the app always used to set things straight again. That's why it took me so long to suspect the OS this time around!)
    iMac intel 20", Mac OS X (10.5.6)
  • Guido Kollerie Level 1 Level 1 (0 points)
    Another failed attempt at finding a workaround. Maybe it might help others in finding a solution:

    http://kollerie.wordpress.com/2008/12/30/continued-2-os-x-1056-update-broke-ecli pse-shortcuts/
    iMac G5, Mac OS X (10.5.6)
  • Pete Siemsen Calculating status...
    Currently Being Moderated
    Dec 31, 2008 8:21 AM (in response to ossmkitty)
    I tried Eclipse 3.5M4 Cocoa. It fixed some of the keyboard problems but not all, and it had other
    obvious problems. Like, Eclipse->About Eclipse didn't do anything, and Eclipse->Preferences didn't
    do anything. I gave up on it.
  • ossmkitty Level 1 Level 1 (0 points)
    Of all the platforms that Eclipse supports, the Mac is special in that it wants preferences and about to be under the application menu. Everywhere else, these choices are in the Window menu and the Help menu, respectively (IIRC). Ancient Eclipse Mac versions didn't have them in the application menu, and then for a period of time Eclipse had them both places, and right now the Cocoa build is back to having them only in the Window and Help menus.
    Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.