4 Replies Latest reply: Jan 9, 2009 1:09 PM by omdumond
omdumond Level 1 Level 1 (5 points)
I migrated from a Macbook (black) to a new Macbook Pro (late 2008 model) a week ago. Everything seemed to work fine except that I can't write to an external USB drive (worked fine with the Macbook) from my new Macbook Pro. Disk utility indicated I only have read-only access and didn't give me a way to change the permissions. The drive still works normally (read-write) with the old Macbook.

The drive was formatted as Mac OS extended (journaled.) Both computers are running 10.5.5 when this happened. I have since upgraded my Macbook Pro to 10.5.6 but won't have an opportunity to test it with my drive till January.

I know I can re-format the drive with Macbook pro but I don't want to lose the data. I have no other storage to temporary hold the data (about 450G worth.) I tend to change computers every 6 months or so. This will continue to be a problem for me. I am looking for a nice permanent solution.

Thanks.

Macbook Pro (late 2008), Mac OS X (10.5.6)
  • nerowolfe Level 6 Level 6 (13,070 points)
    Welcome to Apple Discussions:
    You probably do not have write access to the drive, if it came from a Mac with another account.
    In a terminal run the command
    ls -al /volumes
    and see what permissions the drive has.

    You should see something like
    drwxrwxrwx 1 nero nero 16384 Dec 18 13:02 TravelDrive
    Where "nero" is the name of the user who has access to the drive. Notice that on my drive, everyone has read, write, execute privileges on the drive.

    Message was edited by: nerowolfe
  • omdumond Level 1 Level 1 (5 points)
    Then how do I change the permissions so everybody can read/write/execute all of the files in the drive? I am assuming I have to execute some command from my old Macbook (all of the files were created by it.)

    Can you tell me the specific commands I should use? thanks.
  • Daniel Ebeck Level 4 Level 4 (1,660 points)
    sudo chmod -R 777 /Volumes/flashdrive

    That will change all files on flashdrive to rwx for all users. You'll need to be logged in as an admin user and supply your password.

    An alternative is to open the info pane for the flash drive and, under the permissions tab, hit the "Ignore Permissions on this Drive" checkbox.
  • omdumond Level 1 Level 1 (5 points)
    oops, I just got back to my house after my Christmas holiday. I realized my USB driver was formated as a Windows NTFS file system.

    I tried the chmod command but it has not effect. Sorry about the confusion.