2 Replies Latest reply: Dec 30, 2008 4:56 AM by Stu.Davey
Goodfoot Level 1 Level 1 (0 points)
When I plug my iphone into my computer it says "no camera found" I have gone through all my prefs and can't find anything? My wife's phone just automatically opens iphoto and loads pics?

Any ideas?

Macbook, Mac OS X (10.5.6), 16g iphone
  • morogi Level 1 Level 1 (5 points)
    You probably installed a third-party application, like the software that came with your (new) digital camera. That application is now the default photo import app instead of iPhoto.
    Just run iPhoto with the iPhone connected and at the dialogue that asks you to use iPhoto as the default photo import app, answer "yes". This should solve your problem.

    Also, when using the dedicated photo app from your camera, answer "no" to the question "make this application the default (... whatever)" and also tick the "never ask this question again" check-mark.
  • Stu.Davey Level 1 Level 1 (0 points)
    Thanks for this. Specifically I found the solution by going into Preferences in iPhoto, and under the 'General' tab choosing "no application" under the bottom scroll option for the box labelled "Connecting camera options."
    I find I never upload images from the iPhone (the resolution is too low for more than fun snaps that I can upload directly to facebook or via email) and though I have a Canon SLR camera, I prefer to specify which program to upload images than it automatically do so. As I sync my iPhone much more frequently than I do upload from the SLR this seems the best solution for me.
    Hope this helps.