2 Replies Latest reply: Dec 22, 2008 12:48 AM by Zevoneer
NINnerd Level 1 Level 1 (0 points)
Everything on my iPod nano is just fine, however, one of my artists doesn't get listed under "Artists" on the iPod. On iTunes, it's just fine. But on the iPod, I have to search for them under album titles. Even when I go to genres, and I select the genre of the artist, it counts them in the number of artists total for that genre, but doesn't list them by name. If I select, "All albums", though, there they are.

I've tried resetting my iPod; renaming the artist, syncing the iPod, then renaming them again (to their real name) and re-syncing the iPod; clearing all the music off the iPod and adding it back - none of this worked.

What gives?

Thanks!

Dell XPS M1330, Windows Vista
  • Zevoneer Level 9 Level 9 (52,700 points)
    There are usually two things that contribute to songs not appearing under Artist on the iPod, both due to information either in or missing from the Get Info>Info tab against the song in iTunes. 1) the song is marked as part of a compilation or 2) the song has no album name associated with it.

    if the tracks are ticked in the Get Info>Info tab as part of a compilation, they will not appear under Artist on the iPod. Highlight a song in iTunes that you know is not appearing correctly on your iPod. Right click on it and choose Get Info and click the Info tab (alternatively choose Get Info from the File menu), if "Part of a Compilation" is marked untick it and afterwards update your iPod, you should find it now appears as normal. If you are using iTunes 8 and view the multiple items info box the compilations setting is in the "Options" tab. Setting "Compilations" on your iPod main menu prevents you getting lots of single artist entries when you load an album by various artists.

    Also if the tracks are missing an Album name in the Info tab, this information needs to be filled in. The no album one is a bit quirky as the songs will appear under certain circumstances (for instance I read somewhere that if you have at least two tracks with different album names the rest will appear), however the simplest remedy is just add None or Miscellaneous to all the blanks in place of a title. See this link for more detail: I don't see some of my songs when browsing by artist on my iPod
  • NINnerd Level 1 Level 1 (0 points)
    It was the "compilations" thing!!

    Thank you so much! You are my jeebus!