7 Replies Latest reply: Feb 13, 2009 12:46 PM by James Davis
ralafriz Level 1 Level 1 (0 points)
A few days ago, I had to do a archive and install. Now whenever I try to play any songs purchased from the iTunes store, it prompts me to authorize my computer. When I enter my password and click "Authorize", it tells me the computer is already authorized, yet it still prompts me to authorize when I try playing the song again.

I've tried deauthorizing and authorizing the computer, but it still prompts me every time. Anybody know what's wrong?

Macbook Pro, Mac OS X (10.4.11), iTunes 8
  • Chris CA Level 9 Level 9 (77,720 points)
  • ralafriz Level 1 Level 1 (0 points)
    That page summarizes the problem exactly, but unfortunately, none of the solutions seem to work.
  • Gareth G. Level 1 Level 1 (10 points)
    I have the exact same problem, none of the "resolutions" provided in the above link help.

    An e-mail to apple support concerning this problem has been sent.
    If they fix it I'll share their reply.

    I read (can't find the link atm) that is might help to deauthorize your computer, play back a song purchased in the itunes store on itunes and reauthorize.
    I cannot do this as I don't have any music purchased on itunes (and won't have until this is resolved) and the german itunes does not seem to carry any free music title.
    However, I did find a free episode of some TV show which I cannot even play back on itunes (due to "not being authorized").
  • Gareth G. Level 1 Level 1 (10 points)
    Update:

    I re-downloaded itunes, closed all programs, installed itunes, deleted sc info folder, restarted and it worked.
  • zaphod_beeblebrox Level 1 Level 1 (0 points)
    Ryan, It looks like you and I are in the same boat. I too had to do an archive & reinstall of 10.4 (thank you Apple for Security Update 2008-008).

    I am having the same problems iTunes/DRM. It looks like after the reinstall, the "SC Info" folder is gone. It's not in the archived OR new area of the HD.

    -rob
  • ralafriz Level 1 Level 1 (0 points)
    Ah thank you! A reinstallation of iTunes did the trick.
  • James Davis Level 1 Level 1 (5 points)
    Unfortunately, I'll need to add a "me too" to this list.

    I have followed all of the suggestions on both this and other similar threads to no avail. In my case I changed my Apple account name recently as I no longer used that old email address. I had also at about the same time upgraded the firmware for my iPod Touch.

    I first noticed that my apps for my iPod Touch weren't working. Then I noticed I couldn't play any purchased music on it. After testing I found that iTunes also couldn't play purchased music, giving me the authorize error message everyone's seen. After I read these discussions I realized that the new account name might be the problem and I changed it back. But I still have the same problem.

    I have reinstalled iTunes, I've removed the SC Info folder, I've de-authorized my computer and authorized it again and I've followed all the information I could find, but nothing is working.

    I've found that I can get my iPod apps working again by first deleting them and then downloading them from within the Touch. But as soon as I try to sync the apps via iTunes, they break again.

    At this point I don't know if it is because I recently changed my account name or if it's because of the recent iPod Touch upgrade or if my computer is fritzing out on me. But I definitely need an answer to this. Please, Apple: help us out here!