5 Replies Latest reply: Feb 9, 2009 7:01 PM by MacSacto
Felix Leiter Level 1 Level 1 (5 points)
After 10.5.6, my Imac keeps on disconnecting from the network everytime it goes to sleep, and it loses Apple TV, forcing me to set sleep to "never". And the Imac's awakening is painfully slow, with the computer hanging for over fifteen seconds.

I was wondering if anyone knew a fix for this.

Thank you!

Macbook Air HDD, iMac 24" 2.8Ghz, Iphone, Ipod Touch, Mac OS X (10.5.6), 4 G Ram
  • Kappy Level 10 Level 10 (250,695 points)
    If this is a wireless connection, then it's normal. Airport card is turned off during sleep.
  • Felix Leiter Level 1 Level 1 (5 points)
    But this didn't happen before 10.5.6. I could continue to use my Apple TV and my network even while the computer was sleeping.
  • Carolyn Samit Level 10 Level 10 (95,975 points)
    Hi Felix,

    Kappy is usually spot on but I respectfully beg to differ on this issue. Airport does not turn off when you put the iMac to sleep. And, it can take up to 10 seconds for the iMac to "wake up" and acknowledge the Airport network. It can, however, disconnect from Apple TV in sleep mode. For help with AppleTV go here: http://discussions.apple.com/forum.jspa?forumID=1185

    Also, the more apps you have open when you put the iMac to sleep, the longer it takes to wake up.

    You could try deleting the Airport preference file: com.apple.airport.plist
    It's here; /Users/YourName/Library/Preferences. Drag that file from the Preferences folder to the Trash, empty the Trash and reboot. Your iMac will create a new pref file for you.




    Carolyn

    Message was edited by: Carolyn Samit
  • Alexandre Level 3 Level 3 (850 points)
    I find, it does occasionally happen, but can only assume that this has indeed something to do with the 10.5.6. And I think the reason is improved security.

    You will find, if you "turn off" airport (if your connection is down), then open system preferences/network and unlock the padlock. Then open the "assist me" which may ask for another unlocking, then opens the "network setup assistant". now STOP.

    Simply turn "on" airport from your finder bar and it will find your wifi network instantly. watch the network window (on system preferences which should list your wifi on the right and show a green light (with the word "connected") on the list on the left. If the left green light has the word "self assigned IP" then you are not connected. So, now, go to my step above (where I put STOP) and press "continue", with airport running.
    There may be a pop up window (over the "network setup assistant")and at the same time, the green light appear in the other "Network" window.

    NB: A restart will also work, but the above works every time for me, when it happens; I can only assume, that the new security put the wireless (airport) connection after applying the firewall (you are not on "stealth mode" by any chance?)
  • MacSacto Level 1 Level 1 (0 points)
    I'm having the same issue with airport disconnecting when my Mac Mini goes to sleep. It never did that before the most recent software update to 10.5.6.