9 Replies Latest reply: Mar 4, 2009 6:25 AM by guant
ClayH Level 1 (0 points)
My wife and I both have Scrabble for our iPhone 3Gs. Our hope, of course, was to be able to play against each other on our WiFi network. We have an Airport Express that works fine with everything else.

Every time we try to play Scrabble on our phones on the WiFi network, the game quits out, claiming "connection lost" between players. I've searched Google, and while people tend not to have favorable about the Scrabble game in general, I cannot find any mention of this problem or how to address it. For the record, the app works fine in single player for both of us.

We also tried to connect on another WiFi network. This leads me to believe that the problem might be with the Scrabble install on one of our phones. I've uninstalled and reinstalled it on my phone, but not on hers. The problem persists, unfortunately.

Does anybody have any suggestions about how to fix the WiFi multiplayer in Scrabble? What might we need to do in order to get it to work for us?

Thanks for the help.

iPhone 3G v. 2.2, Mac OS X (10.5.6)
  • Jason L Community Specialists
    Hi ClayH,

    Try removing the app and reinstalling it on your wife's phone.
    You can also try Resetting Network Settings on the iPhone, go to Settings> General> Reset> Reset Network Settings.

    Make sure both the iPhone and scrabble are updated with the latest versions of software available.
    http://www.apple.com/iphone/softwareupdate/
    If there is an update for scrabble you can get it from the App Store on the iPhone.

    This article: http://support.apple.com/kb/TS1702 provides general tips for troubleshooting issues with apps.

    -Jason
  • ClayH Level 1 (0 points)
    Thanks, Jason. We both have the updated software, both for the iPhone and for Scrabble. I reset the Network Settings on both phones. They connect in multiplayer and the connection will hold for 3-4 turns, but then it always quits. I'll try uninstalling and reinstalling on both of them again tomorrow.

    I appreciate the prompt response. Happy New Year!
  • ClayH Level 1 (0 points)
    I'm afraid that none of the suggestions worked. Evidently, something is just interfering with the connection between our phones. Could this be caused by security setting on the Airport Express or anything? Both phones successfully connect to the WiFi network. I'm starting to wonder if one of them doesn't have a problem with its wireless network card or something...

    Any other suggestions?
  • ClayH Level 1 (0 points)
    Sorry to keep answering myself here, but I figured out that it is the Airport Express or one of the settings we're using for the network that is preventing the game from working. I created an Ad Hoc wireless network on my laptop and we can connect and play through that without a problem...

    The other network that we tried it on was configured the same was as the one here that is causing the problem. Any idea what the problematic setting might be?

    Thanks, Clay
  • Joe Vorndran Level 1 (0 points)
    Clay, did you ever figure out how to resolve this issue? My wife and I have the EXACT same issue and it is VERY annoying. We don't lose wifi connection on the browser or any other apps, so clearly this is a Scrabble issue, possibly in conjunction with router settings...
  • Kims50 Level 1 (0 points)
    Joe, My husband and I have the same issue with our new iPods. If you have found an easy solution, I hope you post it. Thanks!
  • Kims50 Level 1 (0 points)
    P.S. Like Clay, I set up an Ad Hoc wireless network on my laptop and we can play with no lost connections. Perhaps someone has an easier solution.
  • zp74 Level 1 (0 points)
    i was able to create an ad hoc network and play multiplayer without any problems, but i'd still like to be able to use the multiplayer without having to always establish an ad hoc network. i never have any troubles with my iphone when it joins my wifi network - are there things i can change within my network configurations to allow for us to play without the connection always being lost over the normal wifi network?
  • guant Level 1 (0 points)
    I'am having the same issue, it will connect for a few turns then disconnect. I really don't want to setup a ad hoc network just to play this game on my local network. Does anyone know if there is a fix? If not any way to get your money back?