7 Replies Latest reply: Jan 4, 2009 4:34 PM by PAHU
harmlessgoat22 Level 1 Level 1 (0 points)
Ok, so I've got a new Macbook Pro, and I'm loving it, but I'm having trouble viewing a printer. I have the settings on the family computer as "Share this printer", but it still doesn't show up on my Mac. Help is greatly appreciated.

Macbook Pro, Mac OS X (10.5.6)
  • PAHU Level 6 Level 6 (15,470 points)
    Is the family computer a Mac or a PC?

    PaHu
  • harmlessgoat22 Level 1 Level 1 (0 points)
    It's Windows
  • PAHU Level 6 Level 6 (15,470 points)
    Okay. In order to 'see' the printer share provided by Windows, you need to ensure that both the Mac and PC are on the same IP subnet. The subnet is determined by your subnet mask. If you have an IP address of 10.0.1.2 and a subnet mask of 255.255.255.0 on your Mac, then your subnet is 10.0.1 and your network address is 2. In order to see the shared printer on the PC, it would also need to have a subnet of 10.0.1.x, where x is a different number to your Mac.

    If your Mac and the PC are on the same subnet, then you should be able to choose to Add the printer and select Windows. You should see the Workgroup name used by the PC (which could be Workgroup or MSHome) and when you click the workgroup name you should see the PC name.

    If you still cannot see the family PC, then open your Finder and click the All icon under Shared. Do you see the family PC's workgroup name here?

    PaHu
  • harmlessgoat22 Level 1 Level 1 (0 points)
    They are on the same subnet. When I go to the Printer thing. I go to the Windows tab. I click "workgroup", which is in the 1st column. Then I click the name of the computer with the shared printer, but nothing shows up in the third column, even though there is a printer connected to that computer, and it is marked as "share this printer".

    When I go to the finder, there is no All icon, but now, the requested computer is showing. It must have been something I had been doing last night with fiddling around and all. However, it is continuously saying "Connecting" even though I have shared folders in there.

    Thank you for being so patient, this probably is just something stupid, but I really need to get this working. Thanks!!!

    Message was edited by: harmlessgoat22
  • PAHU Level 6 Level 6 (15,470 points)
    It sounds like you have an issue with accounts. You may find the Guest account is disabled and this is stopping you from getting any further. At this stage I would create an account on the PC that you can use for the Mac. It can be a standard account and have a simple password, such as mac. Then when you click the PC name after selecting the workgroup, I would expect you to be prompted to authenticate to the PC. This would apply to connecting to the folder share also.

    PaHu
  • harmlessgoat22 Level 1 Level 1 (0 points)
    There are several accounts on the computer. It never asks me to authenticate when I click the computer name. Why would adding another account change it?
  • PAHU Level 6 Level 6 (15,470 points)
    Adding another account won't help. I suggested it because it sounded like there was no account for the Mac to use, since you were not being prompted. Thinking about it now it sounds like the Guest is enabled, and defaulting to this account, however there is some access issue with this account. So you could try disabling the Guest account and seeing if you get prompted for account details after selecting the PC name.

    Could you also confirm which version of Windows and what service pack is being used.

    PaHu