Previous 1 3 4 5 6 7 Next 91 Replies Latest reply: Oct 15, 2009 3:57 PM by Matthew Rosen Go to original post
  • hollistonma Level 1 Level 1
    Quomp,

    Not sure what the issue is but in my setup now, I only have one GMail inbox (at top of pane, under Mailboxes). When I click on an e-mail from my Gmail account using Mail.app, it instantly shows it being read in mail.app. On GMail, using my browser, it will show up as read as well. Perhaps your synchronization setting are set at too long an interval?

    Try manually synchronizing and see if you get a change on Gmail using your browser.
  • furntar Level 1 Level 1
    hollustonma,

    I bet since GMail, Calendar, and all Google Apps have moved out of Beta today that GMail and Apple Mail are now playing nice. I'm going to check it out for myself and test it out and post results. I've been using Safari with my Google Notifier to check my mail. It'll be nice if this problem was resolved so I can switch back. If only Apple Mail could get support for Starring messages.
  • Wondermonkey2k Level 1 Level 1
    Still doesn't work. I messed with the IDLE settings like someone else mentioned. If I read it on the iPhone it doesn't show as read in Mac Mail, unless I restart mail. As soon as you restart mail, it shows as read. There has to be something fundamentally different in the way mail checks for new mail upon first start up as opposed to how it fetches mail while it's open.

    Really frustrating.
  • Fugazer Level 1 Level 1
    I have the same problems.. I can only get a 'refresh' of my Gmail account if i manually click through all my created folders (labels) in Apple Mail.
  • iMacOregon Level 1 Level 1
    I also have the same annoying issue. I have the iPhone 3.0, Apple Mail 3.6 and use GMail as my primary email. iPhone and GMail seem to sync nicely. Isn't the iPhone and Mail suppose to sync via MobileMe? Perhaps that is the culprit?
  • Fugazer Level 1 Level 1
    I think I fixed my problem...

    I decided to STOP using Apple Mail rules with my Gmail IMAP account.

    I then recreated these rules in Gmail as Filters so they go to the correct mail folder (label). After a restart of Apple Mail I started receiving mail in these folders in my Apple Mail instantly.. All my mail folders are now sync'ing up by the second... But then I was getting duplicates in by Inbox.

    To solve this, I edited my Gmail Filters and checked the box “Skip the Inbox (Archive it)”.. This will stop Gmail from putting the label “Inbox” on all incoming messages.

    So after much undocumented playing around this worked for me.

    Looks like I'm finally set after a month.
  • AppleIIme Level 1 Level 1
    I don't think it's just Google - I use SmarterMail on my own domain, and I too have the problem where mail is not being marked as read in Apple Mail via IMAP, even when I have read it on the server or iPhone.

    COME ON APPLE!

    I suggest anyone who hasn't already, report this to Apple directly, as I doubt they bother to read this thread every day: http://www.apple.com/feedback/macosx.html
  • Nikos Level 1 Level 1
    Same issue here on my Mac Pro since December. Apple mail and Gmail work fine on my other 3 macs with exactly the same configuration.

    Waiting for Snow Leopard to do a clean install hoping the issue will not re-appear.
  • Scott2Loud Level 1 Level 1
    I found myself here as well after trying to get my MBA, my iphone and my Imac to all play nice together via IMAP. I use smartermail mail server on personal domain and it all worked well except the not marking the inbox as read issue. Oddly enough, I disabled all my rules in Apple Mail, sent a message read it on my iPhone and it worked! I reactivated my rules and for some strange reason, everything is working perfectly.
    Give that a go, disable your rules..... hope this works out for you as it has for me.
  • AppleIIme Level 1 Level 1
    Disabling rules didn't work for me - the message still shows unread in Mail even when read on the iPhone. How did you 'disable' rules - just untick them all?
  • Scott2Loud Level 1 Level 1
    I Did, I just unchecked them.... closed the mail prefs window, and It has been working. Since I have rebuilt the rules to move the messages on an IMAP folder and it seems to still be working.
  • pardthemonster Level 4 Level 4
    Hopefully this will be fixed in Snow Leopard for it has been a while now!
  • Lebsky Level 1 Level 1
    This issue has been resolved ever since I upgraded to Snow Leopard.
  • Erich Meatleg Level 2 Level 2
    same here!
    I'm happy..
    I guess it was just Mail after all.....
  • doogald Level 1 Level 1
    Yep, since the upgrade it is suddenly all ok with me.
Previous 1 3 4 5 6 7 Next