10 Replies Latest reply: Jan 7, 2009 2:28 PM by Jeremy P
Serk Level 1 (0 points)
I have backups going back to March 2008 on an external USB drive. Recently, there was an error message in my time machine status bar that a backup had been interrupted. After that, TIme Machine stopped backing up. I repaired my time machine backup disk using disk utility (and it found and repaired an error that there were an "Incorrect number of Access Control Lists"). I then reselected my external drive as my backup disk. Time machine is again backing up correctly. Moreover, my time machine preferences show that my oldest backup is, in fact, from March 2008, and when I mount the sparsebundle from the USB drive, all my old backups appear. However, when I actually enter time machine, none of the older backups appear. In fact, none appear at all. Only "today" is visible. Any idea how I can make time machine recognize and view all of my old backups?

13" Macbook, Mac OS X (10.5.3)
  • patrickm1965 Level 1 (10 points)
    I'm having the same problem. Copied the sparsebundle files over to a new HD, and it appears to back up fine and recognize the old sparsebundle files, but when you enter time machine, you can't see anything past the current window.

    I've seen others with this problem on here but no solutions. The only Apple solution I could find is to upgrade to 10.5.6, which I have already done, but to no avail.
  • Jeremy P Level 3 (740 points)
    So when you say that Time Machine is again backing up correctly, you can't see those backups either?
  • Serk Level 1 (0 points)
    That's right. Time machine preferences tells me, correctly, when the last backup occurred. It appears to be backing up regularly (and I hear the disk spinning, etc.). But when I enter Time Machine, no backups appear. I am also running 10.5.6.
  • xl600 Level 1 (0 points)
    I'm seeing similar behavior. My 100GB time machine partition was out of space and I didn't want to see a bunch of old backups lost. So, since the partition was on a 500GB drive, I simply repartitioned the time machine partition to 250GB.

    Now, I'm seeing two very disturbing behaviors:

    1. Finder no longer displays any contents of the time machine partition. Path finder though can see everything that was there before partitioning.
    2. Time machine reports that there are no backups.

    Why on Earth would repartitioning cause this behavior when no data was erased and no changes were made to the time machine configuration? And more importantly, how do I get time machine to see and continue the backup set?
  • patrickm1965 Level 1 (10 points)
    Time Machine backs up normally and it indicates the last backup and first backup as normal. All backups are in the sparsebundle going back to March. But when I enter TM, I only see my current desktop.
    What's up with that?!
  • VA2020 Level 4 (3,450 points)
    Open Finder and then click the Time Machine icon. If nothing is open, you are at your desktop and clicking the TM icon will display as such.

    P.S. Might want to start a new thread next time to get more responses. You questions isn't really related to the thread topic in this case.
  • Jeremy P Level 3 (740 points)
    I don't have anything concrete to offer, but if Time Machine is creating new backups and you can view those through Finder, the problem would appear to be with the Time Machine browser. In your situation I would try:

    1. Turning Time Machine off at the big switch in the system preferences and then back on again.

    2. Trashing the Library/Preferences/com.apple.TimeMachine.plist file.

    3. Seeing whether you can browse to the backups using the Browse Other Time Machine disks option.

    I take it this problem didn't start when you upgraded to 10.5.6?
  • Serk Level 1 (0 points)
    Great suggestions. I tried this, but still no luck. If it adds any information, I tried the "Browse Other Time Machine Disks" option (holding down the "alt" key while selecting time machine in the menu bar), and it did not even recognize my backup disk. That is strange, because Time Machine purports to keep backing up regularly, like normal, I just can't see any of the backups in Time Machine. Again, when I mount the backup disk, all the backups appear to be there.
  • g5user Level 1 (0 points)
    I have a similar problem, with a slight twist.
    Installed Time Machine January 2008.
    The Apple store installed 10.5.6. November 2008.
    Time Machine will only go back to the date of the 10.5.6 installation.
    In console or terminal mode there are some directories and files are there on the backup HD. Although I have not found the original baseline backup yet from the console mode.

    Apple support call in reported that a product specialist said the only thing to do was erase the backup HD and start over, that the 10.5.6 install had been a "new" install and the backups were no longer going to be accessible. One way to cut down on support calls is to to limit the support delivered.

    Found several December 2008 references to changing permissions on "Mac address" based on ethernet card 16 byte file.
    "Note the name of the file that begins with a period and has 12 characters in the name, such as ".001b6397c156" mentioned in the quote above"
    This permission was r-------- to begin with. I did a chmod a+r and a+w.
    A number of ways on the web to do that.

    But this has not changed the behavior, but I have not rebooted yet.
  • Jeremy P Level 3 (740 points)
    The key issue with regard to the Apple support recommendation is the circumstance in which the 10.5.6 install was made. If it was an upgrade of a functioning system made by one of the normal methods, Time Machine should be unaffected. If it was a completely new installation (presumably because of problems) then Time Machine would start a new backup directory and the old one should be accessible using the Browse Other Time Machine Disks option (provided, I think, that your computer name hasn't changed). In neither case can I see the the need to reformat the disk.

    Otherwise you do have a problem with which I can't assist.