5 Replies Latest reply: Jan 5, 2009 1:47 PM by tmanning
jerseyjezebel Level 1 (5 points)
I just bought my 120GB ipod last week. It was working fine, but now the album art that shows up next to each album under "Artists" is not showing up. The art is there if I select a song from one of those albums. This didn't happen before...is there something wrong?

Also, I was listening to a playlist on shuffle, and when I clicked to go to the next song, it kept skipping to the next song like it was stuck in that mode. What's going on with that?

PC, Windows Vista
  • Jeff Bryan Level 9 (61,790 points)
    It's likely that the artwork cache is corrupted.

    It's a simple fix by unchecking "display album artwork" in the music preferences section when your iPod is connected and click "apply". Then sync your iPod.

    Then check "display album artwork" in the music preferences section when your iPod is connected and click "apply". Then sync your iPod again.

    This should resync the album artwork to the iPod.
  • jerseyjezebel Level 1 (5 points)
    Where is the music preferences section? I looked all over itunes. Thanks!
  • Jeff Bryan Level 9 (61,790 points)
    When you connect the iPod the summary screen should automatically open.

    If you click on the 'music' tab, you will see the options to:

    "display album artwork on your iPod".
  • 17matt Level 1 (0 points)
    I have sort of the same problem. Album art is showing with cover flow and when I choose a song to play from cover flow. When I have the ipod in shuffle song mode, the cover art does not show up in the now playing screen. I am using Winamp Pro.
  • tmanning Level 1 (0 points)
    I dunno if this is for every track or not. You might wanna check to see if album artist field is populated. I think there is some sort of heirarchy on itunes where they used album artist over artist. If you have different album artist then artist it might not have loaded the album art.