Skip navigation
This discussion is archived

Disable Firewire?

6100 Views 24 Replies Latest reply: Sep 15, 2009 5:29 PM by bookemdj RSS
1 2 Previous Next
Davidaz Calculating status...
Currently Being Moderated
Jan 3, 2009 9:57 AM
I have a G4 MDD Dual 1.0Ghz. I suspect my firewire hardware on the mainboard is defective. I don't care since I have no firewire devices. Here's my problem, upon a cold start the firmware/software checks all machine functions, well mine hangs on the blue screen for 4-5 minutes (checking firewire?) every time I turn it on. Is there a way to disable the firewire (hardware) or disable the firmware/software check at startup? This delay in startup (I can only assume it's at the firewire check) has become annoying.
iMac 24" 2.8GHZ *** iPhone 3G 16GB Black ***, Mac OS X (10.5.6), G4 MDD Dual 1Ghz 22" LCD Display
  • Kappy Level 10 Level 10 (221,190 points)
    Currently Being Moderated
    Jan 3, 2009 10:48 AM (in response to Davidaz)
    Sorry, but that has nothing to do with your Firewire ports. You have some corrupted files involved in the login that's causing your delay, I suspect. Try creating a new user account. Disable automatic login, then restart the computer. At the login screen select this new account instead of your usual account. If there's no delay, then you indeed have problems with one or more files associated with your normal account's login.
    Mac Pro 2.66 Ghz; MacBook Pro C2D 2.33 Ghz; MacBook Pro 2.16 Ghz, Mac OS X (10.5.6), Intel iMac C2D 17 "; MacBook 2.0 Ghz; 30 GB iPod Video (Black); iPod Nano 2 GB
  • Kappy Level 10 Level 10 (221,190 points)
    Currently Being Moderated
    Jan 3, 2009 11:08 AM (in response to Davidaz)
    I don't doubt your Firewire ports may not be functioning, but that would not cause the problem since it's occurring at the login screen. Hardware tests are done prior to that before the login screen appears.
    Mac Pro 2.66 Ghz; MacBook Pro C2D 2.33 Ghz; MacBook Pro 2.16 Ghz, Mac OS X (10.5.6), Intel iMac C2D 17 "; MacBook 2.0 Ghz; 30 GB iPod Video (Black); iPod Nano 2 GB
  • Kappy Level 10 Level 10 (221,190 points)
    Currently Being Moderated
    Jan 3, 2009 8:57 PM (in response to Davidaz)
    The blue screen means you've gotten past any hardware checks which occur when the gray screen is visible. If you have nothing connected to the Firewire ports then get to the blue screen you are at the point where the OS is starting the initialization process and loading the GUI. As I said your problem is elsewhere. What you might consider doing is the following:

    How to Perform an Archive and Install

    An Archive and Install will NOT erase your hard drive, but you must have sufficient free space for a second OS X installation which could be from 3-9 GBs depending upon the version of OS X and selected installation options. The free space requirement is over and above normal free space requirements which should be at least 6-10 GBs. Read all the linked references carefully before proceeding.

    1. Be sure to use Disk Utility first to repair the disk before performing the Archive and Install.

    Repairing the Hard Drive and Permissions

    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger.) After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list. In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive. If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported, then quit DU and return to the installer.

    2. Do not proceed with an Archive and Install if DU reports errors it cannot fix. In that case use Disk Warrior and/or TechTool Pro to repair the hard drive. If neither can repair the drive, then you will have to erase the drive and reinstall from scratch.

    3. Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When you reach the screen to select a destination drive click once on the destination drive then click on the Option button. Select the Archive and Install option. You have an option to preserve users and network preferences. Only select this option if you are sure you have no corrupted files in your user accounts. Otherwise leave this option unchecked. Click on the OK button and continue with the OS X Installation.

    4. Upon completion of the Archive and Install you will have a Previous System Folder in the root directory. You should retain the PSF until you are sure you do not need to manually transfer any items from the PSF to your newly installed system.

    5. After moving any items you want to keep from the PSF you should delete it. You can back it up if you prefer, but you must delete it from the hard drive.

    6. You can now download a Combo Updater directly from Apple's download site to update your new system to the desired version as well as install any security or other updates. You can also do this using Software Update.
    Mac Pro 2.66 Ghz; MacBook Pro C2D 2.33 Ghz; MacBook Pro 2.16 Ghz, Mac OS X (10.5.6), Intel iMac C2D 17 "; MacBook 2.0 Ghz; 30 GB iPod Video (Black); iPod Nano 2 GB
  • Kappy Level 10 Level 10 (221,190 points)
    Currently Being Moderated
    Jan 4, 2009 9:41 AM (in response to Davidaz)
    If you cannot do an Archive and Install since you do not have the installer disc, then there's really little you can do. If you have a Leopard compatible version of Disk Warrior (4.1) then you can use it to repair the directory structure, but that will not fix a corrupt file problem which is more likely the problem you are having. If it's a cache related problem then you might fix it by removing all system and user caches then rebooting. You can use a tool such as TinkerTool System, Onyx, Cocktail, etc. to clear all system, user, and font caches. Restart immediately. You could also try the following instead:

    You will need to type some Unix commands. If you are not comfortable with this, I don't know of anything other than a re-install. But if you are careful, you should be OK. I recommend you print this out in a largish mono-spaced font so you don't miss any spaces (or add extra ones). Note that case is important.

    Be careful. Some of these commands are dangerous, since you are going to be root.

    Start up in Single-User mode by restarting the computer. After the chime press and hold down the COMMAND-S keys until you see white text on a black background. When this has finished you will see a prompt ending in '#', although there may be other messages. Enter the following commands after the prompt:

    /sbin/fsck -fy


    Press RETURN. Wait a few seconds for 8-10 lines of output. If the last line says repairs were carried out, repeat this command until you get a message 'The volume <yourdiskname> appears to be OK'. Then continue with:


    /sbin/mount -uw /
    cd /Library/Preferences
    rm com.apple.loginwindow.plist
    rm com.apple.windowserver.plist
    cd /Library/Caches
    rm -r *
    cd /System/Library
    rm Extensions.mkext
    cd /System/Library/Caches
    rm -r *
    reboot
    Press RETURN after each command.

    This should now take you to a proper login screen after the normal boot sequence. You should then Repair Permissions by using Disk Utility (in your /Applications/Utilities folder).
    Mac Pro 2.66 Ghz; MacBook Pro C2D 2.33 Ghz; MacBook Pro 2.16 Ghz, Mac OS X (10.5.6), Intel iMac C2D 17 "; MacBook 2.0 Ghz; 30 GB iPod Video (Black); iPod Nano 2 GB
  • paulerskine Calculating status...
    Currently Being Moderated
    Mar 3, 2009 7:43 AM (in response to Kappy)
    hi all,

    well, I hate to say it, but I think Davidaz is right: it is a hardware, specifically FireWire problem. I have the exact same issueand I know for a fact my FireWire is dead. further more, I know the day my FireWire died and the day my computer started to hang for 7 min at startup was one in the same. you see, I made the mistake of trying to plug a powered up harddrive into a powered up mbp. this wouldn't have been a problem except I accidentally had the FireWire 800 plug upside down. I didn't cram it in, just tried it. when it didn't work, I flipped it over, but it was too late. my firewire and mbp would never be he same.

    anyways, all that to say, I have the exact same problem. the grey (or white as some have called it) screen davidaz is talking about is before the blue almost to login screen. it has nothing to do with permissions, it is a hardware issue.

    that being said, I do t know how to fix it except for replaci g the blown out FireWire chip. I'd lime to disable it completely, but I don't know unix and have no idea where to begin (well after I get to the command prompt). I know there are ways of disabling onboard components in BIOS but I'm not sure about EFI. Does anyone know? it would be much appreciated. thanks!
    mbp 15" 2.2ghz, Mac OS X (10.5.6)
  • paulerskine Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2009 10:10 AM (in response to Davidaz)
    Okay, I had the same problem and finally found an answer. It totally worked and my mac is waking, sleeping, and starting up way better again. And, for some reason, the battery life seems to be more stable. Not sure why, but I'm not complaining. Here's the solution:

    Go to:
    (Harddrive) > System > Library > Extensions

    Find everything that looks like IOFireWire*.kext

    for me, it was the following files:

    IOFireWireAVC.kext
    IOFireWireFamily.kext
    IOFireWireIP.kext
    IOFireWireSBP2.kext
    IOFireWireSerialBusProtocolTransport.kext

    Take these files and copy them somewhere else. I put them in:

    (Harddrive) > System-disabled > Library > Extensions

    Just so I'd remember where they originally went. Notice that when you grab them and drag them from the Extensions folder to a new folder, OSX automatically does a copy command rather than a move command, so you will have to manually delete these from the System > Library > Extensions folder after you "move" them to a new folder. (I'm assuming a little trick so we, the users, don't screw ourselves )

    Double check these files are no longer in (Harddrive) > System > Library > Extensions . If they're gone, then restart your computer. It should work great.

    This totally worked for me and, like I said, makes my computer feel like new (kind of) again. Or at least an expensive MacBook.

    Good luck.
    mbp 15" 2.4ghz, Mac OS X (10.5.6)
  • Patrick 01 Level 1 Level 1 (80 points)
    Currently Being Moderated
    Mar 30, 2009 7:43 PM (in response to paulerskine)
    Just found your thread, my firewire failed (apple test disc & system profiler) and sleep does not wake, startup is 5 min+ on leopard.

    I'm going to try to find and disable the firewire extensions you mention and post back. This is on a G4 MDD Dual 1Gig
  • Patrick 01 Level 1 Level 1 (80 points)
    Currently Being Moderated
    Mar 30, 2009 8:22 PM (in response to Patrick 01)
    This worked for me! Thanks OP!

    Removed the firewire extension and may I dare say Leopard startup mops the floor over Tiger . .
    I can sleep again without fear of not waking!
    (even have a spare pci firewire card to install!)
    Live on G4 . . . die another day!
  • twtyler Calculating status...
    Currently Being Moderated
    Jun 10, 2009 11:52 PM (in response to paulerskine)
    I had the same problem, dead firewire port, taking 6 minutes to boot...your solution solved my problem. Thanks much!

    Todd
  • Patrick 01 Level 1 Level 1 (80 points)
    Currently Being Moderated
    Jun 11, 2009 10:14 AM (in response to twtyler)
    I finally replaced my logic board., but this did work for me in between.
    G4 MDD, Mac OS X (10.5.6)
  • Michael Stevenson Calculating status...
    Currently Being Moderated
    Jun 19, 2009 9:49 PM (in response to Davidaz)
    This problem just hit my MBP last night after plugging in an old PowerMac G4 booted into Firewire Target Disk Mode. I'm afraid that a motherboard replacement isn't possible for me right now.

    Could a third party Firewire ExpressCard function without OS X's built-in Firewire extensions?
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.