9 Replies Latest reply: Apr 15, 2009 11:47 AM by Katrina S.
lmj29 Level 1 (0 points)
I have been waiting forever for The Dark Knight movie to be available for rent and finally it is. I went in to itunes yesterday and rented it. It started downloading and about 3 hours later it was almost complete when the description changed from downloading to processing file. Then an error message popped up stating, +"We could not complete your itunes store request. An unknown error occurred (-42110). There was an error in the itunes store. Please try again later."+ I tried to resume the download a couple of times and the same error appeared. The final time it timed out.

Figuring itunes was down or something, I left it alone. This afternoon I went in to resume again hoping the problem had somehow resolved itself, but the same error message is still coming up. I downloaded a few movies just a couple of days ago and everything worked fine.

Side note: I have AVG, but lately Norton has been installing on its own from a source I cannot figure out. I checked to see in add/remove programs and sure enough, it was frickin installed again! I removed/uninstalled it, but the itunes problem still persists. Also, itunes is currently up to date.

I've waited so long for this movie! I can't stand that I'm still waiting...its so frustrating! Any help anyone can give is much appreciated! Thanks!

Message was edited by: lmj29

Dell Studio 17 Laptop, Windows Vista
  • Katrina S. Level 7 (24,095 points)
    I loathe Norton. See if you can get rid of it using the Symantec removal tool.

    http://service1.symantec.com/Support/tsgeninfo.nsf/docid/2005033108162039?OpenDo cument
  • lmj29 Level 1 (0 points)
    I can't stand Norton either. I tried to use the removal tool, but you have to enter your security key, etc. I guess its only for people who bought Norton, which I didn't. The free version of Norton is what keeps popping up on my computer without me downloading it. Too weird.

    Anyway, thanks for the suggestion!

    As far as the movie rental goes...it has disappeared from Downloads and never actually downloaded. I just checked my bank account and they charged me for the rental. UGHHHH!!!
  • Katrina S. Level 7 (24,095 points)
    I had a devil of a time getting Norton off a Win98 PC years ago. I had to use regedit and get rid of every key that had Norton or Symantec in it, and there were plenty....plus some other stuff I've blocked from my memory.

    Anyway - I thought that removal tool was supposed to work for even expired versions. I guess not?

    On the video rental, see if you can get the DL to start again using these directions. I know it's not the same error number you're seeing, but it might work. If it doesn't, contact iTS support from the link in the article.
  • lmj29 Level 1 (0 points)
    I tried deleting the files then re-downloading, but no luck. 5-6 minutes from completion, the download stops and the same error message pops up. I'm going to report the problem to tech support and see what they say. I appreciate the help though...thanks!!

    While I'm waiting for a response from them, I would appreciate any other suggestions/ideas anyone might have. Thanks!!
  • nolegirl98 Level 1 (0 points)
    I have had this same error on 3 different rentals. Apple support has not been able to help me. They finally ended up refunding me my rental cost. Did you ever get some answers and results? I would really love to be able to rent movies again! I will check the norton on my pc and see if that helps while I wait to hear back....thanks!
  • lmj29 Level 1 (0 points)
    These are the instructions I received. The movies downloaded immediately.

    +You will need to follow these steps to resolve the issue.+

    +- Sign out of iTunes by going to the top menu bar then going to Store and clicking on Sign Out+

    +- Quit iTunes+

    +- Follow the instructions in the "Remove the SC Info folder" section of this article: 

    +- After removing the SC Info folder, reopen iTunes.+

    +- Sign into iTunes by going to the top menu bar then going to Store and clicking on Sign In+

    +- Now go to Store again on the top menu bar and go to Authorize Computer.+

    +- Choose Check for available downloads from the Store menu.+
  • trumpeter1 Level 1 (0 points)
    I had the same problem, and lmj29's instructions worked perfectly. Thank you for posting the resolution.
  • supergirl8765 Level 1 (0 points)
    You are my hero!! I had the same problem and have been trying to figure it out all day! THANK YOU!
  • Katrina S. Level 7 (24,095 points)
    Glad to see it got sorted!