Previous 1 2 Next 23 Replies Latest reply: Mar 19, 2009 4:59 PM by luvlabs
digitalgeist Level 1 Level 1 (0 points)
I am literally inches from my router and the iPod Touch seems to connect to it - I get the full signal bars in the top left corner, but incessantly get the "Safari cannot open the page because it is not connected to the Internet." window. This not only happens at my home, but I have tried 3 separate locations (a free coffee shop wifi connection and my connection at work as well) and no luck at all three.

Why doesn't this work? This seems like a common problem looking at the forums here. Is a fix coming?
My Mac Pro and XBox connect to the same router no problem. This is an iPod Touch issue.

Mac Pro, Mac OS X (10.5.6), 2x2.66 Intel Core Duo, 8GB RAM
  • Jobiwan Level 1 Level 1 (15 points)
    It sounds like your Touch is connected to your WiFi access point.

    To confirm this, go to Safari on your Touch and enter the following into the address field:

    If you get to the Google Home page, then you are connected to the internet. The problem is with your DNS settings.

    Go to the settings page on your touch and select Wi-Fi. On the list of networks your wireless router's SSID should be there with a tick beside it. (If it is not ticked, select it) On the other side of the same line there is an arrow inside a circle. Press this to expand more info.

    On the top section headed up "+IP Address+" you will most probably have DHCP selected.

    If this is the case you will not be able to enter anything into the +IP Address, Subnet Mask+ and Router fields. They should have values supplied by your router (if you have the DHCP Server set on in your router). This is ok.

    Look at the next field DNS. This may be blank, but should have a value supplied by the router. It may be the same value as in the Router field or it maybe the value you typed into the DNS or +Primary DNS+ field that you typed into your router when you set it up.

    The DNS field should contain the IP address of your ISP's Primary Domain Name Server (Hence DNS). You should have this info in the information you got from your ISP, but if not you can get it from their helpdesk. Your ISP's DNS is best to use when at home as theoretically closest and will hopefully give you better browsing performance.

    If you don't have the above info to hand, you can use either of these OpenDNS addresses: or

    You should make a note of these in the notes app on your touch. Because when you are out and about you will need them. I would use these in any network except your home one.

    Anyway, select one of these addresses and type it into the DNS field on your touch and then press the return key.

    Press the Wi-Fi Networks button right up the top of the screen which will return you to the previous screen and then turn off the Wi-Fi. Press the Wi-Fi switch again to turn it back on.

    Wait for the Touch to connect to the router (when the tick appears) and then wait for the padlock to come up if you use encryption.

    Once this has occurred, switch back to Safari and type in

    Hopefully if all goes well you should not get the Google home page and not the dreaded "+Safari cannot open the page because it is not connected to the Internet.+" message.

    Post back with how you got on.
  • luvlabs Level 4 Level 4 (3,610 points)
    I was reviewing my experiences with WiFi and I had a couple of the problems that others have noticed. However, most of them, assuming the wireless network is working, can be pretty easily corrected by resetting the network settings on the touch (Settings > General > Reset > Reset Network Settings) and logging back into your network.

    Wireless router setups seem to be the other problem. The most common problem is caused by not broadcasting your SSID. Somehow, the touch 'forgets' the network and the only way to log back in is re-enter everything.

    IP Addresses - either leave DHCP on your router on (recommended) or make sure that you have assigned the touch a correct and open IP address. You can also try 'Renew Lease' which will refresh this.

    DNS - This is a new one for me. My router is my DNS (it contains the actual DNS addresses for my provider).

    MAC filtering - turn it off for troubleshooting purposes if you have it on.

    Your touch should be getting all of its settings from your network router automatically. There should not be a need to enter anything other than your network password or WEP key. Do not input your IP address, subnet mask, DNS or Router IP unless you know what your network settings are.

    Some good resources to look at: or

    Some other things to do: Update your router's firmware, read your router's manual so you are familiar with what is going on, disable security for troubleshooting purposes, reboot your router, and be aware that sometimes the router is just bad.
  • digitalgeist Level 1 Level 1 (0 points)
    Thanks for the help guys, and I do understand this a bit more now after reading your replies. Now instead of getting "not connected" I'm getting "Safari could not open the page because the server stopped responding" - I've scheduled some time with the Apple Store to get to the bottom of this.
  • aaron petit12345 Level 1 Level 1 (0 points)
    thanks i am connected
  • jeffhenc Level 1 Level 1 (0 points)
    I've suddenly got the same iPod Touch issue. When trying to use Mail, Safari (any web app) I get "Safari can't open the page because it can't find the server.", or "... connection to the server failed."

    I've reset network settings, and my other Macs are working the same as always. All settings in the IP Address page are there and are correct.

    All bars are filled in so there's lots of signal.

    Router settings are unchanged.

    Any further ideas? Thanks!
  • jeffhenc Level 1 Level 1 (0 points)
    Sorry, I should add that this is a 1st generation iPod Touch that has had NO connection issues, with the same router for the past 8 months.
  • MidgetMines Level 1 Level 1 (0 points)
    Dunno how you knew that Jobiwan but it was incredibele. you genius. I'm sorry if anyone below you tried to help cos i din't need to read them
  • lnorvig Level 1 Level 1 (0 points)
    That's what I get "server stopped responding"
  • John Potts Level 4 Level 4 (3,100 points)
    That's the most thorough help I've seen in 4 weeks of researching this problem.

    I wish I'd seen it earlier, because now my Touch won't even find my network at all, so I can't follow your steps, as they all depend on having at least a connection.

    In brief: I had the same problem - no connection and a self-assigned 169 IP address. In my case, it is 100% Apple: Touch + Apple Extreme (Time Capsule) router + OSX as the computer OS.

    Now I have a worse problem: the Touch doesn't even see the network at all- so there's not even a self-assigned IP or incorrect DNS to worry about! It just says "could not find the network xxxx". That's it. It kicks me out without further ado - so there's no question of addressing the IP/Subnet mask/DNS settings etc etc.

    So far, after 4 weeks of trying, I have yet to connect the Touch to my wireless network.

    If you have suggestions as to how I can get the Touch to see/find the network I would be very grateful indeed.

    The network details: TimeCapsule/AirPort Extreme, WPA2 personal, create a wireless network checked, 802.11n only (5GHz), using wide channels checked, create a closed network unchecked.
  • Average Gamer Level 1 Level 1 (0 points)
    I seem to be past the problem of my ipod 'not being connected to the Internet.' All Safari seems to say now is:

    "Cannot Open Page. Safari could not open the page because the server stopped repsonding."

    In the top left of my iPod Touch screen there is the 3 blue waves, so I am connected to the internet perfectly fine...I just don't know what's going on...Any ideas?
  • luvlabs Level 4 Level 4 (3,610 points)
    You need to reread Jobiwan's post. The most likely culprit is your DNS settings. If you try the IP address he gives you and you can connect to Google, then that pretty much explains what is going on.

    To check your own network settings on your Touch, go to Settings > WiFi and tap the blue > next to your network name. What you should see is your iPod's IP address, the subnet mask, the router IP address, and the DNS IP addresses.

    If those are missing or you have an IP address of 169.x.x.x there are other things going on. Write back and we will try and help you.
  • Average Gamer Level 1 Level 1 (0 points)
    tried both those Ip addresses, neither worked.

    I noticed on my router setup, that the DNS is set to be given automatically by my ISP, should I contact them and then use what they give me and enter that into the DNS field on my ipod?
  • luvlabs Level 4 Level 4 (3,610 points)
    I think I may have confused you. Does this link work in Safari?

    You router setup for DNS is fine.

    If that link doesn't take you to Google, then there is a problem with your connection to the router. Go to Settings > WiFi. You should see the network name of the network you are connect to (there will be a check mark next to it). Tap on the blue > next to the name. Your touch will display your IP address, subnet mask, Router IP, and DNS IPs. If those look OK (usually 192.168.x.x,, 192.168.x.x, and the DNS will either be the router address or some other IP number).

    If your IP address is 169.x.x.x, then your touch is not communicating with the router. Tap the blue > and select Forget Network. Then go to Settings > General > Reset > Reset Network settings and do that.

    Once your iPod restarts, go to Settings > WiFi > other network and type in your network name. Selection your encryption type, then enter your password or hex key (for WEP).
  • Switch900 Level 2 Level 2 (200 points)
    from what I am seeing it is a common problem with most ipod touch 2nd gen and first gen
Previous 1 2 Next