3 Replies Latest reply: Jan 7, 2009 4:13 PM by BobHarris
dvb Level 1 Level 1 (5 points)
"connection failed...please make sure that Screen Sharing... is enabled...."

i get this error message when i try to screen share from my macbook pro to my g5 desktop whenever i have my vpn client connected to my office network. i'm using cisco vpn client version 4.9.01(0100). screen sharing connects fine as soon as i disconnect the client connection. my macbook connects via the wireless network connected to the g5, a linksys WRT54GL.

i was able to screen share without difficulty until several weeks ago and am just recently realizing the screen sharing issue is reliably related to the vpn being connected.

knowing very little about networking, are there some port changes or something i need to make to allow both connections at the same time (realize i say "port changes" without really knowing what the heck i'm talking about or where those changes would be made).

thanks for any help,

powermac g5, macbook pro intel core2duo, Mac OS X (10.5.6)
  • Apinsley Level 1 Level 1 (0 points)
    The very nature of VPN is to provide a secure connection between your computer and an office network. In order to enforce security, your vpn client will disable all other network connections.

    So, basically, you're stuck. I run into this problem all the time (retrospect backups fail while users are connected to our remote site over vpn), so I feel your pain.
  • BobHarris Level 6 Level 6 (16,480 points)
    One thing to try:

    Cisco VPNClient -> select your connection entry
    Click Modify
    Click Transports
    Check [X] Allow Local LAN Access

    This may or may not work to allow local LAN access.

    The decision to allow or not allow access to anything except the VPN connection is specified by the VPN server. So your company's VPN admins are controlling your access outside of your Mac.
  • dvb Level 1 Level 1 (5 points)
    thanks for the suggestion. allowing the local LAN didn't help.
    looks like company is being extra careful--which i respect. i was hoping there was a safe by-pass, but will work with this as-is.