Previous 1 2 Next 21 Replies Latest reply: Apr 6, 2009 3:28 PM by Xerxes1
noloc4545 Level 1 (0 points)
I have an eMac I guess (G3 all in one screen) and a G4 PowerMac. The G3 is running Classic and the G4 is running Panther (10.2). If I connect a firewire cable between the 2, I can transfer files or not? How would I be able to easily transfer files between the 2? Thanks!

Macbook (black), Mac OS X (10.4.11), 2GB RAM/160GB HDD/FCE
  • Texas Mac Man Level 8 (46,565 points)
    See How to Use Firewire Target Disk Mode

    Depending on the number/size of the files, it might be easier to use a USB thumb drive.

     Cheers, Tom

  • Jan Hedlund Level 6 (9,720 points)
    Alternatively, you could use Ethernet. See, for example, this article.

  • Ed Hanna Level 4 (1,240 points)
    The articles will get you started and there are lots more. The chap who started the "Three Macs and a printer" site's particularly good. But there are lots because the Panther to OS 9 networking was—in my experience—really buggy. Sometimes what had worked fine for days just didn't, or worked in one direction, but not the other. More often than not it did not work as Apple optimistically described.

    So unless you enjoy such exercises as I do, or really want a networked system you can use constantly as I did, I'd suggest you opt for the sneakerware approach and carry the files on some medium from box to box.
  • noloc4545 Level 1 (0 points)
  • Xerxes1 Level 1 (0 points)
    Hi, similar situation here where I'd like to connect 9.2 to OS X. I have a MacBook Pro/10.5.6 and two legacy units: an original G3 and a PowerBook G3, both running 9.2.2.

    I've read the thread and can't get my party started. All 3 are connected through a Linksys router. The 9.2s can see each other, connect to each other and connect to the Internet but I can't get the MacBook Pro in the mix. It connects to the 'net too.

    If someone(s) can provide clear steps on both sides of the setup, that would be wonderful (and will make up for the hours of wasted time I spent today trying to find the info online and then on the phone with three Apple support reps who provided conflicting advice that ultimately didn't achieve the goal).


    Message was edited by: Xerxes1
  • Grant Bennet-Alder Level 9 (56,691 points)
    To make way for the upcoming Intel Macs, AppleTalk and TCP/IP drivers for 10.4 and later were modified.

    File Sharing via AppleTalk: 7.5.3 through 10.3.9 can share their files via AppleTalk.
    10.4 and later cannot share its files via AppleTalk, and cannot mount drives from Macs that only want to share via AppleTalk. (AppleTalk printing in 10.4 and later is still supported.)

    File Sharing via TCP/IP:
    OS 9 and later can share its files via TCP/IP.
    7.5.3 and later can mount other Mac's files on its desktop via TCP/IP if you use the "Server IP Address" button in the AppleShare Chooser Extension.

    Executive Summary:
    The scenario that always works is to start from the older Mac, and mount the 10.4 or later Mac's shared drives or shared folder on the older Mac by using the "Server IP Address" button in the Chooser.

    On the newer Mac -- System Preferences > Sharing > \[√] Personal File Sharing -- must be enabled
    You will need to know the IP address of the Mac whose files you want to share, and enter it on the older Mac in the Chooser's "Server IP Address" window. The login information requested comes from the Mac that is sharing (the newer Mac in this case) and you must provide a valid userid and password for that Mac. If you provide an administrator ID, you can share everything, not just the Public Folder.

    Message was edited by: Grant Bennet-Alder
  • Xerxes1 Level 1 (0 points)
    Grant, thanks.

    I had tried what you suggest but no go. Any idea why it didn't work?

    I see a "file sharing" box in the sharing pref, which is selected, but no "personal file sharing" box. I used the IP address that's displayed near that box.
  • Grant Bennet-Alder Level 9 (56,691 points)
    If you have enabled FireWall on your 10.5 mac, you must explicitly allow File Sharing traffic to go through. use the nearby FireWall pane to check that box, too.
  • Xerxes1 Level 1 (0 points)
    Alright, I fixed the firewall setting, thanks. Still no connection.
  • Grant Bennet-Alder Level 9 (56,691 points)
    How are you going about attempting to connect?
    At what stage does it fail?
    and exactly what messages or symptoms do you see?
  • Xerxes1 Level 1 (0 points)
    On the G3 desktop I open Chooser, select AppleShare and hit the Server IP Address button. Then enter the afp address for the MacBook Pro and hit the "Connect" button. G3 then says "Couldn't Find the Server "afp://""

    Message was edited by: Xerxes1
  • Grant Bennet-Alder Level 9 (56,691 points)
    Are all the Macs set to get their IP addresses via DHCP?
    Are all the IP addresses in the same range, differing only in the last octet, and all using a subnet mask of

    There is a good writeup on connecting OS 9 and 10.3 Macs. Perhaps it will inspire more questions or answers:
  • Xerxes1 Level 1 (0 points)
    Are all the Macs set to get their IP addresses via DHCP?


    Are all the IP addresses in the same range, differing only in the last octet, >and all using a subnet mask of


    However, I've discovered that in the File Sharing control panel of the G3, "Enable File Sharing clients to connect over TCP/IP" is not checked and is grayed out. What can be done to enable that? It seems to be the only item so far that may be obstructing the connection.

    Grant, I really appreciate your assistance.
  • Grant Bennet-Alder Level 9 (56,691 points)
    There is mention of that option in this article, but I am not sure why it should be grayed out.

    TA20671- Mac OS: Sharing Over the Internet, or Between Remote Networks

    This article may also provide some insight, but I am not sure whether it contains a solution:

    HT2246- Mac OS: Connecting to the Internet and sharing files locally at the same time

    One thought that comes to mind is the Mac OS 9 option to load TCP/IP only when needed: In the TCP/IP Control Panel, select "User Mode" from the menu and choose "Advanced". Make sure the "Load TCP/IP only when needed" checkbox is NOT checked. Be certain you close the control panel and save changes to have them take effect. Re-open the TCP/IP Control panel and be sure you have a valid IP address in the required range. means you are talking only to yourself.

    Another possibility is the "enforce strict 802.11" checkbox, I think in the TCP/IP Control Panel. It should usually left unchecked.

    It should not be necessary, but you may want to be sure that AppleTalk is assigned to the Ethernet port and turned on by using the AppleTalk Control Panel. Assigning AppleTalk to a different port such as the Printer port may cause confusion.

    Message was edited by: Grant Bennet-Alder
Previous 1 2 Next