Previous 1 2 Next 21 Replies Latest reply: Apr 6, 2009 3:28 PM by Xerxes1 Go to original post
  • Xerxes1 Level 1 Level 1 (0 points)
    One thought that comes to mind is the Mac OS 9 option to load TCP/IP only when >needed: In the TCP/IP Control Panel, select "User Mode" from the menu and >choose "Advanced". Make sure the "Load TCP/IP only when needed" checkbox is NOT >checked.


    I'm familiar with that...it's properly set.

    Be certain you close the control panel and save changes to have them take >effect. Re-open the TCP/IP Control panel and be sure you have a valid IP >address in the required range. 169.254.xxx.yyy means you are talking only to >yourself.


    Looks ok.

    Another possibility is the "enforce strict 802.11" checkbox, I think in the TCP/>IP Control Panel. It should usually left unchecked.


    There's an 802.3 box in OS9 and it's not checked. The MacBook 802.11 box is not checked either.

    It should not be necessary, but you may want to be sure that AppleTalk is >assigned to the Ethernet port and turned on by using the AppleTalk Control >Panel.


    It's set properly. How about the possibility of something relating to the network and node settings in that control panel? All 3 machines have the same settings. Also, any issues with the Users & Groups tab in File Sharing? I have all 3 machines in a group (that was done after troubleshooting hadn't pinpointed anything).

    Message was edited by: Xerxes1
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    However, I've discovered that in the File Sharing control panel of the G3, "Enable File Sharing clients to connect over TCP/IP" is not checked and is grayed out. What can be done to enable that? It seems to be the only item so far that may be obstructing the connection.


    I think you may have some damaged or missing files or disabled extensions in your OS 9 System. Incoming IP File Sharing in OS 9 was implemented with a version of OpenDoor Software's ShareWayIP, that was included in the standard OS 9 Install. I have often been tempted to disable or discard those extensions, but managed to control myself. (Only much later did I learn they were needed to share via IP.) This may be what is keeping you from sharing starting from Mac OS X, and may have some wacky side-effects like the grayed-out checkbox.
  • Xerxes1 Level 1 Level 1 (0 points)
    Your Sherlock Holmes avatar is proving worthy. Indeed, I had disabled the SharewayIP extension in my efforts years ago to declutter the system.

    My file sharing with the PowerBook wasn't affected so, hey, why would I think about it now, right?

    After re-enabling the extension I am able to select the formerly-grayed out file sharing box. When I attempt to connect now, the G3 appears to search for the MacBook but, like before, it does not connect. The difference now, however, is that an attempt is being made...the G3 is searching for life on the network; before, the attempt failed immediately.

    We're getting close, I feel it. More ideas?
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    My next step would be to restart all the Mac OS X machines and then restart the OS 9 machine, in hopes that something would get initialized differently the next time.

    If it is looking, but cannot find it, that is certainly encouraging. But not there yet. There are a few more desperation moves on the list:

    • Turn off the firewalls on the individual Macs until you can get this working. The Firewall provided by your Router's Network Address Translation should suffice.

    • Try to establish a connection from a 10.5 Mac back to the OS 9 Mac. This direction should work with SharewayIP active.

    • Try using the "Ping" function in Mac OS X Network Utility to explore what seems to be present and answering on your network. There is also an OS 8/9 MacPing Utility that was distributed free with the original Apple Internet connection kit -- send me an email if you cannot find it online and maybe I can find a link to it. Pinging ten times in a row should yield 10 out of 10 OK results. The first response may be a little slow, but actual errors/no responses indicate wiring problems or Router ports that are dying (both of which have happened to me).

    • Re-install Mac OS 9 on the OS 9 Mac. It takes a little while, but is not that daunting if you have the CD for the same version. Otherwise you will have to discard the System and Finder and then Install, or do a clean Install.
  • Xerxes1 Level 1 Level 1 (0 points)
    Grant, again, thanks.

    I changed the Network and Node data in the G3's AppleTalk control panel to match the MacBook's Network and Node settings. I think that was the secret sauce because I just connected the two (G3 to MacBook)! The party is on.

    I was able to ping the G3 before I did that. Didn't do any of the other suggestions in your last note.

    Thanks for all of your help. Apple support couldn't get it done but you did.

    Before I go, one last question: what are the steps to connect in the opposite direction, from the MacBook to the G3? I looked on the MacBook before I made the connection and didn't see anything that was like what the G3 has in the Chooser using AppleShare.

    Did I say thanks?
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    To connect from Mac OS X:
    In the Finder, choose "Connect to Server" from the bottom of the GO Menu.
    It is possible your OS 9 Mac will appear there, but if not, enter its IP Address.
    The dialog box that appears is requesting a login ID and password valid on the OS 9 Mac, and once it is verified, will give you a choice of OS 9 Machine's Volumes to mount, if there are multiple Volumes.
  • Xerxes1 Level 1 Level 1 (0 points)
    Got it. I couldn't get the Powerbook to see the MacBook but the MacBook found the PowerBook so we're all good.

    Grant, thanks once again for all of your help.
Previous 1 2 Next