12 Replies Latest reply: May 20, 2009 8:14 AM by ThePhantomPR
John Klotz Level 1 Level 1 (15 points)
i have the latest version of final cut but ive had this issue with earlier versions...

what i tried to do was drag/drop the video file i captured onto an external hard drive (usb2 if that means anything) and it wont copy it...this window pops up "Sorry, the operation could not be completed because an unexpected error occurred. (error code 0)"

ive had this issue before and ive been in bad situations because of it. ive had to capture footage on one computer and transport onto another computer (for school). Is there any way around this OR should i have captured the footage onto the hard drive in the first place? i would love to find a loop hole because sometimes i run out of space and need to move stuff around, maybe i should become more organized? thanks for any help!

Power Mac G5
  • Nick Holmes Level 7 Level 7 (29,975 points)
    You should run Disk Utility's "Repair Disk" function on that drive. (not Repair Permissions)

    Post any error reports it displays here, exactly as they are presented to you.
    Also post the format of the drive, it's capacity, how much free space and the size of the file you are trying to copy.
  • John Klotz Level 1 Level 1 (15 points)
    hm, never really thought it was a drive issue....cause this has happened for a while, then again come to think about it, i always use this hard drive. but i clicked on "Repair Disk" and this pops up...

    "Verify and Repair volume "LACIE"
    (in red) The Disk "LACIE" could no be unmounted.

    thats all that comes up....
  • Nick Holmes Level 7 Level 7 (29,975 points)
    That might be temporary.
    Shut the drive down and let it cool for half an hour or so, then run Disk Utility on it again.
  • Strypesx Level 1 Level 1 (35 points)
    "Sorry, the operation could not be completed because an unexpected error occurred. (error code 0)"


    5 bucks says that you are copying a file larger than 4 gigs onto a FAT32 formatted volume. You need to either 1, reduce the file size by splitting up the file, or 2, reformat your drive, or 3, get another drive and format it to Mac OS Extended (HFS+) with Disk Utility.
  • 23circles Level 1 Level 1 (5 points)
    I am having the same problem, however, I can't break up my files into smaller bits because of the nature of the file. I am assuming the only thing I can do to get the files on is reformat. Is that correct?

    If I reformat, what format should I use? Chances are this drive is going to be going from Mac to PC.

    I am using a 250gb WD passport and trying to add three files around 10gb in size.
  • Strypesx Level 1 Level 1 (35 points)
    Individually the files cannot be larger than 4 gigs if you're going onto a FAT32 volume. Macs read and write to Mac OS Extended (HFS+) and FAT32. Macs can read from an NTFS, but can't write to it. There's the NTFS for mac which can allow you to do so, but I haven't tried it personally.

    PCs can read and write to FAT32 and NTFS. You'll need the MacDrive software installed for a PC to write to a Mac formatted volume.
  • Am_Rock Level 1 Level 1 (0 points)
    AAAA!!! i have the same problem Error code 0!!!!

    if i run Disk Utility's "Repair Disk" the files in my external disk will be erased?

    if i need to format (or Reformat)my external disk , how i do that!?


    what can i do !!!! for fixed(kill) this Error!!!!?

    Message was edited by: Am_Rock
  • Nick Holmes Level 7 Level 7 (29,975 points)
    Repair disk will not delete anything.

    While Repair Disk can fix problems, it might not fix them completely.

    Run *Verify Disk* first and post the error messages here, should any show up. If there are no errors, you don't need to run Repair Disk, the issue lies elsewhere.
  • Am_Rock Level 1 Level 1 (0 points)
    Verifying volume “NEGRITO”
    ** /dev/disk2s1
    ** Phase 1 - Preparing FAT
    ** Phase 2 - Checking Directories
    ** Phase 3 - Checking for Orphan Clusters
    16460 files, 853500800 KiB free (26671900 clusters)


    i think there is no problem! but i need to send big files to my external disk,not just 4 gb!there is any way to fix or change or format(FAT 32) or wherever!?

    thanks!

    Message was edited by: Am_Rock
  • Nick Holmes Level 7 Level 7 (29,975 points)
    any way to fix or change or format...


    Yes. Use the "Erase" function in Disk Utility. This will of course do just that, and format the drive. Back up your files first.

    Unless you absolutely have to use the drive to exchange files with a Windows PC, format as Mac OS Extended.
  • mikepsux Level 1 Level 1 (0 points)
    i was having the same problem with this error code. here is a work around:

    if you're working with video files in FCP, drop your video into a FCP sequence, set in/out points to break up the video into sub-4GB segements, export them, however many it takes (knowledge of the codec you're using is important to know this). then bring these segments ALL into a sequence in order, then choose:
    FILE: export: quicktime movie THEN AT THE BOTTOM OF THE DIALOG BOX UNCHECK "make self-contained movie" then export. this will make a TINY quicktime movie that instead of being a self contained video is a reference video that references the segments. quicktime can play this movie through most programs. just copy the segments AND the reference video all over.

    not a perfect solution, but it works if you need to get videos to a PC.
  • ThePhantomPR Level 1 Level 1 (0 points)
    I was having the same error code. And i fix that error with this steps: I erase the disk with Disk Utility in fat then i go to time machine and i choose the Change Disk button then i select the drive and the drive would change the icon to the time machine icon. i turn off my time machine and then i can pass all my projects and all the stuff that i have in my computer without error.