5 Replies Latest reply: Apr 4, 2009 9:50 AM by tool
wunwspirit Level 1 Level 1 (0 points)
Hi all,

I have been having this annoying little problem ever since switching webhosting servers with Verio. Everytime I boot up Mac mail, I get a popup warning titled 'Verify Certificate' and the body of it says 'Mail can't verify the identity of "my IP address here". The certificate for this server is invalid....(see attached jpg for visual), it also gives three button choices 'Show Certificate', 'Cancel' and 'Connect'. I always hit connect and everything is fine. I tried finding out about this certificate stuff through the 'help' section of the finder. It pointed me to the 'Keychain Access' utility. I opened that up and clicked on the category 'Certificates' in the left hand column (again see attached jpeg).
The certificate listed is from verio.com so I assume that this is the 'invalid certificate'. I also see that the number 19 is included in the certificate name, which is the group number of my previous server. So my questions are:

1. What is the fix here?
2. Can I just delete the existing certificate?
3. Do I need a certificate in order to log in to mac mail and access my mailserver?
4. If so, where do I get a valid certificate for my new server, verio?








Thanks in advance for any input.

Best,

Dennis


Mac Pro 2.8GHz quad 10GB RAM 320GB SATA 500GB SATA, Mac OS X (10.5.6), Power Mac G4 dual 1.2GHz 1.5GB RAM 120GB SATA 80GB SATA, G4 Powerbook 1GHz 2GB
  • 2point5 Level 3 Level 3 (955 points)
    Dennis,

    Close Mail and delete the old certificate from Keychain and then re-open Mail again. Mail will create a new certificate to reflect the new server and hopefully all should be good again.

    Chris
  • kencanuck Level 1 Level 1 (10 points)
    I have the exact same problem. I've added the certificate and selected "always trust". Yet, ever time I open up mail, it warns me of the invalid certificate.

    I tried deleting and creating a new one but it's still doing the same thing.
  • wunwspirit Level 1 Level 1 (0 points)
    Hi Ken,

    Are you using the mac mail client? You might want to try saving any mail in your inbox in a separate mailbox folder, then deleting your mail account and go through the process of creating a new mail account. When you get to the part that says 'use secure socket layers' leave that box unchecked, this should make your outgoing mail server send through port 110 rather than the secure socket layer port 995. I have done this and it seems to have alleviated the problem. Not sure if that's the correct fix or what these certificate authorities are all about.
    As I said I tried to bone up on them in the help section but my head just got dizzy after awhile, lol.

    Let me know how you fare.

    Best,

    Dennis
  • tool Level 2 Level 2 (320 points)
    I too have been having major issues with mail on my MacBook Pro. It's so aggravating i only open it up when i have to reply to an e-mail or can't look at certain e-mail attachments on my iPhone - otherwise i only ever check my e-mail with my iPhone or iPod Touch.

    Every time i open mail on my MacBook Pro, i consistently get the "could not verify certificate" error. Even though i consistently go through the options and checkmark the box to "Always Trust", i still continue to get the message every time i open Mail up.

    My e-mail is strictly POP accounts, and i DO NOT have the Use SSL box checked, so it is using Port 110, not 995.

    I have gone through and removed my e-mail accounts, and then tried to set them up all over again, with no success.

    I'm so fed up with the Mail App.

    I continue to get the error messages even though i removed the certificates out of Keychain Utility and tried to open Mail again.

    I'm going bald trying to figure this out - does anybody have any other ideas for me to try please? Thank you!

    Jason
  • tool Level 2 Level 2 (320 points)
    i also found this page that says that once you select "Always Trust" that you shouldn't continue to get the message.

    http://docs.info.apple.com/article.html?path=Mail/3.0/en/9989.html