Previous 1 2 Next 25 Replies Latest reply: Feb 22, 2010 6:53 AM by mbblack.......................
mangowarrior Level 1 (0 points)
I was able to install Windows 7 on my MBP, installed graphics drivers perfectly. Only thing I cant figure out is getting the audio to work. Some people suggested downloading Realtek audio drivers which I tried but those too were unsuccessful. Any of you guys figured it out yet or could point me in the right direction?

Thanks

Mac book pro, Mac OS X (10.4.10)
  • Nehemiascr Level 1 (0 points)
    I have the same problem, no solution yet
  • Nehemiascr Level 1 (0 points)
    Unzip the RealTekSetup.exe files that is located in the drivers folder of the Leopard DVD, unninstal the current driver, and then update the driver using the files located in the VISTA folder of the previously unzipped file. after that,just listen to some music!!
  • Perr0 Level 1 (0 points)
    Which driver did you get? I had the same problem and solved with the driver. Actually, what you have to get is the Vista version of the High Definition Audio Codecs fom Realtek.


    <Edited by Moderator>
  • CoolMe Level 1 (0 points)
    Was just about to link those ^
  • Nehemiascr Level 1 (0 points)
    This is the driver I used: DriverVer=08/20/2007, 6.0.1.5469
  • Easybourne Level 1 (110 points)
    Try this.

    Boot into Windows 7.

    Insert Leopard DVD for Boot Camp Drivers. Don't auto-run the installer. Navigate to the drivers folder and there you find the individual .exe files files for each driver.

    Right click on the RealTek driver and select 'troubleshoot installation'. Windows will ask you several questions, but basically the gist of it is to tell Windows that 'This driver used to work OK in Vista'. You can answer all of the questions as 'Don't know' or 'Other'. Provided you say that it worked in Vista, you should be fine.

    This work for me with the 64-bit version on my iMac 24". I didn't bother downloading from the realtek website.

    If you've installed the 64-bit version, make sure you use the 64-bit driver. I don't know if this technique will work for the 32-bit version, but I don't see why not.
  • A.mt972 Level 1 (0 points)
    This did the trick for me (on a Windows 7 beta 32-bit install w/Boot Camp).

    As mentioned above, RealTekSetup apparently likes being run in "Windows Vista" compatibility mode and as an Administrator. So one could also set this on the Compatibility tab of the Properties for this app before running it, I suppose.
  • mangowarrior Level 1 (0 points)
    I found a fix a couple days ago. What I ended up doing was install Bootcamp 2.1, the whole disk. Towards the end of the install dialog i noticed it saying "Removing Realtek drivers ..." then "Installing SigmaTel drivers ..." A short time afterwards I started hearing all the bells and whistles of Windows 7. Everything works great now.
  • cjvista217 Level 1 (0 points)
    perr0, when i click on the links you provided it takes me to a username and password dialog box. what do i enter?
  • The hatter Level 9 (60,930 points)
    Every driver and installer, you should run using Troubleshoot Compatibility Mode.

    Easier to go to Properties and change yourself.

    http://www.opendrivers.com/company/2358/realtek-free-driver-download.html
    http://downloads.guru3d.com/downloadget.php?id=2163
    http://www.realtek.com.tw/downloads/
  • be ottomans Level 1 (0 points)
    dear mangowarrior
    I had the same problem of you but I figured out a way to solve this issue.
    You need drivers of boot camp on mac osx 10.5.4 dvd.then open Drivers folder, you will see RealTekSetup.exe right click then click to troubleshoot compability. A window will apper.You'll se Program Compability click next below. Select "the program worked earlier versions of windows but won't install or run nom." and click next. Realtek Setup will start and install drivers. solution is just this.
    have fun with yor windows seven macbook pro
  • mixmasterdan Level 1 (25 points)
    Hey thanks this worked
  • RobNYC2009 Level 1 (0 points)
    This a a tip for all of those who are going Crazy looking for RealTek Driver!!
    After 8 hours trying over 10 different versions of the driver as well as Compatibility modes on my Windows 7. Turns out I was installing the wrong Manufacturer Driver all Along!
    My MBP 17" _uses SigmaTel_, ran the setup that came on the OX 10.5 CD, installed in less than a minute!!!!
    *IF YOU ARE GETTING A RED LED ON THE AUDIO JACK* on the side of your laptop, is an indication you have the wring driver installed..

    Best of luck, i just had to share to save anyone out there time and frustration.
  • gonegolf Level 1 (0 points)
    Hi, thanks for the tip. I have ran the Realteksetup and now everything works ! I have even tried deleting the optical output device in the control panel to no avail.

    Now, trying to find the driver to get enhanced scroll pad functionality
Previous 1 2 Next