Skip navigation
This discussion is archived

Time machine is very slow

3032 Views 33 Replies Latest reply: Jan 27, 2009 8:17 AM by Pondini RSS
1 2 3 Previous Next
wchlm Calculating status...
Currently Being Moderated
Jan 11, 2009 10:41 AM
I'm using TM to back up a 150 Gb drive to a 591 Gb partition (Mac OS Extended (Journaled)) on a 1 Tb Lacie D2 Quadro connected via Firewire 800.

A TM backup usually takes more than 1 hour. Due to this, I decreased frequency to every 6 hours, but even so, during the 1+ hours the backup takes, the machine is only marginally usable.

Below is an excerpt from my system.log file bracketing a TM backup.

In contrast, I occasionally use Silverkeeper (a free backup tool provided by Lacie) to create a bootable backup to another partition on the same drive. Even though I only do this every week or so, the Silverkeeper backup only takes about 3/4 hour.

--
Jan 11 11:10:58 shenkin /System/Library/CoreServices/backupd[75466]: Starting standard backup
Jan 11 11:10:58 shenkin /System/Library/CoreServices/backupd[75466]: Backing up to: /Volumes/Time Machine Bak/Backups.backupdb
Jan 11 11:16:48 shenkin /System/Library/CoreServices/backupd[75466]: No pre-backup thinning needed: 741.5 MB requested (including padding), 446.50 GB available
Jan 11 12:10:09 shenkin /System/Library/CoreServices/backupd[75466]: Copied 214541 files (18.9 MB) from volume Macintosh HD.
Jan 11 12:10:20 shenkin /System/Library/CoreServices/backupd[75466]: No pre-backup thinning needed: 740.2 MB requested (including padding), 446.48 GB available
Jan 11 12:11:42 shenkin /System/Library/CoreServices/backupd[75466]: Copied 5400 files (17.8 MB) from volume Macintosh HD.
Jan 11 12:11:47 shenkin /System/Library/CoreServices/backupd[75466]: Starting post-backup thinning
Jan 11 12:32:02 shenkin /System/Library/CoreServices/backupd[75466]: Deleted backup /Volumes/Time Machine Bak/Backups.backupdb/shenkin /2009-01-10-055318: 446.50 GB now available
Jan 11 12:32:02 shenkin /System/Library/CoreServices/backupd[75466]: Post-back up thinning complete: 1 expired backups removed
Jan 11 12:32:02 shenkin /System/Library/CoreServices/backupd[75466]: Backup completed successfully.
--
PowerMac G5, Mac OS X (10.5.6), iPod shuffle, Treo 650, Linux, W*****s
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 11, 2009 3:31 PM (in response to wchlm)
    At first glance, I'd say yes, that's far too long for about 20 mb of data.

    But then I see that it's backing-up over 200,000 files! Small ones, obviously, in the area of 200 bytes each.

    As I recall my first TM backup, was in the neighborhood of 500,000 files (mostly the OS) and took perhaps an hour and a half, so perhaps yours isn't all that bad. TM may, I suppose, be spending most of it's time creating files & folders instead of actually copying data.

    I can only guess -- are you running an app that's adding/updating a whole passel of files?

    If you don't know what these files are, you might want to download the (free) app TimeTracker, from VersionTracker. It will show you what was backed-up on each TM backup.
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 11, 2009 4:39 PM (in response to wchlm)
    wchlm wrote:
    And why are there two entries -- one for 215,000 files and one for 5400 files? Maybe this is normal... but it still comes to my eye.


    This is not uncommon, and is yet another TM mystery. TM does use an internal OSX event file that logs changes, in contrast to most backup apps that examine every file -- that's why it's usually so much faster.

    My completely-uneducated guess is, when a backup starts, TM gets the changes from the event file that's been written to disk, and copies those files. Then it forces a "flush" of changes made but not yet written to the event file on disk, thus including any last-minute changes as well, and copies the new files. This is, of course, probably 100% wrong!

    But whatever the reason, it is fairly common, and doesn't seem to be a problem.
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 11, 2009 5:28 PM (in response to wchlm)
    wchlm wrote:
    TimeTracker from VersionTracker has nothing to do with Time Machine; rather, it's a personal productivity/time-reporting tool. There is a TimeTracker from charlessoft.com that I found a link to on the web; that appears to be what you're thinking of; but charlessoft.com no longer exists.


    So I see. I just got it a month or so ago, a great little app, and does just exactly what you need. Perhaps a trade name problem -- maybe it'll be back under a new name.


    timedog run on the latest backup reports the following summary, after listing all the files:

    ==> Total Backup: 1042 changed files, 69.27MB

    This latest backup was subsequent to the one I first reported; in the syslog, the latest backup shows the following. There appears to be a huge discrepancy between what Time Machine claims it is backing up and what timedog claims Time Machine is backing up.


    Very odd indeed. Do the 1042 files listed seem correct?

    If so, then the only thing I can think of is, how are you limiting TM to run every 6 hours? I know there are some apps that will do that, also instructions on how to edit TM's preference file, but I've not used them. Perhaps that has somehow confused it mightily?

    To run that long, and post those wildly spurious messages, it's apparently spending a whole lot of time trying to do something!

    If you haven't already, you might try just turning it off, then back on, and see if that will somehow reset it.
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 13, 2009 8:12 AM (in response to wchlm)
    One other thought: How long have you been on 10.5.6, and how did you install it?

    A different, but equally-strange problem in another thread was solved by downloading and installing the Combo update.

    Might be worth a try in your case, as well.
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 13, 2009 10:09 AM (in response to wchlm)
    The "combo" update contains all the changes from the original issue of Leopard in one big package. Thus loading it should fix anything that went wrong in any previous update.

    It's possible that some small item was missed or somehow messed-up (pardon the technical term!) on one of your past updates, but never caused a problem because you weren't using TM.

    The update and info are at: http://support.apple.com/downloads/MacOS_X_10-5-6_ComboUpdate

    It's a big one (668 mb), so allow yourself plenty of time.
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 17, 2009 8:00 PM (in response to Pondini)
    TimeTracker is back!

    Very neat little app, shows what was backed-up (hidden files and all) on each TM backup.

    http://www.charlessoft.com/
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jan 18, 2009 8:28 AM (in response to wchlm)
    Glad to hear it's improved, but you've still got something wrong. If it's really only backing-up 35-40 mb, half an hour is far too long, even if it were wireless. If you're on FW800, it's ridiculous.

    Since most of the time appears to have been spent copying the first group of files (21:24 to 21:50), it calculates to about 32 mb in 25 minutes! You could fax it faster!

    And the huge file counts make no sense either. Mine are high, but "only" 2 or 3 times what I see in TimeTracker. I suspect the difference is the metadata associated with OSX files being counted separately by TM.

    Yes, TM's "requested" space always seem high, often quite high. The speculation is, TM makes a quick estimate based on what's in the File System Event Log. Apparently this could include things like counting the same file more than once if it was updated multiple times since the last backup, etc., so nobody really worries about it.

    Are there any other messages in your log for this period?

    Are you running File Vault?

    Have you watched CPU usage while a backup is in progress (seems unlikely, but something unrelated might be going on).

    Just to rule it out, you might try doing a simple copy of a file or files totalling perhaps 30 mb to the other partition on that same disk, and time it. Again it seems unlikely, but perhaps there's something strange happening with the drive and/or cable.

    How weird.
    iMac G5 1.8 GHz PowerPC 1.5gb RAM, Mac OS X (10.5.6)
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.