2 Replies Latest reply: Jan 23, 2009 12:27 AM by Doug Weiss
Ninsei Level 1 Level 1 (0 points)
Hi.

I've recently experienced painfully slow downlink (download) speed using Airport Express.
My WiFi configuration:
- main router: WRT54G connected to my provider (speed limit: 4Mbit up/down link),
- AirPort Express with WiFi N and Airtunes hooked up to stereo in living room,
- AirPort Express WiFi G and Airtunes connected to stereo on bedroom.

Second Airport is currently not used to simplify tests and description of my problem.

The problem: when connecting from MacBook to Airport Express I can't reach more than approx. 512kbit downloading from internet, usually even 300kbit, while uplink reaches easily 2.5Mbit (limited probably by my network provider). While connected to WRT54G I can get 2.5 up to 4Mbit downlink, same when using cable directly plugged in to WRT54G.
I tried changing channels, switching different options in Airport with no effect - still getting pathetic download speeds. Even worse - browsing experience is awful, with frequent slowdowns, etc.
I tried different encryption methods, and seems like only switching it off at all (unprotected network) seems to let my Airport work on full speed (2.5Mbits symmetrically up/down, up to 4Mbits - provider speed limit) - which is unacceptable, I refuse to set up and use unprotected network at home.
Problem is clearly in Airport or in interaction between Airport and Macbook. I've just ran out of ideas - can you help me?

MacBook Black 2.2GHz, Mac OS X (10.5.6)
  • captain b Level 1 Level 1 (0 points)
    I can't offer any help with your problem except for the fact that mine has recently done the exact same thing. It's ridiculous, for months and months it was extremely fast and then all of a sudden it takes 20 minutes to open a simple browser page. Something is definitely wrong with the airport because all other wireless internet connections from other routers are as usual. \
  • Doug Weiss Level 2 Level 2 (355 points)
    Try resetting the router, airport and computer by shutting each one down.
    Unplug the power source from the router and the airport,
    wait 10 minutes then reboot each, one at a time.
    Things should improve.