6 Replies Latest reply: Jan 14, 2009 6:34 PM by BDAqua
Jason Rainbows Level 1 (0 points)
For some reason I can't copy stuff from my Mac to a USB Flash drive.

I have several of them ranging from a few MB to 4 GB. I was able to copy files to them yesterday, but suddenly am no longer able to.

I can plug them into my other Mac and they work fine. Only having problems on this machine.

I also have a several external hard drives, and no problem copying files to them, seems to be only USB Flash drives that are not working.

What happens is, when I try to copy a file I get the progress bar and it sits at zero and says estimated time one minute remaining, but does nothing for hours until I finally go to FORCE QUIT and restart the finder.

If I put a file on the flash drive from another computer, it will copy to this Mac but if I then take the file from the flash drive and drop it in trash and empty trash, I get a similar result with the progress bar - just sits and does nothing till I restart finder.

I used Disk Utility to repair the USB flash drive and to completely reformat it (erase), but still not able to copy even the smallest text file or JPG to it. Works fine on any other machine.

The USB Flash drives are not locked, and are fine as far as I know. I've tried pluging them into different USB ports and, still not working.

I've also run Disk Utility from the StartUp Disk and verified my Mac's Disk, and all seems fine there.

Any suggestions?

iMac Cubicle Partition Model, Mac OS X (10.4.11)