4 Replies Latest reply: Jan 16, 2009 12:19 PM by Baffie
Baffie Level 1 Level 1 (0 points)
I have migrated itunes from my old imac to my macbook and can see all the music folders within Finder but when I open itunes it does not pick up the songs and the play list is empty. How can I get itunes on my new macbook to recognize my imported itunes library. I used Migration assistant using a firewire cable.
Any suggestions
Thanks

imac G4, Mac OS X (10.4.8), Macbook
  • Jim VanLeeuwen Level 6 Level 6 (18,820 points)
    If you migrated everything from your old computer, try opening iTunes while holding down the option/alt key. When it gives you the opportunity to create or choose a library, select the choose option and navigate to your music library on your new Mac. (It should be in your iTunes folder within your Music folder.)
  • Baffie Level 1 Level 1 (0 points)
    Looked promissing for a moment but the did not work.
    I've compared the 2 iTunes folders and they were not the same, the old folder had a artwork folder. Ive tried moving this across within Finder but still no luck. I'm confident that it migrated across as the folder is 9gig and full of songs.
    Any other suggestions. I may dump the lot and start again.
    Note that when I used Migration assistant I only selected itunes as the folder to migrate. All the other options were unchecked. What was sent is what arrived.
    I've also tried using the create a new itunes folder - this came up as itunes 1. I then moved the itunes music folder into this but again did not recognise it.
    Many thanks
  • Jim VanLeeuwen Level 6 Level 6 (18,820 points)
    If you still have access to your computer and you can network them together, or even better mount the old one as a hard disk on the new one. Dump what you have on the new computer and just drag the entire iTunes folder (not just the iTunes music folder) to your new computer's music folder. Then repeat the choose library thing.
  • Baffie Level 1 Level 1 (0 points)
    Jim
    Spot on mate
    Worked a treat
    Cheers
    Mike