0 Replies Latest reply: Jan 14, 2009 9:14 PM by Richard Liu2
Richard Liu2 Level 1 Level 1 (5 points)
I'm a programmer, I write codes for Linux server. For years I write on my Mac, and compile those code on a Linux machine. I've defined a SMB share on Mac where my codes placed within it, and I mount the SMB share from the Linux machine with "smbmount" command. I worked fine till yesterday.

When I login Linux and mount SMB share as usual, the mount goes up without any error, but I can't get the file list. All files and directories are still accessible, but the response time is much slower then normal situation, and the 'ls' command failed to give any response till it's terminated due to I/O problem (it's the error message).

I tried to connect to Mac with "smbclient" command, everything worked without any problem, including file list. And than I tried to mount the SMB volume from a Windows XP, everything was OK, too.

So now I have a SMB share which can be accessed normally by Windows XP and "smbclient" command, but failed with "smbmount". I can't figure out what's wrong with it.

Full command of smbmount:

smbmount //192.168.1.200/myaccount /smb -o username=username%passwd

where 192.168.1.200 is the IP of my Mac, "/smb" is the mount point created on the Linux.
I've also tried "mount -t smbfs", the situation was the same.

PoweBook G4, Mac OS X (10.4.11)