3 Replies Latest reply: Feb 2, 2009 5:22 PM by Ken_Edgar
Ken_Edgar Level 1 Level 1 (30 points)
I have a G5 server with a dual port apple 2GB HBA installed. Long story short... there was a power outage at the site and since then, I have been having problems communicating with the tape library. The library would freeze whenever sending a backup job to it.

Support suggested replacing HBA... did that, the library was visable for a little while until I ran a backup job... then I could no longer see it from the server (however the port still shows active on the server). The Library this time did not freeze, but restarting it and the server would not bring the library back on the server.

I also have a promise vtrak on the other port which is working fine before and after replacement of the HBA.

Any suggestions? I have tried multiple cables... the library is an Exabyte Magnum 224.

Mixed environment
  • Strontium90 Level 4 Level 4 (3,580 points)
    I am surprised you did so well with the 224 up to now. They've been largely unstable in direct connect mode. Use of a FC fabric and zoning tends to make the connection more stable. The drive or library just "disappears" from the FC connection and then pops back on. Since it sounds like you do not have an FC switch, it will not be possible to resolve with zoning.

    Try this. In the Fibre Channel preference panel (assuming you are on Leopard), try changing the connection method from Automatic to Arbitrated Loop. Then, try point-to-point. A reboot is needed after each change. I've had some success forcing the connection type in the past, especially in the 10.4 days with Exobyte/Tandberg devices.

    Also check out http://support.apple.com/kb/HT1769 According to this note, the Promise devices are not intended to be used on G5 class systems. We know that they do, but the official stance is not.

    And finally, check out http://www.tandbergdata.com/us/fileadmin/AppleFiles/FC-INTEGRATION2008webFINAL.pdf for some good information on FC tape libraries and OS X.

    Hope this helps.
  • Ken_Edgar Level 1 Level 1 (30 points)
    Wow... thank you for the tandberg document... I wish they would have sent me this when I bought the tape library... and when I called for support on this system. I've got an RMA tape library on it's way, so we'll see what happens. The only thing I'm not doing in regards to tandberg's specs is having the tape libary plugged into interface 0 of the fibre card... wonder if that will make a diff or not.

    Thanks again... I will post solution in case it helps someone in the future.
  • Ken_Edgar Level 1 Level 1 (30 points)
    Argh, this issue has been very frustrating and stressful. In the meantime I'm doing disk to disk backups with time machine.

    Working with Bakbone, Tandberg, and Apple on a solution. None of them want to talk with eachother or escalate the issue (other than Apple). Tandberg says I should have a specific firmware for the HBA which Apple says does not exist. Tandberg had me switch the library to port 0 on the hba otherwise they could not have an engineer look at it... still the same problem.

    Bakbone has looked at logs but doesn't want to have me turn on tracing to log this more thoroughly.

    I will post a solution if one is found... I just wish this would be resolved soon!