Skip navigation
This discussion is archived

Slow internet access on my imac

6445 Views 4 Replies Latest reply: Feb 18, 2009 8:08 AM by Duane RSS
bugsy56 Calculating status...
Currently Being Moderated
Jan 17, 2009 12:35 AM
I have a imac, about a year old, and as of late I've been having really slow internet access. Pages come up slowly in Safari and Firefox. It's usually super slow when I first turn on the computer from sleep mode, and speeds up to painfully slow after a few page views.

Internet access is through a DSL connection connected to a wireless router, but my mac is hardwired to the router. I have a pc laptop which I connect wirelessly to the router and it runs just fine, so I don't think it's the router or the DSL connection. I think it's something with my Mac.

Have others seen this problem? Any fixes?
imac, Mac OS X (10.5.6)
  • Kenichi Watanabe Level 7 Level 7 (29,975 points)
    Currently Being Moderated
    Jan 18, 2009 4:28 PM (in response to bugsy56)
    Is the slowness just with Internet access, or is the iMac generally running slow?

    Either way, you should run +Repair Disk Permissions+ in Disk Utility, if you have not done so recently.

    How much free space do you have on your startup drive?

    Does it seem faster immediately after you do a restart?
    Various including Intel iMac, Power Mac G5, Pismo w/G4, Power Mac 8100 w/G3, Mac OS X (10.5.6), also Mac OS X 10.4.11, Mac OS X 10.3.9, and Mac OS 9.x
  • fxander Calculating status...
    Currently Being Moderated
    Feb 3, 2009 4:04 PM (in response to bugsy56)
    I've been experiencing the same thing lately. It seems to be worse on some sites, and video (Quicktime, Real Player) files play for a few seconds, stop, buffer, start up again, stop, buffer, etc... I'm doing the Repair Permissions now (it's taking a while). Please advise if any other fixes have helped with your situation. Thanks.
    iMac G5, Mac OS X (10.5.5)
  • SuzLewis Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 17, 2009 7:29 PM (in response to bugsy56)
    I'm having the same problem - except my iMac is brand new, just got it last Saturday. I don't think it should be this slow out of the box!!
    iMac, Mac OS X (10.5.6)
  • Duane Level 10 Level 10 (117,955 points)
    Currently Being Moderated
    Feb 18, 2009 8:08 AM (in response to SuzLewis)
    You should visit the Intel-based iMac discussion area instead of this iMac G4 discussion area.
    iMac Alu C2D 2.4 GHz 24" 4GB and 20" 2GB, Mac OS X (10.5.6), iBook G4 14" 1.42 [1.5GB],iBook 466 SE Graphite [576M-40GB],iMac G4 700/768MB

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.