5 Replies Latest reply: Apr 8, 2009 4:08 AM by djr3ll
xpwoppa Level 1 (0 points)
hi.

i'm having an issue with my external hard drive. this morning i went to plug it in since that's where i store all of my music, and for some odd reason it didn't work. i have a feeling it's because the night before i unplugged it without ejecting it. my mistake, i know, but now the drive is all messed up. earlier i was able to view the volumes on it in disk utility, and before deciding to erased anything i plugged it into my sister's dell where i transfered everything on the drive. now, when i plug it in my macbook it only shows up in disk utility without the volumes, it doesn't show up on the dell anymore, and when i go to erase everything it tells me "operation timed out".

i'm at a loss of what to do. i tried restarting the macbook, unplugged the cables... nothing seems to work. i would really like to get the thing back to factory settings if that's possible. so if anyone can offer help, it would be most appreciated. the external drive is a 500GB Maxtor OneTouch

macbook, Mac OS X (10.5)
  • Kappy Level 10 (265,914 points)
    Try this:

    Extended Hard Drive Preparation

    1. Open Disk Utility in your Utilities folder. If you need to reformat your startup volume, then you must boot from your OS X Installer Disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger or Leopard.)

    2. After DU loads select your hard drive (this is the entry with the mfgr.'s ID and size) from the left side list. Note the SMART status of the drive in DU's status area. If it does not say "Verified" then the drive is failing or has failed and will need replacing. SMART info will not be reported on external drives. Otherwise, click on the Partition tab in the DU main window.

    3. Set the number of partitions from the drop down menu (use 1 partition unless you wish to make more.) Set the format type to Mac OS Extended (Journaled.) Click on the Options button, set the partition scheme to GUID (only required for Intel Macs) then click on the OK button. Click on the Partition button and wait until the process has completed.

    4. Select the volume you just created (this is the sub-entry under the drive entry) from the left side list. Click on the Erase tab in the DU main window.

    5. Set the format type to Mac OS Extended (Journaled.) Click on the Options button, check the button for Zero Data and click on OK to return to the Erase window.

    6. Click on the Erase button. The format process can take up to several hours depending upon the drive size.

    If you plan to use this drive on both your Mac and a PC, then format the drive MS-DOS rather than Mac OS Extended.
  • sobarch Level 1 (0 points)
    I am having the same problem with my external hard drive, but even using the partition function with GUID selected, my operation times out. I have tried this on 2 different macs. Any further suggestions?
  • jtlikk Level 1 (0 points)
    I have the exact same problem. I checked the system profiler, disk utility, and even tried to boot from the install CD. I don't know what is the problem, USB ports are working, have my iPod Touch connected while I am typing this. It was working until it showed the device disconnected warning and i tried to re-plug it in an the hard drive does run, but it is not appearing on the desktop, system profiler and disk utility.
  • non genius Level 1 (0 points)
    I have WD too - rang Western Digital (check their website - for time zones - they are based in Singapore) cost is for a local call - they are fantastic sorted out my problem. I'm in Australia...
  • djr3ll Level 1 (0 points)
    Similar problem here. My external(maxtor family III) is firewire connected and partitioned into two drives. One for time machine and the other for music. unmounted drive and shutdown computer at work. came home booted up and drive never showed. later on tried a different external(western digital) and did not show. nothing is in disk utility and wont show anywhere.got any tips