1 2 Previous Next 17 Replies Latest reply: Apr 11, 2009 4:37 PM by Michael Stoffer Go to original post
  • 15. Re: iMac Doesn't Detect Headphones
    Betelgeuse135 Level 1 Level 1 (0 points)
    Awesome. Thanks for the links. I think I may try to verify it's a hardware problem before I open it up (I'm thinking I should use a Linux Live CD and see if headphones work under Linux), but this may prove very useful.
  • 16. Re: iMac Doesn't Detect Headphones
    boarder9 Level 1 Level 1 (0 points)
    I had a similar problem except I have external speakers plugged into the headphone jack. The speakers stopped working after the power was turned off in my house (doing some remodeling). In conjunction, my backup drive also was not being recognized. I thought it might be a problem with the ports so I brought it into the apple store. And of course when they tested it, everything worked. They said that by unplugging everything and then waiting (in my case overnight) it reset itself. Have you tried unplugging everything and then waiting at least a half hour? My speakers didn't work at first, I kept plugging and unplugging them and finally they started working again. My TM backup is sporadic still. I think there is a glitch in the ports. Occasionally my keyboard stops working too.
  • 17. Re: iMac Doesn't Detect Headphones
    Michael Stoffer Level 1 Level 1 (0 points)
    Hi. Same problem here. When plugging in headphones system preferences' sound output selection displays them for second, then jumps back to "Internal Speakers". Also, I cannot setup anything else than internal speakers in Audio MIDI Setup. Thus, internal speakers are always on even if headphones are connected, no red light in the jack when headphones are not in.
    Any idea? Lubing with WD40 didn't help either.
    Thanks a lot...
1 2 Previous Next