8 Replies Latest reply: Feb 15, 2009 9:21 PM by andriesz
[dot]Zac Level 1 Level 1 (5 points)
When I attempt to open a file, one that I had been working on for hours, I might add, Numbers brings up a dialog box that says "The document "Science Fair 2009 Data" is invalid. The index.xml file is missing." Now I had just saved this file maybe 25 minutes before trying to open it, but when I tried to open it, Numbers brought up the dialog box. Also, when using quicklook, the file is viewable just fine (I believe this is due to the fact that the application takes a snapshot of the file and that it was quicklook displays), but can not be opened for editing or printing. Is there any way to recover the file, or revert to it??? Thanks for you help!!!

Aluminum iMac 7,1, Mac OS X (10.5.2), 2 GHz Intel Core 2 Duo 1 GB RAM
  • [dot]Zac Level 1 Level 1 (5 points)
    I attempted to use show package contents, but the option was not there.
  • [dot]Zac Level 1 Level 1 (5 points)
    Tried opening it in iwork 09, worked fine.
  • Level 8 Level 8 (41,780 points)
    Next time, take care of what you do

    By default, Numbers '09 creates files which can't be opened by Numbers '08.
    This feature has two explanations:
    (1) Numbers '09 introduced a lot of features which are ununderstandable for Numbers '08
    (2) the default file format is not a package containing a zipped Index.xml file as it was in Numbers '08, it is a zipped (package containing a non-zipped Index.xml file) whose extension name was changed from zip to pages.
    Replace it by zip and you will be able to unpack it with a double click.
    But given explanation (1), even expanded, Numbers '08 will be unable to open it.

    Yvan KOENIG (from FRANCE dimanche 25 janvier 2009 14:50:19)
  • Randy Zercher Level 1 Level 1 (0 points)
    How do I open the package of a Numbers file? Right-click doesn't work.
  • oakframe_tim Level 1 Level 1 (0 points)
    I have this problem too
    When I swapped to '09 I saved all my documents as '09 versions but whenever I open them the message "The index.xml file is missing" pops up.
    I have checked that my default application for all numbers docs is version 2.0 ('09) - It is.
    I have removed the previous iWork folder from Apps and put it in my Documents folder to try and prevent it opening docs in '08
    It still tries to use '08.
    If I go to 'right click'>'open with' and choose "numbers.app (default) (2)" it succeeds.

    It's as if my computer wants numbers'08 to be the default app even though it shouldn't, and I have told it not to.
  • Level 8 Level 8 (41,780 points)
    oakframe_tim wrote:
    I have this problem too
    When I swapped to '09 I saved all my documents as '09 versions but whenever I open them the message "The index.xml file is missing" pops up.
    I have checked that my default application for all numbers docs is version 2.0 ('09) - It is.
    I have removed the previous iWork folder from Apps and put it in my Documents folder to try and prevent it opening docs in '08


    This will change nothing.

    When I want to disable such an old beast, I copy it in a Disk Image (created from Disk utility)
    So, the operating system is unable to see it if I don't open deliberately the disk image.

    At this time, the system continue to see iWork '08.

    It still tries to use '08.
    If I go to 'right click'>'open with' and choose "numbers.app (default) (2)" it succeeds.
    It's as if my computer wants numbers'08 to be the default app even though it shouldn't, and I have told it not to.


    If you define Numbers '09 as the default program (Apply All) from the 'Infos Window' , it will be used when you double click a doc's icon.

    Yvan KOENIG (from FRANCE mercredi 28 janvier 2009 22:39:47)
  • Level 8 Level 8 (41,780 points)
    Randy Zercher wrote:
    How do I open the package of a Numbers file? Right-click doesn't work.


    If it is an iWork '09 one it's not a package.

    By default, iWork '09 uses a new format.

    old one was made this way:

    create a special kind of folder named 'package'
    save the Index.xml file in it
    compress the Index.xml file with the UNIX tool Gzip
    close the package

    the new default format is made this way:

    create a special kind of folder named 'package'
    save the Index.xml file in it
    close the package
    remove the "Pages" extension
    compress the folder with the UNIX tool Zip
    then rename it from wxyz.zip to wxyz.pages.

    So, to see the internal of a new singlefile created from iWork '09,
    rename it as wxyz.zip
    double click to expand it
    You will get a folder whose contents will be easily examined.
    You may rename it as wxyz.pages.
    iWork '09 will be able to open it but iwork '08 will not because as many features are added, there is a signature which tells to iWork '08: caution, this file is a new one, you can't decipher it.

    Yvan KOENIG (from FRANCE mercredi 28 janvier 2009 22:48:27)
  • andriesz Level 1 Level 1 (0 points)
    using zip decompression and renaming the file works great. Note: the files have to be decompressed into a new folder. Rename that folder and add .pages .

    This fixed my problem. The index file was still there. For some reason saving from iWork08 to 09 cause an error in the container.