11 Replies Latest reply: Feb 25, 2009 8:11 PM by jay1999
Shrooman Level 1 Level 1 (10 points)
Since late December I have noticed horrible download times from Apple TV movies. I am running 12,544 KB/s down with 22ms latency on DSL Reports speed tests. I have had the Apple TV for months and it usually downloads and lets me start watching a movie ( HD or regular) within 30 seconds while it continues to download. Now it is taking 8 hours on random nights. I have reset the router and cable box to no avail when I run into this problem. needless to say, it's most frustrating and not Comcasts fault as I have run extensive tests.

Anyone have info on this recent problem??

apple, Mac OS X (10.5.6)
  • 1. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    John Bailey2 Level 1 Level 1 (25 points)
    I'm experiencing the same problem. I rented a movie last night and it took over three hours just to get to the point where I could start watching it. I'm running Apple TV with Apple's TimeCapsule which was marketed as providing faster downloads although it never took this long with my old Airport Express.

    Very frustrating.
  • 2. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    johnmci Level 1 Level 1 (0 points)
    Same here, in looking it's pulling data from a72-246-51-6.deploy.akamaitechnologies.com
    however it's doing only about 60 packets a second. In the past it would do about 1200 packets a second. At 60 it's come back in 7 hours, at 1200 which it was pre january time frame (and maybe 10 or 20 seconds when starting a download) you could watch the entire movie right away.

    traceroute shows

    traceroute 72.246.51.6
    traceroute to 72.246.51.6 (72.246.51.6), 64 hops max, 40 byte packets
    1 spidercrab (192.168.1.100) 9.708 ms 39.950 ms 93.648 ms
    2 24.108.24.1 (24.108.24.1) 55.959 ms 14.458 ms 21.371 ms
    3 rd1cv-ge3-3-4.gv.shawcable.net (64.59.166.162) 23.770 ms 22.552 ms 15.013 ms
    4 rd2cv-ge1-0-0.gv.shawcable.net (66.163.72.6) 40.287 ms 19.181 ms 16.985 ms
    5 66.163.76.217 (66.163.76.217) 15.806 ms 53.444 ms 32.307 ms
    6 six-sea.netarch.akamai.com (198.32.180.113) 37.049 ms 158.770 ms 22.403 ms
    7 a72-246-51-6.deploy.akamaitechnologies.com (72.246.51.6) 43.221 ms 16.798 ms 56.809 ms

    where 192.168.1.100 is an internal firewall
    24.108.24.1 is the IP assigned by the cable modem
    66.163.76.217 is also owned by shaw

    On a clear day google.com is 13 hops away, versus 72-246-51-6 which seems to sit right close to shaw's servers somewhere.


    ping 72.246.51.6
    PING 72.246.51.6 (72.246.51.6): 56 data bytes
    64 bytes from 72.246.51.6: icmp_seq=0 ttl=59 time=19.498 ms
    64 bytes from 72.246.51.6: icmp_seq=1 ttl=59 time=15.206 ms
    64 bytes from 72.246.51.6: icmp_seq=2 ttl=59 time=22.561 ms
    64 bytes from 72.246.51.6: icmp_seq=3 ttl=59 time=11.973 ms
    64 bytes from 72.246.51.6: icmp_seq=4 ttl=59 time=44.109 ms
    64 bytes from 72.246.51.6: icmp_seq=5 ttl=59 time=12.012 ms

    On a clear day ping of google gives.
    64 bytes from 74.125.45.100: icmp_seq=0 ttl=242 time=116.897 ms
    64 bytes from 74.125.45.100: icmp_seq=1 ttl=242 time=97.186 ms
    64 bytes from 74.125.45.100: icmp_seq=2 ttl=242 time=110.851 ms
    64 bytes from 74.125.45.100: icmp_seq=3 ttl=242 time=98.566 ms
    64 bytes from 74.125.45.100: icmp_seq=4 ttl=242 time=113.079 ms

    so it's at much as 10x long to ping google than 72.246.51.6 which
    tells me the turn around time talking to 72.246.51.6 is very good.

    Therefore I can only assume either akamaitechnologies.com is doing a lousy job, or the AppleTV is funky however it's not as if any software updates occurred.
  • 3. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    Cameron Hopkins Level 1 Level 1 (5 points)
    Sorry nothing to add, other than I've been suffering the same glacial slow down. Even a 30 second preview takes minutes to load. Huge drag
  • 4. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    Hans Van Riet1 Level 1 Level 1 (20 points)
    Didn't notice it before, but I have the same issue. Over four hours to download a HD movie, more than an hour to start the movie. Other internet traffic is great; 10 Mbps.
  • 5. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    Maggot Level 2 Level 2 (185 points)
    Good investigative work, johnmci!

    That seems to be the cuplrit -- and it's affecting anything from download speeds to the amount of time it takes to load 30 second TV Show clips.

    I assumed that because Apple had recently farmed out a percentage of their network delivery chores to Limelight, that they were to blame for the bottleneck. Looks like the difficulty may lie elsewhere after all.
  • 6. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    deraven Level 1 Level 1 (0 points)
    There's a much longer thread about this ongoing slow download problem elsewhere in the forum. Could you guys join us there? People have been pointing Apple Support to it as proof that it's a wide-spread problem so it'd be a good to have as many folks as possible that have the same problem to focus in once place.

    Here's a link to that thread:

    http://discussions.apple.com/thread.jspa?threadID=1838952&tstart=0
  • 7. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    peterAndres Level 1 Level 1 (0 points)
    Ya there is a longer thread - but lets get 2 going.
    My download speeds still suck.
  • 8. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    scotthew Level 1 Level 1 (0 points)
    holy crap - super slow time to watch movies, even though it's telling me movies are upwards of 20% downloaded. FIX IT APPLE.
  • 9. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    Vincent Raicovi Level 1 Level 1 (0 points)
    Same here. In the past, HD rentals would take less than a minute to become playable. I tried to sit down with my daughters to watch a movie and it was only at 16% after an hour tonight. My connection tests out great to all the DSLReports locations...
  • 10. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    Maggot Level 2 Level 2 (185 points)
    Same thing here last night. Another "will be ready to play in 8 hours" message, instead of the usual near-instantaneous "Your movie is ready to watch" message -- which is what I'd always had prior to last December.

    This is rendering my Apple TV pretty much useless for renting movies. I used to be one of its biggest boosters, and have sold at least five of my friends on ATV in the past six months. It's still a great addition to my living room, but it's completely undependable when it comes to renting a movie. What a shame.
  • 11. Re: Apple TV agonizingly slow downloads since Dec 08-Jan 09.
    jay1999 Level 1 Level 1 (0 points)
    yeah kinda disappointed, got one for my birthday and last night go to watch a movie and took 3 hours to get it going and then couldn't finish it. My old cable tv system did a better job. Plus i'm in Canada where anchor man is in the top 10 downloads! Wasn't that out like 5 years ago. Terrible selection.