Previous 1 2 3 4 Next 86 Replies Latest reply: Aug 31, 2009 9:03 PM by Mike Connelly Go to original post
  • planoBob Level 1 (0 points)
    Don't know what others have to put in the directory path field, but for my hosting account, I have two web sites, each with a different name. In other FTP clients, I must provide some variation of a unix path (relative or rooted) to be able to ensure that the client places the the right web site contents in the right location. I'd expect that on some other systems, your default directory on login might be the correct place already and there would be no need to enter anything.

    I hope that makes sense.

    Robert
  • RRoman Level 1 (0 points)
    Was on the phone with Apple last night and they believe the problem is with Windows servers. They are investigating and will post fix soon.... At least that's what they told me.
  • chipmunk6 Level 1 (0 points)
    No, the problem isn't with windows servers, it's a bug. I might be to do with how it handles those servers but I doubt it.

    B
    U
    G
  • Roddy Level 6 (17,265 points)
    You're not stuck with a hosting company because of a domain name registration. Simply sign up with a new one and get it redirected.
    Although I'm not going to use the built in FTP because of all the downsides, I have tested it and it works on my server whether I fill in the Directory/Path or not.
    This is because Host Excellence allows you to create your own folder on the server and name it the same as the one produced by iWeb. This overcomes the limitations of the way in which the iWeb FTP works.
  • planoBob Level 1 (0 points)
    Not for my case ... pair networks (my hosting company) uses unix systems. Apple support is very wrong and that's because the developers aren't being brought in on this soon enough. I know some folks have fixed their problems with a switch to a linux platform from windows, but that's likely only because they have changed the destination server causing a keychain change which I suspect is the critical link.
  • Viktor.Karlsson Level 1 (0 points)
    Regarding "Windows problem" there is a simple way to reply to that lame excuse. Try publishing with sftp to your own OS X. Test works, but when actually publishing the very elaborate "unknown error". I've managed to make iWeb simply crash on me when trying different ways as well. This was the key feature for updating for me, hope a patch is out soon.
  • Steffen Bendix Level 1 (40 points)
    I've just found out that the issue of error 530 "authentication failed" has something to do with the form of the password. If you use other characters than letters and numbers, some servers seem to have problems with it. Try to change your password at your webhoster that it is a combination of letters and numbers.

    Steffen
  • planoBob Level 1 (0 points)
    When I sniffed the FTP packets, for my case, I found that iWeb wasn't sending a password for the publish operation, just for the test. My solution was to open key chain access and delete the existing keychain entry and then add it again through iWeb.
  • planoBob Level 1 (0 points)
    I've found that if I remove the directory/path, the tool can publish to the "current directory" fine ... it just doesn't know how to handle a provided alternate directory.
  • William Huisking1 Level 1 (15 points)
    I followed this thread and found how how my host needs the form filled in. I tested it and it works!!!!!!
    In the FTP server settings under Directory/Path: I put in the website name only! I did not include www. or ftp:// or http:/ JUST the name of the website. In my case, my website is www.huisking.net and all I put in was huisking.net
    Hopefully this works for you. By the way, Bruce S was great on the 1/2 time show that just ended...
    Skip
  • Deborah Shadovitz Level 1 (0 points)
    To be clear for everyone, the ftp part NEVER belongs in path/directory. The FTP part goes in the first field to get to the server. Apple gives you the gray example. The path/directory is ONLY the part after the .com text. You begin with the "/" and list anything up til and including the folder/directory in which you want your site to land.
  • William Huisking1 Level 1 (15 points)
    In my case, what I plugged in to the Path/Directory box was my hosted website name which included the .com and what was before the .com. It did work as my test website was published.
    Skip
  • Dav-o Level 1 (0 points)
    I had the same problem, generally. Test worked, publish failed. So I tried some of the suggestions listed in this discussion. I changed my ftp password to start with a number, all lower case letters, no special characters. I deleted the keychain listing, and I only listed my domain (in iWeb's ftp setup) as "mydomain.com" - no www, no http://

    It worked.

    One slight hiccup - even though I only changed one or two pages, I had to upload the entire site, so it took a while, but the site works. I am hoping that was only for the first upload using iWeb 09.
  • Viktor.Karlsson Level 1 (0 points)
    Yay, a patch was released. But did it help? Nope. This is getting silly, I can publish fine to a folder, testing (sftp to the very same machine) works fine but "unknown error" when publishing over (s)ftp.

    I guess I'll try to go through the steps (again) in this discussion when I get home but really this 100% reproducible bug should be fixed.
  • kgirls Level 1 (30 points)
    After reading numerous posts about FTP not working I am posting a screenshot of my settings for FTP '09 which has been working perfectly for me. Perhaps this will help:
    http://www.geistphotography.net/Geist_Photography/iWebFTP.html

    I did not use iWeb '08 because it did not have FTP and used DreamWeaver. From being a DreamWeaver user I have been very impressed at what iWeb '09 can do.
Previous 1 2 3 4 Next