Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Aug 31, 2009 9:03 PM by Mike Connelly Go to original post
  • planoBob Level 1 Level 1 (0 points)
    Glad to hear someone getting some success. That doesn't fix my problem where the login directory isn't right on top of the publish directory. I end up having to put in a longer, multi-part, path such as: /usr/www/users/xxxxxxxx/my-website

    The publish action did a change directory to "/usr/www/users" where it tried to get a listing and got permission denied. That is expected, but it should have changed to the full path before doing anything.

    Oh well ... I hope Apple folks are listening.

    Robert
  • Kalyman Level 1 Level 1 (0 points)
    I can concur with the switch from windows hosting server to linux server.
    I have godaddy.com hosting and I just completed the switch from windows hosting server to linux and now its uploading my changes as I type this post.

    Initial error was "unable to write to server" no matter what I changed. But after the switch was completed, it immediately connected and completed the test connection and now its about 50% completed with updates of my web site.

    There is a definite bug with iWeb and Windows servers. I really hope Apple fixes this quickly.
    Don't waste your time trying to correct this on your own(I regret the hours I dumped into this). Unfortunately we have to wait for Apple to fix it now.
  • cteufert Level 1 Level 1 (0 points)
    I purchased iLife specifically to be able to upload iWeb created sites more easily, of course that is exactly what isn't happening.

    I have been maintaining the web site with iWeb 08, publishing to a folder then upload using Fetch.

    iWeb 09, says the test works but the upload fails anyway. Publishing to a folder and using Fetch works -- the various files iWeb creates seem to be fine, it is only the upload that fails.

    I created a new very simple web site and was able to publish it with iWeb 09 -- the ftp upload can work. I added more pages and it continued to work. I went and tried the real site it failed. That is when I noticed one web album page name had a blank space in it. I changed the space to an '_' and was able to upload just fine.

    What is strange is when I exported to a folder and uploaded using Fetch it was fine with the space. Only when uploading with the internal FTP is it a problem. Clearly a bug in how iWeb's FTP handles either file or folder names with spaces.

    Happier, but not thrilled having to rename pages and have the '_" appear in menus displayed on the web site.

    Charlie.
  • cteufert Level 1 Level 1 (0 points)
    Forgot to mention... another test I did.

    I created an account on another Mac, enabled file sharing, etc to allow FTP publishing locally. iWeb has the same problem uploading a page with a space in the name to another Mac running OSX. I suspect the solutions involving Windows Hosting vs. Linux Hosting is only part of the problem. If iWeb can't upload to either a Windows based server and a Mac running straight OSX exactly what was iWeb tested with?

    Charlie.
  • EWAN SMITH Level 1 Level 1 (0 points)
    I'm no tech master but it seems to be different things work depending your sites server! If you use Namesco (UK) the change your site name in the menu to Web and leave the path/directory empty.
    This works as Nameco uses a file name web to publish from! So it you call your site eg MySite.com then it will make a folder of the same name... an then your stuffed!

    Hope this helps,

    Cheers!
  • Roddy Level 6 Level 6 (17,265 points)
    Different servers work in different ways.
    Apple licensed the FTP software from a very reputable developer whose system works flawlessly.
    It appears to be the implementation of this software by the iWeb development team that is not so flawless.
    I guess we, the users are the unpaid testers!
  • Barry Rickert1 Level 1 Level 1 (5 points)
    Did not work for me.
  • Barry Rickert1 Level 1 Level 1 (5 points)
    sorry to inform you but I use GoDaddy Linux and I have tried most every option posted here and it fails to complete the upload. I am back to folders.
  • Jason Libas Level 1 Level 1 (5 points)
    Are there any shared-server Media Temple users out there who've had any luck? I've tried everything. Not too web savvy... but did know to check the settings I have, for example, in CyberDuck. This hasn't helped.

    With iWeb '08, I was publishing to folder and dropping into CyberDuck "mainwebsite_html" folder, and I'm noticing that this folder might be an alias(?) +folder-with-arrow icon,+ versus a plain folder... still not clear where my site is ACTUALLY being stored if this is in fact an alias... Any case, putting "/home/ mysitename /mainwebsite_html" in the directory/path: does not work (test connection FAILS), and if I leave it blank or try anything else it publishes to the wrong folder.

    Any help would be GREATLY appreciated.

    —j.
  • Francis Moran Level 1 Level 1 (0 points)
    Same here. I have a Godaddy Linux server as my host and I can't publish.

    Test Works. Publish Fails.

    iWeb 09 = fail.


    =|
  • Barry Rickert1 Level 1 Level 1 (5 points)
    I cannot tell you what I did but it is now working with GoDaddy fine. FTP from iWeb seems to work great.
    I had been using a wrong setting. Apple makes this confusing too. If you use the "Visit Website" it will always take to you to a wrong location. Even though the FTP is correct.
    Try no Dir/path folder even though you might think they want that folder name as to where you are putting your files.
    I am hosting 10 websites from one GoDaddy account. The site name is what is critical. That should be the name of the folder you are uploading to.

    Say you site is HammerAlley.com
    The folder you use on GoDaddy is Hammer
    Then the site name should be hammer not hammeralley or hammeralley.com

    Good luck
  • Roddy Level 6 Level 6 (17,265 points)
    This has been the case from day one. If your server allows you to name the folder the same as your iWeb site folder it works.

    I tested this with Host Excellence immediately I got iWeb '09 and had no problems.
    This doesn't appear to be the case with servers that force you to upload to a pre named folder.

    I reverted to publishing to a local folder and uploading using FTP for my own reasons.
    Apple is now advising you to do the same if you are having problems.
  • angryshortguy Level 1 Level 1 (0 points)
    Same problem.
    Initial upload worked, subsequent uploads fail.
    It's a bug. My provider is not the problem. Windows servers are not the problem.
    iWeb is the problem and Apple needs to fix this asap or recall this product with a full refund.

    That's not even the biggest bug.
    Only Safari can view my page.
    IE and Firefox are unable to view it properly or at all.
    What a joke. What a waste of time. What a waste of money.
  • Barry Rickert1 Level 1 Level 1 (5 points)
    GoDaddy users: I have the solution. I have 8 sites all hosted from one host account.

    The key is you must have a separate FTP login for each website. In the past I would just use the root. Now, each site has its own.

    Examples:
    iWeb document name:memorialslive
    Site Name: meorialslive
    Server address: studiobuzz.biz
    User name: memorialslive
    Directory/Path: BLANK

    URL://www.memorialslive.com

    =================
    iWeb document name:ministrieslive
    Site Name: ministrieslive
    Server address: studiobuzz.biz
    User name: ministrieslive
    Directory/Path: BLANK

    URL://www.ministrieslive.com


    Etc.

    What is also great is that the visit button now works too.

    All is good. Apple is once again vindicated.
  • Roddy Level 6 Level 6 (17,265 points)
    This is what I have been doing for years with Host Excellence.
    I have 20+ sites in one account but each is in a folder with the same name as the site in iWeb.
    When uploading, the only variables I have to deal with are Parent Site folder name and Server Address number.
    Because I use Web Site Maestro to optimize and upload, all these settings are in the upload preferences so that all I need to do is launch the application, select the site I want to upload, turn on Smart Handling and the changed files only are optimized and uploaded.
    Once you have it set up it is almost as easy as one click publishing. The only difference is that, because the files are now optimized, they have a chance of displaying in IE.