Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Aug 31, 2009 9:03 PM by Mike Connelly Go to original post
  • Austin_Kevin Level 1 Level 1 (0 points)
    I still cannot publish my iWeb to my own hosting - godaddy - says write error on the test. Can you e-mail me or give me a # or something if you have the cure? I can send over my settings here or in private so maybe you can knock me on the right path. It is Windows hostin...heck, I'll put it here like you did:

    iWeb document name: ? Just called iWeb in the menu bar
    Site Name: TheTechShack
    Server address: ftp.thetechshack.com
    User name: thetechshack
    Directory/Path:

    URL: http://www.thetechshack.com

    You can answer my questions here or e-mail me at:
    kevin@thetechshack.com

    I appreciate any help you can provide. Apple help is not helpful when you put in the errors. You'd think they'd have a great help section so no one has to write or call them.
  • Steffen Bendix Level 1 Level 1 (40 points)
    Have you checked and "simplified" your password, yet? It worked for me.
  • Austin_Kevin Level 1 Level 1 (0 points)
    I see no option to do that. I looking in all the iWeb settings that I can find.
    Still says, "Unable to write to server."
    If I can get this working and it is not an Apple error I'll be so happy!
  • Steffen Bendix Level 1 Level 1 (40 points)
    Austin_Kevin wrote:
    I see no option to do that. I looking in all the iWeb settings that I can find.


    Just change your password for your ftp-account to a more simple one. That means, it should consist only of letters and numbers (in any combination). Then use this password in iWeb. As I mentioned, this worked for me.

    Steffen
  • Austin_Kevin Level 1 Level 1 (0 points)
    I got it now. I already have it to a fairly simple one. The thing that really bugs me is that it is perfect in CuteFTP. I hate uploading folders as my sites are so big with a lot of media and there are a lot of errors uploading that way.

    I'm on the phone with godaddy right now.
  • Barry Rickert1 Level 1 Level 1 (5 points)
    iWeb document name: ? Just called iWeb in the menu bar
    Site Name: thetechshack [no caps - change your iWeb Site]
    Server address: thetechshack.com
    User name: thetechshack
    Directory/Path:

    URL: http://www.thetechshack.com

    You can answer my questions here or e-mail me.
    <Edited by Moderator>

    An you are sure your ftp is exactly the same?



    Try the above changes.
  • Austin_Kevin Level 1 Level 1 (0 points)
    Same. I just talked to Godaddy and we tried 2 different ftp clients that work perfectly.
    I did what some suggested:
    I'm trying the Linux route. We'll see in 1-3 days.
  • Steffen Bendix Level 1 Level 1 (40 points)
    During my tests I found out that the issue may have something to do with file permissions. I have several webhosters and publishing with iWeb always fails with hosters, where I can't set the file permission with a ftp-program like Transmit, Fetch or FileZilla. I get the error number -142 (chmod failed) or 550 (permission denied). It depends on the ftp-program I use. Although iWeb tells that publishing failed, the website is partially uploaded but non-functional.

    Steffen
  • Barry Rickert1 Level 1 Level 1 (5 points)
    I made an assumption that I should not have forgotten to tell you.

    This does work but you must change your server name with GoDaddy and create a folder for each different URL that you host.

    GoDaddy may tell you that your main URL is the root level. NO!
    You want it to be in a folder too.

    I had the host server name as studiobuz.biz which is the same as my URL. But the GoDaddy support person walked me though changing my host name to BMRShine.net. Then we simply created a folder for hosting my studiobuz.biz website.

    Then the other thing that I think some of your are still not getting, You must have a different ftp log-in for each website.

    In the past you could go to any web via your root. That will not work.

    So, call GoDaddy and tell them you want to change the host nameserver to something. It is does not have to be a valid URL infact choose something that is not likely to be one.

    Then setup new ftp uploading users, one for each URL.
  • goldilocks& Level 1 Level 1 (0 points)
    Exactly the same, though after the first attempt neither worked. The server domain is not Windows, it works publishing to a folder then using either Cyberduck or Filezilla to upload but when applying the same settings with iWeb09 it cannot connect and at the same time locks me out of my domain login as it reaches the login attempt limit and there is no way to stop or watch that progress in iWeb; the result is contacting my isp each time to unblock the login.

    I did try all the above, no luck. So waiting for a fix.
  • Barry Rickert1 Level 1 Level 1 (5 points)
    I don't use Windows Server but my guess is that you are trying to use your root level for uploads.

    That will not work.

    See my other posts on this.
  • Barry Rickert1 Level 1 Level 1 (5 points)
    It appears the assumption I made about needing separate ftp log-ins was wrong.
    The directory/path works fine. So you can use your main host servername as long as it has its own folder on the root level.

    I have verified that. Thanks to thetechshack feedback.
  • Austin_Kevin Level 1 Level 1 (0 points)
    Thank you for the kudos. Here is what happened and the fix for now, although not a good fix in my opinion:

    OMG. Really? I switched from Windows server to Linux and it works perfectly. This for sure means Apple needs to fix this. Could it be a prejudice against MS? I know I don't like the company but my goodness, this is not good for us and creats a feeling of false advertising as their ads, keynotes and everything on their web sites do not say you need to have a .me account or Linux.
    Well for now I am happy as it works, but not many love MS and if this is their way of sticking it to them to a degree, it is hurting us, the loyal fans.

    I know it does not sound like it but Apple is everything and one of the best companys out there and I am 100% loyal to them, but when they make a mistake they need to fix it, as in the past they usually do. Hire more programmers to work on OS X, their apps, not just for the iPhone. It seems everything is put on hold at times for the iPhone, I just hope they stop losing sight of the computers, Apple TV and all their other SW/HW products.

    Still loving Apple more than 99.9% of the world,

    Kevin @ The Tech Shack dot com
  • NSXG5 Level 1 Level 1 (0 points)
    I have the same exact problem. All my settings are correct. Username and Password. When I publish to my FTP host site (lunarpages: linux server) It tries to upload but it fails and then my host blocks my IP address and I no longer can use any of my web services including e-mail which becomes very annoying. Then I have to call them every time to unblock my IP address!

    I can use any other FTP client like transmit or cyberduck and I have never had any problems establishing a connection. The built-in FTP client in iweb is horrible! This is sad because it would be such a convenient feature to have.

    It doesn't make sense that the test connection works, but the actual site upload publish fails!

    Apple really needs to fix this issue soon.

    Message was edited by: NSXG5

    Message was edited by: NSXG5
  • mkayes Level 1 Level 1 (0 points)
    I can publish via iWeb 09's own FTP is the hosting server is Unix based, however if a Windows hosting service then it fails with permission errors - I guess I need passive FTP, will investigate further...