Skip navigation
This discussion is archived

iWeb 09 ftp publishing error - Test works, publish fails

29473 Views 86 Replies Latest reply: Aug 31, 2009 9:03 PM by Mike Connelly RSS
  • Barry Rickert1 Calculating status...
    Tell you what. Get and the email me you are ready send me your account username and your password.

    I can do this today. Maybe we can sort this out. After we are done you can change the pw or remove logmein.

    Best i can do
    Mac OS X (10.4.1)
  • Roddy Level 6 Level 6 (17,255 points)
    Most hosting companies will help you switch from Windows to Linux. If yours doesn't, switch to one that does.
    I don't know how you have the patience to deal with a 90 MB site. When mine get to about a quarter of that size I divide them into sections on separate domain files and link them with a custom main navigation menu.
    This one is built on ten domain files and counting...
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • Nate Parker Level 1 Level 1 (10 points)
    I'm getting the same issue here myself. My corp website publishes fine to MobileMe, and one of my clients who's using VodaHost works perfectly. However, my client that has Hostway is not working.

    Test works fine.

    When I publish to FTP without adding any directory, it publishes fine, but publishes it to the wrong place and won't show up online.

    When I add the directory name (/home/www/familylegalpro/) (it's on Linux), I get the publish error.

    I called Hostway and they're baffled.

    Does anyone know what I can do to get this working? I'd like to get out from Publish to Folder.

    Also, I've seen that some people are having issues with GoDaddy accounts. I'm just about to design another website for I client & I recommended Windows GoDaddy hosting to them. Would this work or should we sign them up for a different plan. They're unable to use MobileMe.


    Nathan Parker

    Mallard Computer, Inc.
    15" MacBook Pro (Late 2008), 12" PowerBook G4 (Early 2006), Mac OS X (10.5.6), MobileMe Member, ADC Member, AppleCare Member (MacBook Pro)
  • Roddy Level 6 Level 6 (17,255 points)
    I publish to Host Excellence using Linux.

    The advantage of this hosting company is that they let you create your own folder and name it the same as the one produced by iWeb.

    This means that I can leave the box for Directory/Path empty and it publishes fine. If I enter the correct directory/path that I use in my FTP application, Yummy FTP, and in Web Site Maestro, it fails to publish.
    Another tremendous achievement for the iWeb development geniuses. What fun I have working round their screw ups.

    The iWeb FTP it is absolutely useless to me as I need to optimize my website files so that they will download on a PC running IE. I also need to be found in search engines and to upload assets for flash as I don't use QuickTime for music, and the iWeb Albums and Photos templates are a dead loss.

    In conclusion, if you use a Linux platform with Host Excellence, upload to a folder with the same name as the one produced by iWeb and leave the Directory/Path blank, then the iWeb FTP will work.

    GoDaddy is a buzz word in this forum but, personally, I wouldn't use any hosting company that can't solve my problems. I have advised a lot of people to switch to Host Excellence and I don't think any of them regret it.

    I could write a long dissertation on the reasons not to publish to MobileMe for any type of website. To use it to publish a business website is masochistic.
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • Barry Rickert1 Level 1 Level 1 (5 points)
    Sounds like you have a good handle on this. But your degradation of GoDaddy is just not so.

    I for one got great help from GoDaddy on this issue. Furthermore, I would rate their tech support as a 9.

    I used to use APlus and moved as I could not stand the oversees telephone support language issue.

    I bought Maestro for iWeb. It is also no big deal for me to use Transmit to upload but I don't like the FTP upload built into Maestro.

    But, because I add code to my pages, I like the ability to upload quickly to view and make changes. So, I used both methods on several sites of mine.

    Never used Host Excellence. If it works, don't mess with it.
    Mac OS X (10.4.1)
  • Roddy Level 6 Level 6 (17,255 points)
    I'm not degrading GoDaddy. I'm just observing that the average reader of this forum would get the impression that it's the only way to purchase a domain name and publish a site.

    The built in FTP is WSM is useful for uploading changes once you have published your whole site and are able to use "smart handling" thereafter.

    When I first publish a site, I optimize only and then upload with Yummy FTP which I also use to mange my folders on the server side and upload folders of MP3s, flash files and player assets.

    I switched to flash for playing music and displaying photos a couple of years ago as not enough PC users have Quicktime and the iWeb Albums and Photos templates create huge files which tend to lock up IE.
    iMac 24, Mac OS X (10.5.6), 4GB Ram
  • Newmanity Level 1 Level 1 (0 points)
    Argh! How frustrating is this? I've tried just about every troubleshooting on here to no avail, and I'm sure my host is Linux.

    So I have been playing around with all the settings and it seems I can get the first upload to work, and then after that, I might be able to get an upload to work, but usually not. Once it doesn't work anymore, it's kaput.

    - First upload works
    - Subsequent small tweak uploads work
    - If it asks "directory already exists - replace?" you're as good as dead.

    Can you just delete the directory on the server and reupload? It appears not! I just used Filezilla (which I love for FTP now, btw) to delete the directory on the server, then recreated the directory on the server. When I uploaded again, it got the usual error.

    So I just created another directory, but a new-new one this time. Guess what - it didn't work either.

    I'm thoroughly confused and frustrated.

    Is it a password issue or a permissions issue? Either way, it seems like an easy enough fix. Be nice if Apple could tell us what - we might be able to work around it in the short term. Of course I've never seen them finish a thread with "hey this is how its fixed..."

    Thanks to everyone for sharing...
    Macbook Pro, Mac OS X (10.5.6)
  • pakarang Calculating status...
    When is APPLE going to stop ignoring this problem and come up with an update fixing whatever bug they have in the new iWEB FTP upload menu? Are they just playing the waiting game hoping we all get tired of it and leave them alone?

    When we buy something, it should be working, and if not, they should make it work for all of us. This does not put Apple in a good light at all.

    Disappointed customer. No. VERY disappointed customer.

    iMAC 24" 2.4 GhZ Intel Core 2 Duo 3GB 667 Mhz DDR2 SDRAM, Mac OS X (10.5.6)
  • ckckckck Calculating status...
    Hi planoBob,

    Did you ever get this to work? I'm having exactly the same issues, also using

    Macbook Pro, Mac OS X (10.5.7)
  • BLUEFISHMAC Calculating status...
    Had the same problem publishing to a Go Daddy hosted domain. Followed the FAQ recommendations for settings for iWeb09 on the Go Daddy site and the test connection worked successfully but the upload got an error message.

    Reading below, looked like the password was not being sent when publishing Vs testing. I left the password field blank in the FTP server settings section and hit the publish button in the toolbar below in the iWeb browser. This prompted an enter password box to appear on the screen. Filled in the password and the site was published without an issue.

    Hope this helps everyone and that Apple fixes this bug!
    G5 Quad, Mac OS X (10.5.7)
  • Mike Connelly Level 4 Level 4 (1,785 points)
    I'm also looking for a solution for - I'm having the usual test works, upload fails. I can get it to upload, but it refuses to use the proper path. Anyone figure this out with pair, or is it going to take iWeb '10 to get a fix for this?
    Power Mac G5 quad 2.5 and Mini duo 1.66, Mac OS X (10.5.8)
1 2 3 4 5 6 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.