14 Replies Latest reply: Feb 26, 2009 5:13 PM by luvlabs
Itouched badly Level 1 Level 1 (0 points)
I have a Belkin F5D6231-4 that supports WEP mode 64 bit manually. I current have 3 pcs and an Xbox connected wirelessly to it. I have a 10 digit numeric wep key that I know that works on the pc. On a pc, I have disconnected and reconnect to test the wep key, which we'll call 1234567890 for now.

I just received my Ipod Touch, which recognizes the network, and have tried entering in the wep key a multitude of methods. I have tried "1234567890", 1234567890, #1234567890, $1234567890 all of which give me the popup "Incorrect password for "SSID".

From there I ignored the recognized network and have manually selected Other, entered in the name, security type and wep key. All to no avail. I have also tried to reset network settings.

Touch version is 2.2 (5G77a), model MB528LL.

Any and all help would be appreciated, I though Apple was supposed to be easy!


Windows XP
  • Itouched badly Level 1 Level 1 (0 points)
    It seems that after reviewing the internet, the Apple network is plaqued with problems connecting to wep networks. Many posts have no answers, if you're a frustrated itouch user post here.

    My router key entry is set to 64 bit - manually and has 5 boxes with 2 charactures each. I even tried to use hex values like 31 31 31 31 31 (which translates into ascii as 11111) and then enter the 5 ascii values without success. I love the interface but I'd like to have the guy in the commerical stop by my house and fix this.
  • GraceTurner Level 1 Level 1 (0 points)
    I'm having pretty much the same problem on my brand new iPod touch. Except, I'm using WPA2 personal, and instead of saying the password is wrong it justs says it's unable to connect.
    I've tried all day...
    I feel like throwing the thing out the window.
  • tridimensional Level 1 Level 1 (0 points)
    Wifi on touch 2nd Gen its a mess!
    Complain with Apple!

    Very frustrating!!!
  • Itouched badly Level 1 Level 1 (0 points)
    Update, I found if I remove security it will connect, so it is a definate compatibility issue between the Itouch and WEP as both will work without each other. I plan on calling Apple and staying on the line forever until they figure this thing out. Will keep you informed.
  • luvlabs Level 4 Level 4 (3,610 points)
    Can you set 128 bit WEP on your router? Try that and enter the hexidecimal key when you log in.

    A better alternative, if your router allows it, is to use WPA or WPA2 encryption. It's easier to implement, more secure, and you only need to create and remember a password.

    Whatever you use, make sure your Touch log in matches the encryption your router uses. If your router is WPA2 and your Touch is looking for WEP, it's not going to work.
  • stooge2990 Level 1 Level 1 (0 points)
    I have a Linksys BEFW11S4 and a Belkin F5D6231-4! Same problem with the Linksys and then I put the Belkin in. Wasted 10 hours troubleshooting it.

    64 bit WEP encryption never worked on the IPOD TOUCH and was
    never implemented in it! DO NOT USE 64 BIT WEP on your IPOD!!
    128 bit WEP is supposed to work. I sent the IPOD TOUCH back to APPLE in Califormia. Fortunately they are very quick and I got it back today. They told me nothing was wrong with it.

    Hmmm? It worked fine in NON-ENCRYPTED mode with both routers!
    Niether cable router worked in 128 BIT WEP encryption mode.
    I downloaded the new Belkin firmware and it still did not work.
    Spent hours trying to make it work.
    Took my old Linksys modem and up dated the firmware on it, and re-installed it.
    WOW! Just as I was about to try entering the 26 character hexidecimal key the phone rang. It was my Apple technician calling back to respond to my phone mail. He waited while I re-entered my hex key then V'oila the check mark appeared to the left of the SSID name of my network and I knew I was connected.
    But, wait, selecting "WEATHER" the Ipod It went into download mode, but never succeeded in getting the data from the router.
    My router is in the basement. I went down there and while standing next to the router, the ipod got the download just fine
    The Ipod works fine in my computer room upstairs as long as the WEP is shut off.
    With WEP turned on I have to be within feet of the router for it to work.
    Could this be signal strength or intereference?
    Stay tuned sports fans as I intend to be back with an answer when I waste another day on this aggrivating problem.
  • deggie Level 9 Level 9 (51,745 points)
    Since WEP is pretty lame as far as security anyway why don't you switch to WPA?
  • luvlabs Level 4 Level 4 (3,610 points)
    You might want to power cycle your router. That often clears up connection issues like you are having. Your touch isn't as robust on WiFi as a laptop is.

    To all of you WEP encryption fans...

    I don't use WEP personally as it is not really a very secure encryption method. However, iPod touches and iPhones do not do well on 64 bit WEP. You either need to crank it up to 128 bit or switch to WPA/WPA2. As to entering your network key, I believe you need to enter it as a hex number, ie. A3:11:E4: etc. 123456789 is not hex, for example. Your router generates the hex number, use it as it is displayed in your router control panel.
  • stooge2990 Level 1 Level 1 (0 points)
    Thank you all responders, but LISTEN---- some routers, like ours, can ONLY do WEP encryption--- so suggesting some other method is of NO help!
    All of us now know that 64 bit WEP was never meant to work with the IPOD touch.
    128 bit WEP was implemented in the touch so should work fine.
    Yesterday I found that my Belkin F5D6231-4 cable router:
    1. Will not work with WEP encryption with my IPOD TOUCH!(at any distance)
    2. It works fine with the IPOD with no encryption from distance.
    3. Works fine with 128 bit encryption to my Linksys WPS54GU2 print server at distance.

    LINKSYS BEFW11S4 after installing new firmware
    1. Now works somewhat(with the IPOD)with new firmware.
    2. Now shows a connect to the Ipod touch at distance, but will not transfer data reliably.
    3. Connects and works with the Ipod at distance with no WEP encryption.
    4. Connects and transfers data reliably with encryption if you get it withing 2 feet of the Linksys router!
    5. Linksys router connects and talks with 128 bit wep to my Linksys WPS54GU2 wireless print server at distance.

    (when I say "at distance" I mean 30-40 feet).

    I suggest Apple look into my findings which are thus.
    Stay away from a Belkin if you use 128 bit WEP and an IPOD.
    My IPOD may have a weak radio in it. (even though Apple just tested it, at their California repair facility, and said it was working right.)
    Someone is selling equipment with flakey software? MAYBE EVERYONE?
  • luvlabs Level 4 Level 4 (3,610 points)
    I would not blame your Belkin router or your Touch. Obviously you need to replace the Belkin router with one that is actually up to date with what is being used in the wireless world. The fact is that router is an 802.11b router explains a lot of your problems. Mode b routers have the shortest range and lowest throughput of any of the wireless routers.

    You can get a perfectly good mode g router for $40 or less. My suggestion is that you replace your router as soon as you can.
  • stooge2990 Level 1 Level 1 (0 points)
    Thanks Luvlabs- there is more to report!!!!!!
    the techs at Belkin have been giving me links that take me to "FIRMWARE ****."
    "Firmware ****" is a place with the wrong files and firmware for the wrong type of router.
    There are no firmware up dates for my router on that site. There is a void of information concerning the F5D6231-4 Ver. 2000 router. I guess someone finally just got tired of all my constant pestering and complaining because I was given an RMA today and a free upgrade router. My old router is in the mail heading for silicon valley? I should have the new one next week. I believe I deserve it because of the lifetime of hours we have expended on this problem.
    Now I need to limber up Linksys about the strange connection problemI still have with the BEFW11S4
    1. It talks with 2 laptops and a desktop and a print server wirelessly with WEP 128 bit encryption with no problems at distances of 25 to 40 feet through at least 1 concrete block wall.
    2. It talks to all of those and the IPOD at the same range with NO WEP encoding.
    3. With 128 bit WEP turned on, the IPOD knows it connects (25 to 40 feet away)from the router, (because the check mark appears to the left of the SSID name) but data transfer is almost non existant. I have to move the IPOD just about 2 feet from the router to get good data transfer. Go figure! I will present the problem to Linksys and see what they suggest.
    More to follow in the great WEP-IPOD mystery problem.
  • kayakguy Level 1 Level 1 (0 points)
    I've sometimes had trouble connecting with my touch - it always turned out to be an issue with the router (D-Link). My MacBook Pro does not have issues but both a Toshiba and Dell notebook do at times. I upgraded to an Apple router, and also borrowed one for the road. Both work great on all Macs and PCs + iTouch. On the road other people have no trouble with the Apple Router but often do with another D-Link I had. Other name brand routers I've used in the past worked selectively. I even bought a D-Link n router and have to recycle the power occasionally. Otherwise it transmits well.

    Bottom line is this: the router is your point of contact, get a good one. Apple makes the best I've come across.
  • stooge2990 Level 1 Level 1 (0 points)
    Thanks for the entry- I hope others are following my epic story.
    Concerning my conversation with Linksys about mt BEFW11S4: Linksys insulates itself from email questions and when on-line you can't complain.
    I called their voice line and the tech ignored my complaint that the IPOD was factory tested and is the only piece of wireless equipment that did not work with 128 bit WEP encryption. The lady told me that IPODS only work with WEP-A encryption and if you own an old router like mine it is worthless as they don't support it anymore.
    All in all I got a better shake out of Belkin. They seem to care. Now I have a collection of PCI adapters and printer servers that are not useable. Ebay here I come.
  • luvlabs Level 4 Level 4 (3,610 points)

    Glad you are on the path to upgrading your network. It will make a big difference with all of your devices. Since you are getting a new router, use WPA or WPA2 encryption this time around.